Bug 869075 - The sysconfig.txt file advises users to use a command that fails with an error
Summary: The sysconfig.txt file advises users to use a command that fails with an error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 881827 957109 957111
TreeView+ depends on / blocked
 
Reported: 2012-10-23 00:01 UTC by Jaromir Hradilek
Modified: 2016-11-25 13:02 UTC (History)
4 users (show)

Fixed In Version: initscripts-9.03.34-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: Sysconfig.txt advised calling saslauthd -a instead of -v Consequence: Command fails with error Fix: Replace -a with -v in Sysconfig.txt Result: Command returns expected results
Clone Of:
: 957109 957111 (view as bug list)
Environment:
Last Closed: 2013-02-21 10:26:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0518 normal SHIPPED_LIVE initscripts bug fix and enhancement update 2013-02-20 21:29:01 UTC

Description Jaromir Hradilek 2012-10-23 00:01:09 UTC
Description of problem:
In the description of the /etc/sysconfig/saslauthd configuration file, the /usr/share/doc/initscripts-9.03.27/sysconfig.txt file advises users to run the “saslauthd -a” command to display a list of available authentication mechanisms. However, an attempt to run this command fails with an error, because the “-a” command line option requires an additional argument. Note that both the saslauthd(8) manual page and the configuration file itself recommend the use of the “saslauthd -v” command for this purpose.

Version-Release number of selected component (if applicable):
initscripts-9.03.31-2.el6.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Read the /usr/share/doc/initscripts-9.03.27/sysconfig.txt file to learn about available options in the /etc/sysconfig/saslauthd configuration file.
2. Attempt to run the “saslauthd -a” command to display available authentication mechanisms as advised in the description of the /etc/sysconfig/saslauthd file.
3. See an error message followed by usage information.
  
Actual results:
The description of the /etc/sysconfig/saslauthd configuration file advises users to use a command that fails with an error.

Expected results:
The description of the /etc/sysconfig/saslauthd configuration file should advise users to use a command that displays required information without an error (that is, the “saslauthd -v” command).

Additional info:
Reproduced on Red Hat Enterprise Linux Server release 6.3 (Santiago).

Comment 7 errata-xmlrpc 2013-02-21 10:26:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0518.html


Note You need to log in before you can comment on or make changes to this bug.