Bug 869079 - RFE: Please add functionality to view expired pastes
RFE: Please add functionality to view expired pastes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sticky-notes (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Athmane Madjoudj
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 20:55 EDT by Ankur Sinha (FranciscoD)
Modified: 2012-10-23 17:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 17:37:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ankur Sinha (FranciscoD) 2012-10-22 20:55:54 EDT
The current sticky-notes server does not appear to have the ability to show expired pastes. Is it possible to add this functionality please? It isn't something that's used frequently, but it does come in handy at times.
Comment 1 Clint Savage 2012-10-22 21:00:21 EDT
I'm not sure I can see a valuable use case for this feature. Can we come up with any?
Comment 2 Adam Williamson 2012-10-22 21:19:06 EDT
I've used it multiple times with fpaste: people often leave the timeout very short (as is the default with both the current implementation and sticky-notes) and then I happen to see a conversation or bug report a day and a half later, and want to see what was going on. It's not the kind of thing I have specific instances of right to hand, but I've definitely used this lots of times. Hell, I've had to refer to my *own* pastes beyond the expiry date before.
Comment 3 Adam Williamson 2012-10-22 21:20:05 EDT
it's not unknown for people to put fpaste links in ML posts and even bug reports...I know they can't stick around forever, but in practice, in fpaste, the 're-use cycle' seems to be rather long and you can often see pastes from at least weeks ago.
Comment 4 Clint Savage 2012-10-22 22:16:51 EDT
I can see that usage as valuable. What if we put the default to be somewhere between 3 days and 1 week? I'm sure it is possible to do something like that.

I also want to note that sticky-notes does provide a 'Forever' option, which we might want to remove and set to something like '1 year/6 months' instead.
Comment 5 Athmane Madjoudj 2012-10-23 06:14:56 EDT
So to be clear, we're talking about the current instance of sticky-notes (paste.stg.f.o) or the app itself.

We can have 1mo or 1yr as default or Forever but the second choose will impact the performance as the pastes table will grow rapidly.
Comment 6 Adam Williamson 2012-10-23 13:23:43 EDT
A default of 1 week and no 'forever' option might hit the sweet spot, I guess.
Comment 7 Athmane Madjoudj 2012-10-23 17:32:48 EDT
Hi Adam,

(In reply to comment #6)
> A default of 1 week and no 'forever' option might hit the sweet spot, I
> guess.

It set to 1 month (see my reply on test list).
Comment 8 Athmane Madjoudj 2012-10-23 17:37:15 EDT
If you have issue with paste.stg please fill a ticket in infrastructure trac[1], I'll be happy to look.

[1] https://fedorahosted.org/fedora-infrastructure/

Thanks everyone.

Note You need to log in before you can comment on or make changes to this bug.