Bug 8691 - rup <arg> host1 host2 ... hostN doesn't sort by <arg>
Summary: rup <arg> host1 host2 ... hostN doesn't sort by <arg>
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rusers (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-21 08:02 UTC by James Baum
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-21 08:29:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Baum 2000-01-21 08:02:54 UTC
rup(1) ignores the arguments -h, -l and -t (sort by hostname, load or
uptime) if it is given a list of hostnames. It doesn't sort at all then,
but just uses the list in the order given.
Only tested on x86, but I presume that applies to all platforms.

rpm -qvf `which rup`
rusers-0.15-6

Comment 1 james.baum 2000-01-21 08:29:59 UTC
Hmm, looks like a buglet in bugzilla as well.
My original short title was:
"rup <arg> host1 host2 ... hostN doesn't sort by <arg>"
 or to put it in html:
"rup &lt;arg&gt; host1 host2 ... hostN doesn't sort by &lt;arg&gt;"
Html problem...

Main point:
rup -h gamma beta alpha

should return
alpha up ...
beta  up ...
gamma up ...

but it returns
gamma up ...
beta  up ...
alpha up ...

Comment 2 Phil Knirsch 2001-06-06 13:04:10 UTC
This is not a bug. It simply processes the command line args in the order that
they were given, which is the expected behaviour.
If you need ordering simply use a pipe:

rup <arg> host1 host2 ... hostN | sort

which should return the wanted ordered list.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.