Bug 869103 - ValueError: need more than 1 value to unpack
ValueError: need more than 1 value to unpack
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
abrt_hash:a5b94180083d737185f430d339e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 23:17 EDT by Reartes Guillermo
Modified: 2013-01-01 12:22 EST (History)
5 users (show)

See Also:
Fixed In Version: anaconda-18.20-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 00:54:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (205.20 KB, text/plain)
2012-10-22 23:17 EDT, Reartes Guillermo
no flags Details
File: product (6 bytes, text/plain)
2012-10-22 23:17 EDT, Reartes Guillermo
no flags Details
File: type (9 bytes, text/plain)
2012-10-22 23:17 EDT, Reartes Guillermo
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-10-22 23:18 EDT, Reartes Guillermo
no flags Details
File: storage.log (71.95 KB, text/plain)
2012-10-22 23:18 EDT, Reartes Guillermo
no flags Details
File: version (11 bytes, text/plain)
2012-10-22 23:18 EDT, Reartes Guillermo
no flags Details
File: environ (780 bytes, text/plain)
2012-10-22 23:18 EDT, Reartes Guillermo
no flags Details
File: anaconda.log (3.60 KB, text/plain)
2012-10-22 23:18 EDT, Reartes Guillermo
no flags Details
File: syslog (61.75 KB, text/plain)
2012-10-22 23:18 EDT, Reartes Guillermo
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-22 23:18 EDT, Reartes Guillermo
no flags Details
File: packaging.log (2.38 KB, text/plain)
2012-10-22 23:18 EDT, Reartes Guillermo
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-10-22 23:18 EDT, Reartes Guillermo
no flags Details
File: release (24 bytes, text/plain)
2012-10-22 23:18 EDT, Reartes Guillermo
no flags Details
File: program.log (34.08 KB, text/plain)
2012-10-22 23:18 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-22 23:17:44 EDT
Description of problem:
switched INSTALLATION SOURCE to NFS and set 192.168.0.80 and then returned to the main hub.

Version-Release number of selected component:
anaconda-18.19

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.19 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 499, in apply
:    (self.data.method.server, self.data.method.dir) = url.split(":", 2)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 108, in _runSpoke
:    action.apply()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 323, in _on_spoke_clicked
:    self._runSpoke(spoke)
:ValueError: need more than 1 value to unpack
Comment 1 Reartes Guillermo 2012-10-22 23:17:55 EDT
Created attachment 631863 [details]
File: anaconda-tb
Comment 2 Reartes Guillermo 2012-10-22 23:17:57 EDT
Created attachment 631864 [details]
File: product
Comment 3 Reartes Guillermo 2012-10-22 23:17:59 EDT
Created attachment 631865 [details]
File: type
Comment 4 Reartes Guillermo 2012-10-22 23:18:01 EDT
Created attachment 631866 [details]
File: ifcfg.log
Comment 5 Reartes Guillermo 2012-10-22 23:18:05 EDT
Created attachment 631867 [details]
File: storage.log
Comment 6 Reartes Guillermo 2012-10-22 23:18:08 EDT
Created attachment 631868 [details]
File: version
Comment 7 Reartes Guillermo 2012-10-22 23:18:10 EDT
Created attachment 631869 [details]
File: environ
Comment 8 Reartes Guillermo 2012-10-22 23:18:12 EDT
Created attachment 631870 [details]
File: anaconda.log
Comment 9 Reartes Guillermo 2012-10-22 23:18:15 EDT
Created attachment 631871 [details]
File: syslog
Comment 10 Reartes Guillermo 2012-10-22 23:18:18 EDT
Created attachment 631872 [details]
File: hashmarkername
Comment 11 Reartes Guillermo 2012-10-22 23:18:20 EDT
Created attachment 631873 [details]
File: packaging.log
Comment 12 Reartes Guillermo 2012-10-22 23:18:22 EDT
Created attachment 631874 [details]
File: cmdline_file
Comment 13 Reartes Guillermo 2012-10-22 23:18:25 EDT
Created attachment 631875 [details]
File: release
Comment 14 Reartes Guillermo 2012-10-22 23:18:27 EDT
Created attachment 631876 [details]
File: program.log
Comment 15 Adam Williamson 2012-11-23 00:54:47 EST
In TC9 (tested this rather than RC1 as there's known NFS regressions in RC1) this doesn't crash, but it just sorta silently reverts to 'Closest Mirror' rather than throwing any kind of error. Still, the crash is fixed.
Comment 16 Steve Tyler 2013-01-01 12:22:33 EST
Since this bug is closed as fixed, I opened a new one with the same traceback, but a different reproducer -- enter "foo::/mnt/bar" for the NFS source:
Bug 891091 - ValueError: too many values to unpack

Note You need to log in before you can comment on or make changes to this bug.