Bug 869106 - F18 anaconda chokes on wireless network names containing spaces
F18 anaconda chokes on wireless network names containing spaces
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-10-23 00:12 EDT by Tom Lane
Modified: 2013-07-02 23:46 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-18.23-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 04:35:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Lane 2012-10-23 00:12:01 EDT
Description of problem:
When trying to connect to a wireless network whose name contains spaces, anaconda is inconsistent about replacing the spaces with underscores.  This leads to a crash with the following traceback:

anaconda 18.19 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/simpleconfig.py", line 77, in read
    with open(filename) as f:
  File "/usr/lib64/python2.7/site-packages/pyanaconda/simpleconfig.py", line 187, in read
    SimpleConfigFile.read(self, self.path)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 285, in loadIfcfgFile
    IfcfgFile.read(self)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1060, in getKSNetworkData
    device_cfg.loadIfcfgFile()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1013, in apply
    network_data = getKSNetworkData(dev)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 72, in _on_continue_clicked
    self.apply()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 77, in <lambda>
    self.window.connect("continue-clicked", lambda *args: self._on_continue_clicked(cb))
IOError: [Errno 2] No such file or directory: '/etc/sysconfig/network-scripts/ifcfg-L-K Airport Net'

Local variables in innermost frame:
self: 
filename: /etc/sysconfig/network-scripts/ifcfg-L-K Airport Net

Now, "L-K Airport Net" is the actual name of the network I want to connect to.  But a look into /etc/sysconfig/network-scripts/ shows that the file that was
created during the network config step is
/etc/sysconfig/network-scripts/ifcfg-L-K_Airport_Net

Version-Release number of selected component (if applicable):
anaconda 18.19 (F18 Beta TC6 compose)

How reproducible:
100%

Steps to Reproduce:
1.  Configure anaconda to use a wireless net whose name contains spaces (note that as of 18.19 there are various sub-bugs you have to dodge to get this far, see bug #855526)
2. Try to continue to hub screen

Additional info:
I've been using this network name for ten years or so, and it's worked fine with many previous Fedora releases.  Something broke recently here.
Comment 1 Kamil Páral 2012-10-23 09:16:30 EDT
Proposing as F18 Final Blocker, probably using some criterion like:
 The installer must be able to use at least one of the HTTP or FTP remote package source options 
(as used in bug 855526)
Comment 2 Radek Vykydal 2012-10-29 09:02:55 EDT
Patch sent to mailing list, updates image to check the fix:
http://rvykydal.fedorapeople.org/updates.ifcfgspaced.img
(you need wired connection to get the updates image)
Comment 3 Adam Williamson 2012-10-29 13:21:52 EDT
In theory we could argue this as a Beta blocker. But in an entirely unscientific survey, none of the 30+ APs I can see from my apartment has a space in the SSID. So I'm not _hugely_ worried about it.

Proposing as NTH for Beta.
Comment 4 Adam Williamson 2012-10-31 15:34:57 EDT
Discussed at 2012-10-31 NTH review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-31/f18beta-blocker-review-6.2012-10-31-16.00.log.txt . Accepted as NTH as this is obviously pretty inconvenient for those with APs with spaces in the SSID, and could be hard or impossible to work around.
Comment 5 Fedora Update System 2012-10-31 22:52:37 EDT
anaconda-18.22-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.22-1.fc18
Comment 6 Radek Vykydal 2012-11-01 07:31:50 EDT
The fix in 18.22 is bad, it is causing traceback after visitnig network spoke without selecting any wireless ap.
Comment 7 Fedora Update System 2012-11-01 14:28:34 EDT
Package anaconda-18.22-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.22-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17432/anaconda-18.22-1.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-11-02 00:05:01 EDT
anaconda-18.23-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.23-1.fc18
Comment 9 Fedora Update System 2012-11-02 21:04:32 EDT
anaconda-18.24-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.24-1.fc18
Comment 10 Tom Lane 2012-11-04 11:45:50 EST
Works for me now in Beta-TC7.
Comment 11 Fedora Update System 2012-11-05 20:39:42 EST
anaconda-18.25-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.25-1.fc18
Comment 12 Fedora Update System 2012-11-06 21:11:38 EST
anaconda-18.26-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.26-1.fc18
Comment 13 Adam Williamson 2012-11-08 04:35:43 EST
18.26 went stable. Closing. (Bodhi closing of bugs when updates go stable is currently broken).

Note You need to log in before you can comment on or make changes to this bug.