Bug 869151 - gucharmap draws character grid off-center vertically, sometimes obscuring first row of glyphs
gucharmap draws character grid off-center vertically, sometimes obscuring fir...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gucharmap (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 03:17 EDT by "FeRD" (Frank Dana)
Modified: 2013-09-17 16:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-17 16:20:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Illustration of the grid-placement issue as it relates to block & window size. (2.80 MB, video/ogg)
2012-10-23 03:17 EDT, "FeRD" (Frank Dana)
no flags Details

  None (edit)
Description "FeRD" (Frank Dana) 2012-10-23 03:17:08 EDT
Created attachment 631904 [details]
Illustration of the grid-placement issue as it relates to block & window size.

Description of problem:
When the character grid does not fill the window (such as when a Unicode character block containing few characters is selected), gucharmap draws the table grid too high within its enclosing frame, pushing the first row of glyphs up out of view. The amount of this offset increases as the amount of empty space in the grid area increases relative to total space, and if large enough it will completely obscure the first row of glyphs.

Version-Release number of selected component (if applicable):
gucharmap-3.4.1.1-2.fc17.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Select a block in gucharmap with few members, such as "Box Drawing"
2. Reduce the point size to a reasonably small value, say 10 or 12
3. Resize the window to increase its vertical dimensions
  
Actual results:
The first grid row in the character table will move upwards as the window length increases, eventually disappearing from view.


Expected results:
The character grid is unaffected by window size.


Additional info:
I've recorded a screencast which clearly illustrates the issue and its relationship to window size (empty grid space); it's 2.9MB, so assuming the system accepts attachments that large it'll be included.
Comment 1 "FeRD" (Frank Dana) 2012-10-23 03:34:13 EDT
The screencast attachement did upload, but it has to be downloaded to be viewed. Since that's a bit annoying, I also tossed a copy in my public Dropbox. If you visit this URL, it'll play in-browser using Dropbox's video player.

https://dl.dropbox.com/u/1031979/bugs/gucharmap-gridbug.ogv
Comment 2 "FeRD" (Frank Dana) 2013-02-15 09:11:19 EST
Note that this bug still exists unchanged in the latest gucharmap-3.6.1-1.fc18.x86_64, in Fedora 18.
Comment 3 "FeRD" (Frank Dana) 2013-09-17 16:20:40 EDT
At some point this issue cleared up, it's no longer occurring in the current gucharmap-3.8.2-1.fc19.x86_64 package for Fedora 19. Closing.

Note You need to log in before you can comment on or make changes to this bug.