Bug 869171 - KickstartValueError: The following problem occurred on line 4 of the kickstart file: Specified unpartitioned disk vda in partition command
KickstartValueError: The following problem occurred on line 4 of the kickstar...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:24ab2cecaa31f1bf6084c8eff98...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 04:02 EDT by Jan ONDREJ
Modified: 2012-10-23 10:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 10:28:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda.log (2.54 KB, text/plain)
2012-10-23 04:02 EDT, Jan ONDREJ
no flags Details
File: packaging.log (3.52 KB, text/plain)
2012-10-23 04:02 EDT, Jan ONDREJ
no flags Details
File: environ (891 bytes, text/plain)
2012-10-23 04:02 EDT, Jan ONDREJ
no flags Details
File: anaconda-tb (341.15 KB, text/plain)
2012-10-23 04:02 EDT, Jan ONDREJ
no flags Details
File: version (2 bytes, text/plain)
2012-10-23 04:02 EDT, Jan ONDREJ
no flags Details
File: salstar.ks (404 bytes, text/plain)
2012-10-23 04:02 EDT, Jan ONDREJ
no flags Details
File: product (6 bytes, text/plain)
2012-10-23 04:02 EDT, Jan ONDREJ
no flags Details
File: release (24 bytes, text/plain)
2012-10-23 04:02 EDT, Jan ONDREJ
no flags Details
File: storage.log (443.43 KB, text/plain)
2012-10-23 04:02 EDT, Jan ONDREJ
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-23 04:02 EDT, Jan ONDREJ
no flags Details
File: ks.cfg (13.52 KB, text/plain)
2012-10-23 04:02 EDT, Jan ONDREJ
no flags Details
File: syslog (57.17 KB, text/plain)
2012-10-23 04:03 EDT, Jan ONDREJ
no flags Details
File: program.log (102.90 KB, text/plain)
2012-10-23 04:03 EDT, Jan ONDREJ
no flags Details
File: cmdline_file (246 bytes, text/plain)
2012-10-23 04:03 EDT, Jan ONDREJ
no flags Details
File: type (9 bytes, text/plain)
2012-10-23 04:03 EDT, Jan ONDREJ
no flags Details

  None (edit)
Description Jan ONDREJ 2012-10-23 04:02:15 EDT
Description of problem:
Installation using my kickstart file. Curious, that I don't defined "clearpart --none" but it's displayed in anaconda-tb log file.

Version-Release number of selected component:
anaconda-18.14

Additional info:
libreport version: 2.0.16
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.2-2.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.14 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1015, in execute
:    raise KickstartValueError, formatErrorMsg(self.lineno, msg="Specified unpartitioned disk %s in partition command" % self.disk)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 863, in execute
:    p.execute(storage, ksdata, instClass)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1558, in doKickstartStorage
:    ksdata.partition.execute(storage, ksdata, instClass)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 379, in _doExecute
:    doKickstartStorage(self.storage, self.data, self.instclass)
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 87, in run
:    threading.Thread.run(self, *args, **kwargs)
:KickstartValueError: The following problem occurred on line 4 of the kickstart file:
:
:Specified unpartitioned disk vda in partition command
:
Comment 1 Jan ONDREJ 2012-10-23 04:02:19 EDT
Created attachment 631917 [details]
File: anaconda.log
Comment 2 Jan ONDREJ 2012-10-23 04:02:22 EDT
Created attachment 631918 [details]
File: packaging.log
Comment 3 Jan ONDREJ 2012-10-23 04:02:26 EDT
Created attachment 631919 [details]
File: environ
Comment 4 Jan ONDREJ 2012-10-23 04:02:33 EDT
Created attachment 631920 [details]
File: anaconda-tb
Comment 5 Jan ONDREJ 2012-10-23 04:02:35 EDT
Created attachment 631921 [details]
File: version
Comment 6 Jan ONDREJ 2012-10-23 04:02:43 EDT
Created attachment 631922 [details]
File: salstar.ks
Comment 7 Jan ONDREJ 2012-10-23 04:02:46 EDT
Created attachment 631923 [details]
File: product
Comment 8 Jan ONDREJ 2012-10-23 04:02:48 EDT
Created attachment 631924 [details]
File: release
Comment 9 Jan ONDREJ 2012-10-23 04:02:54 EDT
Created attachment 631925 [details]
File: storage.log
Comment 10 Jan ONDREJ 2012-10-23 04:02:56 EDT
Created attachment 631926 [details]
File: hashmarkername
Comment 11 Jan ONDREJ 2012-10-23 04:02:58 EDT
Created attachment 631927 [details]
File: ks.cfg
Comment 12 Jan ONDREJ 2012-10-23 04:03:00 EDT
Created attachment 631928 [details]
File: syslog
Comment 13 Jan ONDREJ 2012-10-23 04:03:03 EDT
Created attachment 631929 [details]
File: program.log
Comment 14 Jan ONDREJ 2012-10-23 04:03:06 EDT
Created attachment 631930 [details]
File: cmdline_file
Comment 15 Jan ONDREJ 2012-10-23 04:03:08 EDT
Created attachment 631931 [details]
File: type
Comment 16 Jan ONDREJ 2012-10-23 04:21:23 EDT
Unable to reproduce with 18-Beta-TC6. Which one is newer? If TC6 is newer than current development images, just close this as fixed.
Comment 17 Chris Lumens 2012-10-23 10:28:43 EDT
I believe TC6 is somewhere up around anaconda-18.19, which is definitely much newer than what gave your traceback.

Note You need to log in before you can comment on or make changes to this bug.