Bug 869179 - libguestfs fail to startup on latest rhel7 tree
libguestfs fail to startup on latest rhel7 tree
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 04:20 EDT by Mohua Li
Modified: 2014-06-17 21:58 EDT (History)
5 users (show)

See Also:
Fixed In Version: libguestfs-1.22.2-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:57:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohua Li 2012-10-23 04:20:19 EDT
Description of problem:
libguestfs-1.18.1-1.2.el7.x86_64 fail to work on RHEL7 latest tree( RHEL-7.
0-20121012.1), error as below,=20

# guestfish -N fs
guestfish: error while loading shared libraries: libpcre.so.0: cannot open 
shared object file: No such file or directory

manually create a link to libpcre.so.0 could fix this problem, but libguestfs still stuck at  creating the appliance, not sure if it's "-machine" break libguestfs, at least libguestfs-1.18.1-1.2.el7.x86_64 could work on earlier rhel7 tree, 

[root@intel-i7-12-4 tmp]# guestfish -x -v -N fs
libguestfs: trace: set_verbose true
libguestfs: trace: set_verbose = 0
libguestfs: trace: is_config
libguestfs: trace: is_config = 1
libguestfs: trace: set_pgroup true
libguestfs: trace: set_pgroup = 0
libguestfs: trace: add_drive "test1.img"
libguestfs: trace: add_drive = 0
libguestfs: trace: is_config
libguestfs: trace: is_config = 1
libguestfs: trace: launch
libguestfs: [00000ms] febootstrap-supermin-helper --verbose -f checksum '/usr/lib64/guestfs/supermin.d' x86_64
supermin helper [00000ms] whitelist = (not specified), host_cpu = x86_64, kernel = (null), initrd = (null), appliance = (null)
supermin helper [00000ms] inputs[0] = /usr/lib64/guestfs/supermin.d
checking modpath /lib/modules/3.6.0-0.28.el7.x86_64 is a directory
picked vmlinuz-3.6.0-0.28.el7.x86_64 because modpath /lib/modules/3.6.0-0.28.el7.x86_64 exists
supermin helper [00000ms] finished creating kernel
supermin helper [00000ms] visiting /usr/lib64/guestfs/supermin.d
supermin helper [00000ms] visiting /usr/lib64/guestfs/supermin.d/base.img
supermin helper [00000ms] visiting /usr/lib64/guestfs/supermin.d/daemon.img
supermin helper [00000ms] visiting /usr/lib64/guestfs/supermin.d/hostfiles
supermin helper [00024ms] visiting /usr/lib64/guestfs/supermin.d/init.img
supermin helper [00024ms] adding kernel modules
supermin helper [00097ms] finished creating appliance
libguestfs: [00101ms] begin testing qemu features
libguestfs: [00126ms] finished testing qemu features
libguestfs: accept_from_daemon: 0x1fadf30 g->state = 1
[00127ms] /usr/bin/qemu-kvm \
    -global virtio-blk-pci.scsi=off \
    -nodefconfig \
    -nodefaults \
    -nographic \
    -drive file=test1.img,if=virtio \
    -machine accel=kvm:tcg \
    -m 500 \
    -no-reboot \
    -no-hpet \
    -device virtio-serial \
    -serial stdio \
    -chardev socket,path=/tmp/libguestfsBA3yRE/guestfsd.sock,id=channel0 \
    -device virtserialport,chardev=channel0,name=org.libguestfs.channel.0 \
    -kernel /var/tmp/.guestfs-0/kernel.16720 \
    -initrd /var/tmp/.guestfs-0/initrd.16720 \
    -append 'panic=1 console=ttyS0 udevtimeout=300 no_timer_check acpi=off printk.time=1 cgroup_disable=memory selinux=0 guestfs_verbose=1 TERM=screen ' \
    -drive file=/var/tmp/.guestfs-0/root.16720,snapshot=on,if=virtio,cache=unsafe


Version-Release number of selected component (if applicable):
qemu-kvm-1.2-0.6.20120806git3e430569.1.el7.x86_64
kernel-3.6.0-0.28.el7.x86_64
libguestfs-1.18.1-1.2.el7.x86_64


How reproducible:
always

Steps to Reproduce:
1. guestfish -x -v -N fs ( you must have qemu-kvm-system installed on rhel7 system) 
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Richard W.M. Jones 2012-10-23 04:38:54 EDT
What is libguestfs-1.18.1-1.2.el7?

Anyway, yes, libguestfs is broken in RHEL 7.  We're still
rapidly developing the features for RHEL 7 in Fedora 18 at
the moment, and don't expect to finish that before the end
of this year.
Comment 11 Richard W.M. Jones 2013-07-18 12:54:32 EDT
Works for me in 1.22.2, with SELinux enforcing.
Comment 13 bfan 2014-01-08 21:57:57 EST
Verified with libguestfs-1.22.6-17.el7.x86_64

# guestfish -N fs

Welcome to guestfish, the guest filesystem shell for
editing virtual machine filesystems and disk images.

Type: 'help' for help on commands
      'man' to read the manual
      'quit' to quit the shell

><fs>
Comment 14 Ludek Smid 2014-06-13 08:57:09 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.