Bug 869193 - virt-manager can't add unix and pty type channel to guest
virt-manager can't add unix and pty type channel to guest
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-virtinst (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Giuseppe Scrivano
Virtualization Bugs
:
Depends On:
Blocks: 1038912
  Show dependency treegraph
 
Reported: 2012-10-23 04:54 EDT by hongming
Modified: 2014-04-04 07:58 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1038912 (view as bug list)
Environment:
Last Closed: 2014-04-04 07:58:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hongming 2012-10-23 04:54:36 EDT
Description of problem:
virt-manager can't add unix and pty  type channel to guest. virt-manager GUI only can add spicevmc channel.

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-15.el6.x86_64 

How reproducible:
100% 

Steps to Reproduce:
1. Open virt-manager, make sure a good guest is in shutdown status

2. Open guest details page, Click Add Hardware - > Channel ,  There is only one item in Device Type combox  in Channel Device panel. 
  
Actual results:
virt-manager can't add unix and pty  type channel to guest


Expected results:
virt-manager can add unix and pty  type channel to guest.


Additional info:
Comment 3 Tomoki Sekiyama 2013-08-08 18:24:01 EDT
Now the patch to fix this problem is merged into upstream tree.
(commit 419b34bb2e60c54d3258c01d9d05a288c47649f2)
Comment 4 Giuseppe Scrivano 2014-04-04 07:58:04 EDT
the upstream commit 419b34bb2e60c54d3258c01d9d05a288c47649f2 is not enough to get this feature working in rhel-6.6.  Since it depends from other bits and that this is not a bug but a RFE, I am going to close it.

Note You need to log in before you can comment on or make changes to this bug.