Bug 869197 - Errai CDI examples - Importing of all projects to the JBDS is impossible due to parsing error in the parent pom.xml
Errai CDI examples - Importing of all projects to the JBDS is impossible due ...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Examples, Errai (Show other bugs)
2.1.0
Unspecified Unspecified
unspecified Severity high
: CR1
: 2.1.0
Assigned To: Karel Piwko
Stefan Miklosovic
errai-example
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 05:02 EDT by Stefan Miklosovic
Modified: 2015-08-02 19:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 10:34:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error while parsing the parent pom.xml (527 bytes, text/plain)
2012-10-23 05:04 EDT, Stefan Miklosovic
no flags Details

  None (edit)
Description Stefan Miklosovic 2012-10-23 05:02:44 EDT
Description of problem:
While trying to import all projects to JBDS in the CDI example suite of Errai example distribution as an existing Maven project, it is impossible to do so because of the parsing error in the parent pom.xml where all projects are added as modules. 

Version-Release number of selected component (if applicable):
jboss-wfk-2.1.0.ER2/demo/errai-2.1.0.Final-redhat-1/cdi-examples

How reproducible:
Always unless the version tag in the parent pom.xml is commented out.

Steps to Reproduce:
Do not import an CDI project individually, try to import them all at once by importing the parent directory where parent pom.xml is present.

Please see attachment in orded to see the error.
  
Actual results:
Impossibility of importing the whole Errai CDI example suite via JBDS.

Expected results:
The opposite of actual results.

Additional info:
Comment 1 Stefan Miklosovic 2012-10-23 05:04:07 EDT
Created attachment 631975 [details]
Error while parsing the parent pom.xml
Comment 2 Pavel SLegr 2012-10-23 09:14:44 EDT
Errai CDI demos parent.pom after verification didn't show up as invalid, as well as effective pom were ok.
However the plugin managment configuration in cdi demos parent pom caused the problem with examples import into JBDS - out of box... therefore plugin management was slightly modified to fix the issue.

fixed with: http://git.app.eng.bos.redhat.com/?p=errai/errai.git;a=commit;h=b8fa989a1c42b6ce573f687e3aa325042be23b94
Comment 3 Stefan Miklosovic 2012-10-23 09:18:50 EDT
I verify Pavel's fix has solved the issue.
Comment 4 Pavel SLegr 2012-10-23 09:23:26 EDT
changed Status back to:ON_DEV .. as target is CR01 and QA does not have CR01 release... :)
Stefan thanks for pre-verification for this issue, however there is need to verify this on CR01 release once it reaches QA
thanks !
Comment 7 Karel Piwko 2012-11-12 08:58:17 EST
Verified in WFK 2.1.0.CR1 using both JBDS 5.0.1 and JBDS 6.0.0.Beta1
Comment 8 Karel Piwko 2012-11-30 10:34:55 EST
Distributed as a part of WFK 2.1.0.GA release.

Note You need to log in before you can comment on or make changes to this bug.