Bug 869222 - [Libvirt] - libvirt in deadlock while trying to destroy qemu process while it can't communicate with its monitor socket
[Libvirt] - libvirt in deadlock while trying to destroy qemu process while it...
Status: CLOSED DUPLICATE of bug 859712
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Libvirt Maintainers
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 06:22 EDT by David Botzer
Modified: 2014-01-13 19:04 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 06:36:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
VDS-logs (201.33 KB, application/x-gzip)
2012-10-23 06:22 EDT, David Botzer
no flags Details
qemu-cmd (2.30 KB, text/plain)
2012-10-23 06:24 EDT, David Botzer
no flags Details
libvirt-debug (20.28 KB, text/plain)
2012-10-23 06:24 EDT, David Botzer
no flags Details
engine-logs-just-in-case (219.15 KB, application/x-gzip)
2012-10-23 06:24 EDT, David Botzer
no flags Details

  None (edit)
Description David Botzer 2012-10-23 06:22:40 EDT
Created attachment 632013 [details]
VDS-logs

Description of problem:
libvirt in deadlock while trying to destroy qemu process while it can't communicate with its monitor socket

Version-Release number of selected component (if applicable):
3.1/si21
====
libvirt-lock-sanlock-0.9.10-21.el6_3.5.x86_64
libvirt-debuginfo-0.9.10-21.el6_3.5.x86_64
libvirt-python-0.9.10-21.el6_3.5.x86_64
libvirt-0.9.10-21.el6_3.5.x86_64
libvirt-client-0.9.10-21.el6_3.5.x86_64
====
vdsm-python-4.9.6-38.0.el6_3.x86_64
vdsm-4.9.6-38.0.el6_3.x86_64
vdsm-cli-4.9.6-38.0.el6_3.noarch
----

How reproducible:
always

Steps to Reproduce:
1.Installed rhevm+dwh+reports
2.Created setup - DC, Host, Storage(iscsi), vms
3.Changed engine & vds date to 31/12/12
  
Actual results:
All VMs show "Not Responding"
Host CPU jumps to 99%
libvirt in deadlock while trying to destroy qemu process while it can't communicate with its monitor socket

Expected results:
Should recover

Additional info:
logs
Comment 2 David Botzer 2012-10-23 06:24:02 EDT
Created attachment 632014 [details]
qemu-cmd
Comment 3 David Botzer 2012-10-23 06:24:27 EDT
Created attachment 632015 [details]
libvirt-debug
Comment 4 David Botzer 2012-10-23 06:24:56 EDT
Created attachment 632016 [details]
engine-logs-just-in-case
Comment 5 Haim 2012-10-23 06:36:34 EDT

*** This bug has been marked as a duplicate of bug 859712 ***

Note You need to log in before you can comment on or make changes to this bug.