Bug 869233 - Font not set in minimal install
Font not set in minimal install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
:
Depends On: 888721
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 07:06 EDT by Vratislav Podzimek
Modified: 2013-05-29 21:37 EDT (History)
9 users (show)

See Also:
Fixed In Version: anaconda-19.25-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 859867
Environment:
Last Closed: 2013-05-29 21:37:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vratislav Podzimek 2012-10-23 07:06:28 EDT
+++ This bug was initially created as a clone of Bug #859867 +++

Description of problem:

Run an install with the new Fedora 18-Alpha installer. Select a non-standard keyboard, for example Dvorak. Install a minimal install, without a Desktop Environment.

After completing the install the correct keyboard map is not configured at terminal when logging in from a VT.

Version-Release number of selected component (if applicable):

Fedora 18-Alpha

How reproducible:

Every time.

--- Additional comment from stefw@redhat.com on 2012-09-24 05:27:26 EDT ---

Also not set in many other software set installs. /etc/sysconfig/keyboard is blank.

--- Additional comment from vpodzime@redhat.com on 2012-09-24 07:01:57 EDT ---

(In reply to comment #0)
> Description of problem:
> 
> Run an install with the new Fedora 18-Alpha installer. Select a non-standard
> keyboard, for example Dvorak. Install a minimal install, without a Desktop
> Environment.
> 
> After completing the install the correct keyboard map is not configured at
> terminal when logging in from a VT.
Please see bug #837292 for the reason why this is not yet possible.

--- Additional comment from vpodzime@redhat.com on 2012-10-09 05:00:04 EDT ---

Patches for using systemd-localed to convert X layout to VConsole keymap have been posted to anaconda-patches list. Once they are pushed it will be up to systemd-localed to do the conversion right.

--- Additional comment from vpodzime@redhat.com on 2012-10-12 10:18:23 EDT ---

(In reply to comment #3)
> Patches for using systemd-localed to convert X layout to VConsole keymap
> have been posted to anaconda-patches list. Once they are pushed it will be
> up to systemd-localed to do the conversion right.

Pushed.

--- Additional comment from marcosfrm@gmail.com on 2012-10-21 09:13:12 EDT ---

It's working now (F18 Beta TC6). After a minimal install, /etc/vconsole.conf has KEYMAP="br-abnt2" as expected.

Related, the kernel's default console font doesn't have latin characters. Since systemd 194, it doesn't load by default latarcyrheb-sun16 anymore [1]. I need to add FONT="latarcyrheb-sun16" to /etc/vconsole.conf.

[1] http://lists.freedesktop.org/archives/systemd-devel/2012-October/006817.html
Comment 1 Vratislav Podzimek 2012-10-23 07:37:29 EDT
(In reply to comment #0) 
> --- Additional comment from marcosfrm@gmail.com on 2012-10-21 09:13:12 EDT
> ---
> 
> It's working now (F18 Beta TC6). After a minimal install, /etc/vconsole.conf
> has KEYMAP="br-abnt2" as expected.
> 
> Related, the kernel's default console font doesn't have latin characters.
> Since systemd 194, it doesn't load by default latarcyrheb-sun16 anymore [1].
> I need to add FONT="latarcyrheb-sun16" to /etc/vconsole.conf.
> 
> [1]
> http://lists.freedesktop.org/archives/systemd-devel/2012-October/006817.html
From the referenced email:
> If distributions want to continue to default to a
> non-kernel font or key map they should ship a default
> /etc/vconsole.conf with the appropriate contents.

Lennart, do I understand it correctly that Anaconda should now write FONT=latarcyrheb-sun16 to /etc/vconsole.conf ?
Comment 2 Marcos Mello 2012-10-25 11:20:23 EDT
Probably yes with the recent F18 systemd package update:

http://lists.fedoraproject.org/pipermail/scm-commits/2012-October/889150.html

btw, will not this break on F17->F18 upgrade because bug 799401 ?

F17 installs have "SYSFONT=True" on /etc/sysconfig/i18n ...
Comment 3 Karel Volný 2012-12-18 11:39:40 EST
I've just hit this too

> Related, the kernel's default console font doesn't have latin characters.

btw, can the kernel have a font which includes wider character set?
if yes, wouldn't it be better to do the change in kernel?
Comment 4 Marcos Mello 2013-01-06 07:52:46 EST
It's fixed somehow (without FONT= in /etc/vconsole.conf) after F18 final TC4 (didn't test RC1). dracut?
Comment 5 Vratislav Podzimek 2013-01-07 04:42:50 EST
Maybe the problem lies somewhere else, please see bug #889710
Comment 6 Adam Williamson 2013-05-29 21:37:21 EDT
I did a minimal install of F19 Beta, I see FONT="latarcyrheb-sun16" in /etc/vconsole.conf and vconsole.font set on cmdline. I think we can close this.

Note You need to log in before you can comment on or make changes to this bug.