Bug 869268 - notify-send fails as root
notify-send fails as root
Status: CLOSED DUPLICATE of bug 915346
Product: Fedora
Classification: Fedora
Component: libnotify (Show other bugs)
18
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 872540
  Show dependency treegraph
 
Reported: 2012-10-23 08:50 EDT by Marko Myllynen
Modified: 2013-03-01 22:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 872540 (view as bug list)
Environment:
Last Closed: 2013-03-01 22:43:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marko Myllynen 2012-10-23 08:50:49 EDT
Description of problem:
All of the following work on RHEL 6 under GNOME when logged in as "testuser" (meaning that DISPLAY is properly set for each command):

$ notify-send test
$ su -
Password: 
# notify-send test
# su testuser -c "notify-send test"

Only the following work on F17:

$ notify-send test
$ su -
Password: 
# su testuser -c "notify-send test"

But under F18 sending notifications to the desktop user as root with notify-send does not work with either of the commands working on RHEL 6.

Is this to be expected? If yes then what's the recommended way to send notifications to the user as root on F18 instead of notify-send?

Thanks.
Comment 1 Matthias Clasen 2012-11-02 20:40:46 EDT
# su mclasen -c "notify-send test"

works fine here. What error are you seeing ?
Comment 2 Marko Myllynen 2012-11-05 09:30:49 EST
I don't see anything, i.e., no notification, no error, but strace output reveals:

"The name org.freedesktop.Notifications was not provided by any .service files"

And it can be seen also that notification-daemon is not running altough the package is installed. This is on freshly installed F18 + all available updates installed.

Please let me know if you need any additional details or logs. Thanks.
Comment 3 Matthias Clasen 2012-11-05 12:23:24 EST
gnome-shell is providing org.freedesktop.Notifications on the session bus.
Isn't gnome-shell running ?
Comment 4 Marko Myllynen 2012-11-05 15:47:03 EST
(In reply to comment #3)
> gnome-shell is providing org.freedesktop.Notifications on the session bus.
> Isn't gnome-shell running ?

It is. Selected GNOME desktop during installation but no add-ons, then all defaults till the first login to discover that notify-send fails for root but not for the testuser. Putting SELinux in Permissive doesn't help.

Thanks.
Comment 5 Fedora Admin XMLRPC Client 2013-02-24 05:38:01 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Michael Schwendt 2013-02-25 07:52:05 EST
Problem is reproducible with Rawhide (20130224). Haven't checked F18.

All of the following doesn't manage to send any notification:

  $ su -
  Password: 
  # notify-send blubb
  # su mygnomeuser -c "notify-send blubb"
  #

Only the currently logged in GNOME user can send notifications.
Comment 7 Dan Mashal 2013-03-01 22:43:58 EST

*** This bug has been marked as a duplicate of bug 915346 ***

Note You need to log in before you can comment on or make changes to this bug.