Bug 869280 - Review Request: openlmi-networking - CIM provider for network management
Review Request: openlmi-networking - CIM provider for network management
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ales Ledvinka
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-10-23 09:13 EDT by Radek Novacek
Modified: 2016-11-30 19:35 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-12-20 10:47:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
aledvink: fedora‑review+
limburgher: fedora‑cvs+

Attachments (Terms of Use)

  None (edit)
Description Radek Novacek 2012-10-23 09:13:55 EDT
This is a re-review, original name is cura-networking.

Spec URL: http://rnovacek.fedorapeople.org/openlmi-networking.spec
SRPM URL: http://rnovacek.fedorapeople.org/openlmi-networking-0.0.5-1.fc17.src.rpm
Description: openlmi-networking is set of CMPI providers for network management using
Common Information Model (CIM).
Fedora Account System Username: rnovacek
Comment 1 Ales Ledvinka 2012-10-24 05:11:07 EDT
license check and several other review comments fixed in upstream. available in next version.

Package Review

[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated
[ ] = Manual review needed
[m] = Passed manual review
[* ...] = Passed manual review/Review comment
[# ...] = Failed manual review

===== MUST items =====

[x]: Header files in -devel subpackage, if present.
[x]: Package does not contain any libtool archives (.la)
[m]: Package does not contain kernel modules.
[m]: Package contains no static executables.
[x]: Rpath absent or only used for internal libs.
[* invalid review check for cim broker libraries]: Development (unversioned) .so files in -devel subpackage, if present.
     Note: Unversioned so-files in private %_libdir subdirectory (see
     attachment). Verify they are not in ld path.

[m]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[* cmake macro optflags]: %build honors applicable compiler flags or justifies otherwise.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[m]: Package contains no bundled libraries.
[m]: Changelog in prescribed format.
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[m]: Sources contain only permissible code or content.
[x]: Each %files section contains %defattr if rpm < 4.4
[m]: Macros in Summary, %description expandable at SRPM build time.
[m]: Package contains desktop file if it is a GUI application.
[m]: Development files must be in a -devel package
[* filesystem only]: Package requires other packages for directories it uses.
[m]: Package uses nothing in %doc for runtime.
[* impossible to verify -L]: Package is not known to require ExcludeArch.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[m]: Package complies to the Packaging Guidelines
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[m]: Large documentation files are in a -doc subpackage, if required.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[# license of /var/lib/mock/fedora-rawhide-x86_64/root/builddir/build/BUILD/openlmi-networking-0.0.5/src/dbus_wrapper.h (not generated)]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "GPL (v2 or later)", "Unknown or generated". 2 files have unknown
     license. Detailed output of licensecheck in /home/aledvink/rev/869280
[m]: Package consistently uses macro is (instead of hard-coded directory
[x]: Package is named using only allowed ASCII characters.
[m]: Package is named according to the Package Naming Guidelines.
[m]: Package does not generate any conflict.
     Note: Package contains no Conflicts: tag(s)
[x]: Package do not use a name that already exist
[m]: Package obeys FHS, except libexecdir and /usr/target.
[m]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[# package does not own but implies %{_datadir}/%{name}]: Package must own all directories that it creates.
[m]: Package does not own files or directories owned by other packages.
[x]: Package installs properly.
[m]: Package is not relocatable.
[m]: Requires correct, justified where necessary.
[x]: CheckResultdir
[x]: Rpmlint is run on all rpms the build produces.
     Note: No rpmlint messages.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[m]: Spec file is legible and written in American English.
[x]: Spec file name must match the spec package %{name}, in the format
[m]: Package contains systemd file(s) if in need.
[x]: File names are valid UTF-8.
[m]: Useful -debuginfo package or justification otherwise.

===== SHOULD items =====

[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
[m]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[* glib2-devel]: Final provides and requires are sane (rpm -q --provides and rpm -q
[ ]: Package functions as described.
[m]: Latest version is packaged.
[m]: Package does not include license text files separate from upstream.
[x]: The placement of pkgconfig(.pc) files are correct.
[# openlmi-mof-register]: Scriptlets must be sane, if used.
[x]: SourceX tarball generation or download is documented.
[!]: SourceX / PatchY prefixed with %{name}.
     Note: Source0 (openlmi-networking-0.0.5.tar.gz)
[x]: SourceX is a working URL.
[ ]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[ ]: Package should compile and build into binary rpms on all supported
[ ]: %check is present and all tests pass.
[ ]: Packages should try to preserve timestamps of original installed files.
[x]: Spec use %global instead of %define.

===== EXTRA items =====

[x]: Rpmlint is run on all installed packages.
     Note: No rpmlint messages.
[x]: Spec file according to URL is the same as in SRPM.

Checking: openlmi-networking-0.0.5-1.fc19.src.rpm
3 packages and 0 specfiles checked; 0 errors, 0 warnings.

Rpmlint (installed packages)
# rpmlint openlmi-networking openlmi-networking-debuginfo
2 packages and 0 specfiles checked; 0 errors, 0 warnings.
# echo 'rpmlint-done:'

openlmi-networking-debuginfo-0.0.5-1.fc19.x86_64.rpm (rpmlib, GLIBC filtered):

openlmi-networking-0.0.5-1.fc19.x86_64.rpm (rpmlib, GLIBC filtered):
    openlmi-providers >= 0.0.10

    openlmi-networking-debuginfo = 0.0.5-1.fc19
    openlmi-networking-debuginfo(x86-64) = 0.0.5-1.fc19

    cura-networking(x86-64) = 0.0.5-1.fc19
    openlmi-networking = 0.0.5-1.fc19
    openlmi-networking(x86-64) = 0.0.5-1.fc19

Unversioned so-files
openlmi-networking-0.0.5-1.fc19.x86_64.rpm: /usr/lib64/cmpi/libcmpiLMI_Networking.so

MD5-sum check
http://fedorahosted.org/released/openlmi-networking/openlmi-networking-0.0.5.tar.gz :
  CHECKSUM(SHA256) this package     : f8a9d97d11557554b72c5c530508ecb4129e1907723244f38d6835bc3dd38e8c
  CHECKSUM(SHA256) upstream package : f8a9d97d11557554b72c5c530508ecb4129e1907723244f38d6835bc3dd38e8c

Built with local dependencies:

Generated by fedora-review 0.3.0 (c78e275) last change: 2012-09-24
Buildroot used: fedora-rawhide-x86_64
Command line :/usr/bin/fedora-review -b 869280 -m fedora-rawhide-x86_64 -L /mnt/scratch/rnovacek/openlmi-providers
Comment 2 Radek Novacek 2012-10-24 05:15:02 EDT
New Package SCM Request
Package Name: openlmi-networking
Short Description: CIM provider for network management
Owners: rnovacek
Branches: f17 f18
Comment 3 Gwyn Ciesla 2012-10-24 07:02:33 EDT
Git done (by process-git-requests).
Comment 4 Fedora Update System 2012-10-24 08:45:03 EDT
openlmi-providers-0.0.10-1.fc18, openlmi-storage-0.4.0-2.fc18, openlmi-networking-0.0.5-1.fc18 has been submitted as an update for Fedora 18.
Comment 5 Fedora Update System 2012-10-24 12:18:09 EDT
Package openlmi-providers-0.0.10-1.fc18, openlmi-storage-0.4.0-2.fc18, openlmi-networking-0.0.5-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openlmi-providers-0.0.10-1.fc18 openlmi-storage-0.4.0-2.fc18 openlmi-networking-0.0.5-1.fc18'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-10-25 12:02:10 EDT
openlmi-storage-0.4.0-2.fc17, openlmi-networking-0.0.5-1.fc17, openlmi-providers-0.0.12-1.fc17 has been submitted as an update for Fedora 17.
Comment 7 Fedora Update System 2012-10-26 15:34:00 EDT
Package openlmi-storage-0.4.0-2.fc18, openlmi-networking-0.0.5-1.fc18, openlmi-providers-0.0.12-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openlmi-storage-0.4.0-2.fc18 openlmi-networking-0.0.5-1.fc18 openlmi-providers-0.0.12-1.fc18'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-12-20 10:48:50 EST
openlmi-storage-0.4.0-2.fc18, konkretcmpi-0.8.7-7.fc18, openlmi-networking-0.0.5-3.fc18, openlmi-providers-0.0.12-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.