Bug 869282 - Missing "show all deployments" filter from the deployments tab of the table view of Monitor page
Missing "show all deployments" filter from the deployments tab of the table v...
Status: CLOSED DUPLICATE of bug 870999
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Angus Thomas
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 09:16 EDT by Imre Farkas
Modified: 2016-09-20 01:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-21 05:03:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Deployments filter table (151.83 KB, image/png)
2012-10-23 09:16 EDT, Imre Farkas
no flags Details

  None (edit)
Description Imre Farkas 2012-10-23 09:16:50 EDT
Created attachment 632112 [details]
Deployments filter table

Description of problem:
The "show all deployments" filter is missing from the deployments tab of the table view of Monitor page. The filtering also doesn't work: before the backbone update all deployments are listed even if the "Non-stopped Deployments" is selected by default.

This behaviour is introduced by the fix fox BZ #859926 which works for Rails 3.2 but not for 3.0.


Version-Release number of selected component (if applicable):



How reproducible:

Steps to Reproduce:
1. Go to Monitor -> Deployments
  
Actual results:
1. There's no "All Deployments" filter
2. The default filter is "Non-stopped Deployments"
3. All deployments are listed even if the filter says "Non-stopped Deployments"

Expected results:
1. There should be filter for "All Deployments"
2. The default filter should be "All Deployments"
3. All deployments should be listed by default with the "All Deployments" filter

Additional info:
It should work on Rails 3.0 for product and Rails 3.2 for upstream
Comment 2 Imre Farkas 2012-11-21 05:03:45 EST

*** This bug has been marked as a duplicate of bug 870999 ***

Note You need to log in before you can comment on or make changes to this bug.