Bug 869336 - A wrong callback used causes getgrgid to not work for trusted domains
Summary: A wrong callback used causes getgrgid to not work for trusted domains
Keywords:
Status: CLOSED DUPLICATE of bug 871576
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd
Version: 6.4
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Jakub Hrozek
QA Contact: Kaushik Banerjee
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-23 15:40 UTC by Jakub Hrozek
Modified: 2012-11-02 14:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-02 14:16:12 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jakub Hrozek 2012-10-23 15:40:26 UTC
Description of problem:
When the subdomains are discovered during a getgrgid request, the SSSD calls a wrong callback, causing the getgrid operation to fail.

Version-Release number of selected component (if applicable):
1.9.2-4

How reproducible:
always

Steps to Reproduce:
1. getent passwd <uid-of-user-from-trusted-domain>
2.
3.
  
Actual results:
no results. Internally the SSSD encounters an error.

Expected results:
the user shows up

Additional info:
The upstream has a patch available, it is commit a489aec7d328ad4fd8f420e1ac011c1fdc247465:

http://git.fedorahosted.org/cgit/sssd.git/commit/?id=a489aec7d328ad4fd8f420e1ac011c1fdc247465

Comment 1 Jakub Hrozek 2012-10-24 10:33:46 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1601

Comment 2 Jakub Hrozek 2012-10-24 10:43:45 UTC
This was fixed upstream.

Comment 3 Jakub Hrozek 2012-11-02 14:16:12 UTC
This is the same issue as #871576, so they should be dup-ed. At the same time, #871576 has a cleaner reproducer than this bug, so I'm going to mark this one as duplicate of #871576.

*** This bug has been marked as a duplicate of bug 871576 ***


Note You need to log in before you can comment on or make changes to this bug.