Bug 869348 - Seam2.3 blog example atom feed not working and JBDS import errors
Seam2.3 blog example atom feed not working and JBDS import errors
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Examples (Show other bugs)
2.1.0
Unspecified Unspecified
unspecified Severity medium
: CR1
: 2.1.0
Assigned To: Marek Novotny
Marek Schmidt
Seam2.3 seam-example
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 12:05 EDT by Marek Schmidt
Modified: 2013-06-07 09:54 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The atom feed blog example distributed with JBoss Web Framework Kit for Seam 2.3 did not work correctly. The example has been corrected for this release by updating the web.xml file with a new definition for javax.faces.FACELETS_VIEW_MAPPINGS and modifying the example content type.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 10:34:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBSEAM-5048 Major Closed blog example atom feed not working 2013-06-07 09:54:51 EDT

  None (edit)
Description Marek Schmidt 2012-10-23 12:05:45 EDT
Description of problem:

seam-blog example application atom feed displays facelet page source, instead of the atom feed.

The example also displays the several errors when imported into JBDS related to the index.xml file.

Version-Release number of selected component (if applicable):
jboss-seam-2.3.0.Final-redhat-1


Steps to Reproduce:
1. Import Seam2.3 blog example into JBDS
2. Notice the JBDS errors
3. Deploy the app
4. Go to http://127.0.0.1:8080/seam-blog/
5. Click on "Atom feed"
  
Actual results:
index.xml source is displayed

Expected results:
an atom feed XML should be displayed instead
Comment 1 Marek Novotny 2012-11-01 08:48:47 EDT
What JBDS errors are you referring?

I can see only:
cvc-elt.1: Cannot find the declaration of element 'f:view'.

Is that what you see too?
Comment 2 Marek Schmidt 2012-11-01 11:06:35 EDT
I can see also something like: (in both JBDS 6.0.0.Beta1 and 5.0.1)

Referenced file contains errors (file:/home/maschmid/jbdevstudio-6.0.0.Beta1/studio/plugins/org.jboss.tools.jst.web.kb_3.4.0.Beta1-v20121018-0628-B39/taglibs/tld/facelets_jsf_core.taglib.xml). 

Referenced file contains errors (file:/home/maschmid/jbdevstudio-6.0.0.Beta1/studio/plugins/org.jboss.tools.jst.web.kb_3.4.0.Beta1-v20121018-0628-B39/taglibs/tld/html_basic.taglib.xml).
Comment 3 Marek Novotny 2012-11-03 16:59:56 EDT
I created JBDS issue for weird XML validation errors https://issues.jboss.org/browse/JBIDE-12990
Comment 4 Vaclav Dedik 2012-11-05 09:27:43 EST
I fixed the feeds by adding this definition in web.xml:

    <context-param>
        <param-name>javax.faces.FACELETS_VIEW_MAPPINGS</param-name>
        <param-value>*.xhtml;*.xml</param-value>
    </context-param>

Though I also had to change the content type of the atom feeds, because mojarra throws this exception: 

java.lang.IllegalArgumentException: Unrecognized Content Type.
	com.sun.faces.renderkit.RenderKitImpl.createResponseWriter(RenderKitImpl.java:290)
	com.sun.faces.application.view.FaceletViewHandlingStrategy.createResponseWriter(FaceletViewHandlingStrategy.java:923)
	com.sun.faces.application.view.FaceletViewHandlingStrategy.renderView(FaceletViewHandlingStrategy.java:377)
	com.sun.faces.application.view.MultiViewHandler.renderView(MultiViewHandler.java:125)
	org.jboss.seam.jsf.SeamViewHandler.renderView(SeamViewHandler.java:88)
	javax.faces.application.ViewHandlerWrapper.renderView(ViewHandlerWrapper.java:288)
	com.sun.faces.lifecycle.RenderResponsePhase.execute(RenderResponsePhase.java:121)
	com.sun.faces.lifecycle.Phase.doPhase(Phase.java:101)
	com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:139)
	javax.faces.webapp.FacesServlet.service(FacesServlet.java:594)
	org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:83)
	org.jboss.seam.web.RewriteFilter.doFilter(RewriteFilter.java:63)
	org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
	org.jboss.seam.web.LoggingFilter.doFilter(LoggingFilter.java:60)
	org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
	org.jboss.seam.web.IdentityFilter.doFilter(IdentityFilter.java:40)
	org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
	org.jboss.seam.web.MultipartFilter.doFilter(MultipartFilter.java:90)
	org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
	org.jboss.seam.web.ExceptionFilter.doFilter(ExceptionFilter.java:64)
	org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
	org.jboss.seam.web.RedirectFilter.doFilter(RedirectFilter.java:45)
	org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
	org.jboss.seam.web.HotDeployFilter.doFilter(HotDeployFilter.java:53)
	org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
	org.jboss.seam.servlet.SeamFilter.doFilter(SeamFilter.java:158)

when any content type other then application/xml, application/xhtml+xml, text/html or text/xml is provided.
Comment 5 JBoss JIRA Server 2012-11-08 07:11:04 EST
Vaclav Dedik <vdedik@redhat.com> made a comment on jira JBSEAM-5048

I have added a bugzilla reference, this issue is kind of resolved by this commit:
https://source.jboss.org/changelog/Seam?cs=15348

Though, as I have posted in the bugzilla, since there is a problem with mojarra and content type, I also had to change the content type of index.xml.
Comment 6 mark yarborough 2012-11-09 10:02:39 EST
mnovotny: Please add CCFR for WFK 2.1 release notes.
Comment 7 Marek Novotny 2012-11-10 07:02:30 EST
I have added Release Notes text, and again changed status to ON_QA, because this issue is partially resolved and QE should verify at least the fix for Blog example Atom feed page.

After QE verification, we should probably create another issue for tracking only JBDS upstream issue.
Comment 8 Tomas Remes 2012-11-12 05:05:50 EST
Verified Blog example Atom feed functionality and also created tracking issue with id 875656.
Comment 9 JBoss JIRA Server 2012-11-19 04:28:06 EST
Marek Novotny <mnovotny@redhat.com> updated the status of jira JBSEAM-5048 to Resolved
Comment 10 JBoss JIRA Server 2012-11-19 04:28:06 EST
Marek Novotny <mnovotny@redhat.com> made a comment on jira JBSEAM-5048

fixed by rev #15348
Comment 11 Marek Schmidt 2012-11-26 04:22:40 EST
I believe this issue should not appear in the release notes, as it has not been present in any product (only community Seam2.3.0.Final)
Comment 12 Karel Piwko 2012-11-30 10:34:52 EST
Distributed as a part of WFK 2.1.0.GA release.
Comment 13 JBoss JIRA Server 2013-06-07 09:54:52 EDT
Marek Novotny <mnovotny@redhat.com> updated the status of jira JBSEAM-5048 to Closed
Comment 14 JBoss JIRA Server 2013-06-07 09:54:52 EDT
Marek Novotny <mnovotny@redhat.com> made a comment on jira JBSEAM-5048

2.3.1.CR1 is now out, so closing all resolved issues

Note You need to log in before you can comment on or make changes to this bug.