Bug 869359 - MDRaidError: raid0 requires at least 2 disks
MDRaidError: raid0 requires at least 2 disks
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:0438a351de1deff5aba7c21aecc...
:
: 873486 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 12:42 EDT by Reartes Guillermo
Modified: 2013-05-30 13:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-30 13:04:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (310.83 KB, text/plain)
2012-10-23 12:42 EDT, Reartes Guillermo
no flags Details
File: product (6 bytes, text/plain)
2012-10-23 12:42 EDT, Reartes Guillermo
no flags Details
File: type (9 bytes, text/plain)
2012-10-23 12:42 EDT, Reartes Guillermo
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-10-23 12:42 EDT, Reartes Guillermo
no flags Details
File: storage.log (142.17 KB, text/plain)
2012-10-23 12:42 EDT, Reartes Guillermo
no flags Details
File: version (11 bytes, text/plain)
2012-10-23 12:42 EDT, Reartes Guillermo
no flags Details
File: environ (780 bytes, text/plain)
2012-10-23 12:42 EDT, Reartes Guillermo
no flags Details
File: anaconda.log (11.04 KB, text/plain)
2012-10-23 12:43 EDT, Reartes Guillermo
no flags Details
File: syslog (68.42 KB, text/plain)
2012-10-23 12:43 EDT, Reartes Guillermo
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-23 12:43 EDT, Reartes Guillermo
no flags Details
File: packaging.log (2.38 KB, text/plain)
2012-10-23 12:43 EDT, Reartes Guillermo
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-10-23 12:43 EDT, Reartes Guillermo
no flags Details
File: release (24 bytes, text/plain)
2012-10-23 12:43 EDT, Reartes Guillermo
no flags Details
File: program.log (48.49 KB, text/plain)
2012-10-23 12:43 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-23 12:42:28 EDT
Description of problem:
deleted a partition in manual partitioning. i will clarify later.

Version-Release number of selected component:
anaconda-18.19

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.19 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicelibs/mdraid.py", line 146, in get_member_space
:    % (level, min_members))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 3342, in device_size
:    level=self.raid_level)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1348, in _populate_raid
:    base_size = factory.device_size
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1547, in _populate_right_side
:    self._populate_raid(raid_level, device.size)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1817, in on_selector_clicked
:    self._populate_right_side(selector)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1712, in _show_first_mountpoint
:    self.on_selector_clicked(page._members[0])
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1835, in on_page_clicked
:    self._show_first_mountpoint(page=page)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 787, in _do_refresh
:    self.on_page_clicked(self._accordion.currentPage())
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1771, in on_remove_clicked
:    self._do_refresh()
:MDRaidError: raid0 requires at least 2 disks
Comment 1 Reartes Guillermo 2012-10-23 12:42:39 EDT
Created attachment 632198 [details]
File: anaconda-tb
Comment 2 Reartes Guillermo 2012-10-23 12:42:42 EDT
Created attachment 632199 [details]
File: product
Comment 3 Reartes Guillermo 2012-10-23 12:42:44 EDT
Created attachment 632200 [details]
File: type
Comment 4 Reartes Guillermo 2012-10-23 12:42:47 EDT
Created attachment 632201 [details]
File: ifcfg.log
Comment 5 Reartes Guillermo 2012-10-23 12:42:52 EDT
Created attachment 632202 [details]
File: storage.log
Comment 6 Reartes Guillermo 2012-10-23 12:42:55 EDT
Created attachment 632203 [details]
File: version
Comment 7 Reartes Guillermo 2012-10-23 12:42:58 EDT
Created attachment 632204 [details]
File: environ
Comment 8 Reartes Guillermo 2012-10-23 12:43:01 EDT
Created attachment 632205 [details]
File: anaconda.log
Comment 9 Reartes Guillermo 2012-10-23 12:43:04 EDT
Created attachment 632206 [details]
File: syslog
Comment 10 Reartes Guillermo 2012-10-23 12:43:06 EDT
Created attachment 632207 [details]
File: hashmarkername
Comment 11 Reartes Guillermo 2012-10-23 12:43:09 EDT
Created attachment 632208 [details]
File: packaging.log
Comment 12 Reartes Guillermo 2012-10-23 12:43:12 EDT
Created attachment 632209 [details]
File: cmdline_file
Comment 13 Reartes Guillermo 2012-10-23 12:43:14 EDT
Created attachment 632210 [details]
File: release
Comment 14 Reartes Guillermo 2012-10-23 12:43:17 EDT
Created attachment 632211 [details]
File: program.log
Comment 15 Reartes Guillermo 2012-10-23 12:45:14 EDT
I reproduced it in this way:

Setup has 3 disks, all with preexisting partitions.

0. Enter STORAGE: INSTALLATION DESTINATION

1. Select second disk, MANUAL PARTITIONING, Delete SWAP in 'unknown' tree. FINISH PARTITIONING

2. Enter STORAGE: INSTALLATION DESTINATION again. (The exclamation mark is correctly shown)

3. Select the first disk & deselect the second one,Do MANUAL PARTITIONING, Delete the currently selected partition in 'unknown' tree.
Comment 16 Chris Lumens 2012-11-05 10:24:14 EST
Are you still seeing this with anaconda-18.23-1?
Comment 17 Brian Lane 2012-11-08 14:27:07 EST
*** Bug 873486 has been marked as a duplicate of this bug. ***
Comment 18 David Lehman 2013-05-30 13:04:19 EDT
This should have been fixed for the release of Fedora 18. If you continue to see the problem, please reopen this bug with attached logs (/tmp/anaconda-tb-*). Thanks.

Note You need to log in before you can comment on or make changes to this bug.