Bug 869375 - 'Reclaim space' button in RECLAIM DISK SPACE dialog takes you back to INSTALLATION OPTIONS if no action changes were made, it should initially be insensitive
'Reclaim space' button in RECLAIM DISK SPACE dialog takes you back to INSTALL...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 13:51 EDT by Volker Sobek
Modified: 2012-12-06 02:27 EST (History)
4 users (show)

See Also:
Fixed In Version: anaconda-18.21-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 00:55:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Volker Sobek 2012-10-23 13:51:21 EDT
Version-Release number of selected component (if applicable):
anaconda 18.19 (Fedora 18-Beta-TC6)

How reproducible:
Always


Steps to Reproduce:
1. In the 'installation destination' panel, select a disk that already contains partitions and doesn't have enough free space for an installation.
2. Click on continue
3. In the appearing 'installation options' dialog, click on the 'reclaim space' button
4. In the appearing 'reclaim disk space' dialog, leave all action fields unchanged ('Preserve') and click on 'reclaim space'
5. You are taken to the 'installation options dialog' again
6. continue at 3.
  
Actual results:
The user might miss the fact that you have to change the action field in the 'reclaim disk space' dialog, and think the selected row/partition will be deleted when clicking the 'reclaim space' button, which is not the case. He ends up in a loop, trying to remove partitions.

Expected results:
The 'reclaim space' button in the reclaim disk space' dialog should not be sensitive until at least one least one action field was changed.
Comment 1 Fedora Update System 2012-10-25 21:29:11 EDT
anaconda-18.21-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.21-1.fc18
Comment 2 Fedora Update System 2012-10-26 15:31:09 EDT
Package anaconda-18.21-1.fc18, pykickstart-1.99.21-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.21-1.fc18 pykickstart-1.99.21-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16868/pykickstart-1.99.21-1.fc18,anaconda-18.21-1.fc18
then log in and leave karma (feedback).
Comment 3 Adam Williamson 2012-11-07 15:24:12 EST
this has been fixed in all recent builds. we still don't have a build since 18.19 stable, though, so setting VERIFIED.
Comment 4 Adam Williamson 2012-11-23 00:55:49 EST
later builds are stable now.
Comment 5 Fedora Update System 2012-11-28 20:25:03 EST
anaconda-18.32-1.fc18, pykickstart-1.99.22-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pykickstart-1.99.22-1.fc18,anaconda-18.32-1.fc18
Comment 6 Fedora Update System 2012-12-06 02:27:11 EST
pykickstart-1.99.22-1.fc18, anaconda-18.35-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.