Bug 869422 - "finish partitioning" is clickable when there are unresolved storage errors
"finish partitioning" is clickable when there are unresolved storage errors
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 16:33 EDT by Reartes Guillermo
Modified: 2012-11-23 01:04 EST (History)
5 users (show)

See Also:
Fixed In Version: anaconda-18.22-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 01:04:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reartes Guillermo 2012-10-23 16:33:57 EDT
Description of problem:

The installation process can be installed with "Apparently" two root '/' partitions defined. Dual-ROOT? :-)

The installation process does complete without any error, the "Apparent" second root kept the /foo mount point (the previous valid value).

Steps:

0. Enter STORAGE: INSTALLATION DESTINATION

1. Select a single disk, do MANUAL PARTITIONING.

2. Create your layout. (/boot, SWAP and /) but leave free space for another partition.

3. Create a /foo partition.

4. Change the mount point of /foo to / (from the 'customize' tree)

5. By pressing 'apply' an error will (correctly be displayed in a yellow banner)

6. Press 'finish partitioning' and return to the main hub. 

7. 'begin installation' is UNLOCKED with 'custom partitioning selected'


Version-Release number of selected component (if applicable):
F18b TC6

How reproducible:
Always
  
Actual results:
the systems is installed with /foo (the previous valid value for the 'mount point' filed). 

Expected results:
'finish partitioning' should have not permitted to use such partitions. It has no way of know if the previous valid field for 'mount point' is the desired mount point. It is being changed for some reason after all.

Additional info:
Comment 1 Chris Lumens 2012-10-30 18:26:05 EDT
After looking at this a little bit, I think the entirety of the problem is just that the mount point entry on the right hand side of the screen still contains the "/" you put in.  We've not done anything in the storage module given the failure, so we just need to fix that entry up.

We do not have much interest in locking you into a spoke, so I don't want to simply disable the finish button.  Posting a patch.
Comment 2 Fedora Update System 2012-10-31 22:51:11 EDT
anaconda-18.22-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.22-1.fc18
Comment 3 Fedora Update System 2012-11-01 14:26:42 EDT
Package anaconda-18.22-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.22-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17432/anaconda-18.22-1.fc18
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-11-02 00:05:40 EDT
anaconda-18.23-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.23-1.fc18
Comment 5 Fedora Update System 2012-11-02 21:05:07 EDT
anaconda-18.24-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.24-1.fc18
Comment 6 Fedora Update System 2012-11-05 20:40:18 EST
anaconda-18.25-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.25-1.fc18
Comment 7 Fedora Update System 2012-11-06 21:12:15 EST
anaconda-18.26-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.26-1.fc18
Comment 8 Adam Williamson 2012-11-23 01:04:12 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.