Bug 869424 - RuntimeError: Error running systemctl: No such file or directory
Summary: RuntimeError: Error running systemctl: No such file or directory
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 18
Hardware: All
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:26ff98f4d3ef9cd1052f1bdae61...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-23 20:51 UTC by Mark Hamzy
Modified: 2014-01-21 23:04 UTC (History)
10 users (show)

Fixed In Version: anaconda-18.22-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-02 17:57:19 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (321.52 KB, text/plain)
2012-10-23 20:51 UTC, Mark Hamzy
no flags Details
File: product (6 bytes, text/plain)
2012-10-23 20:51 UTC, Mark Hamzy
no flags Details
File: type (9 bytes, text/plain)
2012-10-23 20:51 UTC, Mark Hamzy
no flags Details
File: storage.log (153.14 KB, text/plain)
2012-10-23 20:51 UTC, Mark Hamzy
no flags Details
File: version (2 bytes, text/plain)
2012-10-23 20:52 UTC, Mark Hamzy
no flags Details
File: environ (815 bytes, text/plain)
2012-10-23 20:52 UTC, Mark Hamzy
no flags Details
File: anaconda.log (9.11 KB, text/plain)
2012-10-23 20:52 UTC, Mark Hamzy
no flags Details
File: syslog (38.20 KB, text/plain)
2012-10-23 20:52 UTC, Mark Hamzy
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-23 20:52 UTC, Mark Hamzy
no flags Details
File: packaging.log (16.05 KB, text/plain)
2012-10-23 20:52 UTC, Mark Hamzy
no flags Details
File: cmdline_file (188 bytes, text/plain)
2012-10-23 20:52 UTC, Mark Hamzy
no flags Details
File: release (24 bytes, text/plain)
2012-10-23 20:52 UTC, Mark Hamzy
no flags Details
File: program.log (48.62 KB, text/plain)
2012-10-23 20:52 UTC, Mark Hamzy
no flags Details
anaconda log (1.41 MB, text/plain)
2012-12-24 08:24 UTC, Dan Mashal
no flags Details

Description Mark Hamzy 2012-10-23 20:51:51 UTC
Description of problem:
Selected Software Development

Version-Release number of selected component:
anaconda-18.19

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.ppc64

description:
:The following was filed automatically by anaconda:
:anaconda 18.19 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iutil.py", line 193, in execWithRedirect
:    raise RuntimeError, errstr
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1300, in execute
:    root=ROOT_PATH)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 58, in doConfiguration
:    ksdata.services.execute(storage, ksdata, instClass)
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
:    threading.Thread.run(self, *args, **kwargs)
:RuntimeError: Error running systemctl: No such file or directory

Comment 1 Mark Hamzy 2012-10-23 20:51:53 UTC
Created attachment 632379 [details]
File: anaconda-tb

Comment 2 Mark Hamzy 2012-10-23 20:51:55 UTC
Created attachment 632380 [details]
File: product

Comment 3 Mark Hamzy 2012-10-23 20:51:57 UTC
Created attachment 632381 [details]
File: type

Comment 4 Mark Hamzy 2012-10-23 20:51:58 UTC
Created attachment 632382 [details]
File: storage.log

Comment 5 Mark Hamzy 2012-10-23 20:52:00 UTC
Created attachment 632383 [details]
File: version

Comment 6 Mark Hamzy 2012-10-23 20:52:01 UTC
Created attachment 632384 [details]
File: environ

Comment 7 Mark Hamzy 2012-10-23 20:52:03 UTC
Created attachment 632385 [details]
File: anaconda.log

Comment 8 Mark Hamzy 2012-10-23 20:52:05 UTC
Created attachment 632386 [details]
File: syslog

Comment 9 Mark Hamzy 2012-10-23 20:52:06 UTC
Created attachment 632387 [details]
File: hashmarkername

Comment 10 Mark Hamzy 2012-10-23 20:52:08 UTC
Created attachment 632388 [details]
File: packaging.log

Comment 11 Mark Hamzy 2012-10-23 20:52:09 UTC
Created attachment 632389 [details]
File: cmdline_file

Comment 12 Mark Hamzy 2012-10-23 20:52:11 UTC
Created attachment 632390 [details]
File: release

Comment 13 Mark Hamzy 2012-10-23 20:52:12 UTC
Created attachment 632391 [details]
File: program.log

Comment 14 Mark Hamzy 2012-10-23 21:01:20 UTC
Selected:

Development and Creative Workstation
Development Tools

Comment 15 Vratislav Podzimek 2012-10-24 09:11:29 UTC
Obviously systemd was not installed with the Development and Creative Workstation environment.

Comment 16 Chris Lumens 2012-10-24 14:21:32 UTC
I'm almost positive this is an anaconda problem.

Comment 17 Fedora Update System 2012-11-01 02:52:56 UTC
anaconda-18.22-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.22-1.fc18

Comment 18 Fedora Update System 2012-11-01 18:29:01 UTC
Package anaconda-18.22-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.22-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17432/anaconda-18.22-1.fc18
then log in and leave karma (feedback).

Comment 19 Fedora Update System 2012-11-02 04:07:12 UTC
anaconda-18.23-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.23-1.fc18

Comment 20 Fedora Update System 2012-11-03 01:06:51 UTC
anaconda-18.24-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.24-1.fc18

Comment 21 Fedora Update System 2012-11-06 01:41:55 UTC
anaconda-18.25-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.25-1.fc18

Comment 22 Fedora Update System 2012-11-07 02:14:04 UTC
anaconda-18.26-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.26-1.fc18

Comment 23 Adam Williamson 2012-11-23 06:05:23 UTC
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

Comment 24 Dan Mashal 2012-11-23 07:58:45 UTC
Still hitting this bug.

Comment 25 Chris Lumens 2012-11-24 04:47:31 UTC
Any time you reopen a bug, you need to attach the traceback.

Comment 26 Dan Mashal 2012-11-24 04:57:32 UTC
It wont let me do that through ABRT since it says it's a duplicate of this bug. Any tips on an easy way to do that?

Comment 27 Adam Williamson 2012-11-24 08:10:07 UTC
dan: you have to do it manually unfortunately. the traceback will be in /tmp with the filename anaconda-tb-randomstring . just grab it and attach it (either usb stick or fpaste it out).

Comment 28 Karsten Hopp 2012-11-28 17:59:48 UTC
no ppc specific problem, I'll put it on the F18Blocker list

Comment 29 Adam Williamson 2012-11-29 07:58:48 UTC
karsten: do you have a traceback for us?

Comment 30 Kamil Páral 2012-11-29 17:54:04 UTC
I tested with F18 Beta DVD i386, selected components according to comment 14. No problem at all, everything worked fine.

Comment 31 Adam Williamson 2012-11-29 17:56:15 UTC
Discussed at 2012-11-29 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-11-29/f18final-blocker-review-1.1.2012-11-29-17.01.log.txt . We agreed we need re-testing to clarify whether this is really a current issue before deciding on blocker status.

Comment 32 Tim Flink 2012-12-06 15:57:16 UTC
From c#30, it sounds like this might be fixed. Dan, if you're still hitting this, could you attach the tracebacks that Chris asked for?

Comment 33 Dan Mashal 2012-12-24 08:22:00 UTC
(In reply to comment #27)
> dan: you have to do it manually unfortunately. the traceback will be in /tmp
> with the filename anaconda-tb-randomstring . just grab it and attach it
> (either usb stick or fpaste it out).

Here is the file you request (which was too large for fpaste) and hit on my current compose of the DVD.(In reply to comment #32)

> From c#30, it sounds like this might be fixed. Dan, if you're still hitting
> this, could you attach the tracebacks that Chris asked for?

Done.

Using Anaconda 18.37.4

Comment 34 Dan Mashal 2012-12-24 08:24:08 UTC
Created attachment 668355 [details]
anaconda log

Comment 35 Adam Williamson 2013-01-02 17:54:39 UTC
Dan: your install had massive dependency problems and almost the entire package set was nerfed by skipbroken. Only 36 packages got installed. Just search the log for SKIPBROKEN and see the carnage. Since you're using a DVD you built yourself, that looks like your problem, unless you can reproduce it with an official build. And almost certainly not the same problem as the original reporter hit.

Comment 36 Adam Williamson 2013-01-02 17:57:19 UTC
Discussed at 2013-01-02 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2013-01-02/f18final-blocker-review-8.2013-01-02-17.03.log.txt . Rejected as a blocker per comment #35 - this looks like it was specific to Dan's own build / comps setup. As Dan re-opened this 'fixed' bug for his case, I am going to re-close the bug. Dan, if you think there's a valid bug lurking here, please pin it down more specifically - or if it's in your MATE comps stuff, just fix it yourself - and file it separately. Thanks. It is clearly not really this bug.


Note You need to log in before you can comment on or make changes to this bug.