Bug 869457 - ovirt all in one install fails w/ "could not create ovirtsdk API object"
ovirt all in one install fails w/ "could not create ovirtsdk API object"
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-installer (Show other bugs)
3.1 GA
Unspecified Linux
urgent Severity unspecified
: ---
: 3.2
Assigned To: Juan Hernández
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 20:41 EDT by Jason Brooks
Modified: 2013-02-15 01:47 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-15 01:47:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Brooks 2012-10-23 20:41:15 EDT
Description of problem:

The ovirt-engine-setup-plugin-allinone package depends on ovirt-engine-sdk, version 3.1 of which is provided in the ovirt release repo. As of Sept 21, there's a version 3.2 of ovirt-engine-sdk in the Fedora 17 update repository, and the allinone plugin now pulls this version of the package in to fill the dep. This prevents the all-in-one setup from completing, so people who attempt to set up oVirt AIO now error out w/ "Exception: Error: could not create ovirtsdk API object"

The ovirt-engine-setup-plugin-allinone package should probably be made to call specifically for the 3.1 version of ovirt-engine-sdk.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jason Brooks 2012-10-29 15:50:12 EDT
This issue appears to affect the ovirt iso uploader as well: http://lists.ovirt.org/pipermail/users/2012-October/004610.html
Comment 2 Van Der Fran 2012-11-01 23:13:33 EDT
If we downgrade the ovirt-engine-sdk, we can go further...


[root@MyNode ~]# uname -a
Linux p100 3.6.3-1.fc17.x86_64 #1 SMP Mon Oct 22 15:32:35 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux


[root@MyNode ~]# yum install http://www.ovirt.org/releases/ovirt-release-fedora.noarch.rpm
ovirt-release-fedora.noarch.rpm                                                                                                     | 7.0 kB     00:00
Examining /var/tmp/yum-root-QANreY/ovirt-release-fedora.noarch.rpm: ovirt-release-fedora-4-2.noarch
Marking /var/tmp/yum-root-QANreY/ovirt-release-fedora.noarch.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package ovirt-release-fedora.noarch 0:4-2 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

===========================================================================================================================================================
 Package                                   Arch                        Version                     Repository                                         Size
===========================================================================================================================================================
Installing:
 ovirt-release-fedora                      noarch                      4-2                         /ovirt-release-fedora.noarch                       12 k

Transaction Summary
===========================================================================================================================================================
Install  1 Package

Total size: 12 k
Installed size: 12 k
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : ovirt-release-fedora-4-2.noarch                                                                                                         1/1
  Verifying  : ovirt-release-fedora-4-2.noarch                                                                                                         1/1

Installed:
  ovirt-release-fedora.noarch 0:4-2

Complete!
[root@MyNode ~]#yum install ovirt-engine-setup-plugin-allinone
.
.
.
(656/659): yajl-2.0.4-1.fc17.x86_64.rpm                                                                                             |  34 kB     00:00
(657/659): yum-plugin-versionlock-1.1.31-4.fc17.noarch.rpm                                                                          |  24 kB     00:00
(658/659): yum-utils-1.1.31-4.fc17.noarch.rpm                                                                                       | 101 kB     00:00
(659/659): zip-3.0-4.fc17.x86_64.rpm                                                                                                | 253 kB     00:00
-----------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                      3.0 MB/s | 344 MB     01:53
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-x86_64
Importing GPG key 0x1ACA3465:
 Userid     : "Fedora (17) <fedora@fedoraproject.org>"
 Fingerprint: cac4 3fb7 74a4 a673 d81c 5de7 50e9 4c99 1aca 3465
 Package    : fedora-release-17-1.noarch (@fedora)
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-x86_64
Is this ok [y/N]:Y
.
.
.
 xnio.noarch 0:3.0.3-1.fc17                                                 xpp2.noarch 0:2.1.10-10.3.fc17
 xpp3.noarch 0:1.1.3.8-6.fc17                                               xpp3-minimal.noarch 0:1.1.3.8-6.fc17
 xsom.noarch 0:0-5.20110809svn.fc17                                         xstream.noarch 0:1.3.1-3.fc17
 yajl.x86_64 0:2.0.4-1.fc17                                                 yum-plugin-versionlock.noarch 0:1.1.31-4.fc17
 yum-utils.noarch 0:1.1.31-4.fc17                                           zip.x86_64 0:3.0-4.fc17

Complete!


[root@MyNode ~]# yum downgrade ovirt-engine-sdk
Loaded plugins: versionlock
Resolving Dependencies
--> Running transaction check
---> Package ovirt-engine-sdk.noarch 0:3.1.0.4-1.fc17 will be a downgrade
---> Package ovirt-engine-sdk.noarch 0:3.2.0.2-1.fc17 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

===========================================================================================================================================================
 Package                                  Arch                           Version                                Repository                            Size
===========================================================================================================================================================
Downgrading:
 ovirt-engine-sdk                         noarch                         3.1.0.4-1.fc17                         ovirt-stable                         210 k

Transaction Summary
===========================================================================================================================================================
Downgrade  1 Package

Total download size: 210 k
Is this ok [y/N]: y
Downloading Packages:
ovirt-engine-sdk-3.1.0.4-1.fc17.noarch.rpm                                                                                          | 210 kB     00:01
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : ovirt-engine-sdk-3.1.0.4-1.fc17.noarch                                                                                                  1/2
  Cleanup    : ovirt-engine-sdk-3.2.0.2-1.fc17.noarch                                                                                                  2/2
  Verifying  : ovirt-engine-sdk-3.1.0.4-1.fc17.noarch                                                                                                  1/2
  Verifying  : ovirt-engine-sdk-3.2.0.2-1.fc17.noarch                                                                                                  2/2

Removed:
  ovirt-engine-sdk.noarch 0:3.2.0.2-1.fc17

Installed:
  ovirt-engine-sdk.noarch 0:3.1.0.4-1.fc17

Complete!


[root@MyNode ~]# engine-setup
Welcome to oVirt Engine setup utility
HTTP Port  [80] :
HTTPS Port  [443] :
Host fully qualified domain name, note that this name should be fully resolvable  [MyNode.MyDomain.inc] :
Password for Administrator (admin@internal) :
Confirm password :
Organization Name for the Certificate: MyDomain.inc
The default storage type you will be using  ['NFS'| 'FC'| 'ISCSI']  [NFS] :
Enter DB type for installation ['remote'| 'local']  [local] :
Local database password :
Warning: Weak Password.
Confirm password :
Local ISO domain path: /mnt/iso
Display name for the ISO Domain: ISO
Firewall ports need to be opened.
You can let the installer configure iptables automatically overriding the current configuration. The old configuration will be backed up.
Alternately you can configure the firewall later using an example iptables file found under /usr/share/ovirt-engine/conf/iptables.example
Configure iptables ? ['yes'| 'no']: yes
Configure VDSM on this host? ['yes'| 'no']  [yes] : yes
Local storage domain path: /mnt/data
Confirm root password :

Installing:
AIO: Validating CPU Compatibility...                               [ DONE ]
Configuring oVirt-engine...                                        [ DONE ]
Creating CA...                                                     [ DONE ]
Editing JBoss Configuration...                                     [ DONE ]
Setting Database Configuration...                                  [ DONE ]
Setting Database Security...                                       [ DONE ]
Creating Database...                                               [ DONE ]
Updating the Default Data Center Storage Type...                   [ DONE ]
Editing oVirt Engine Configuration...                              [ DONE ]
Editing Postgresql Configuration...                                [ DONE ]
Configuring the Default ISO Domain...                              [ DONE ]
Configuring Firewall (iptables)...                                 [ DONE ]
Starting JBoss Service...                                          [ DONE ]
Handling HTTPD...                                                  [ DONE ]
AIO: Creating storage directory...                                 [ DONE ]
AIO: Adding Local Datacenter and cluster...                        [ DONE ]
AIO: Adding Local host (This may take several minutes)...       [ ERROR ]
Error: Timed out while waiting for host to start


[root@MyNode ~]# rpm -qa | grep ovi*
mobile-broadband-provider-info-1.20120614-1.fc17.noarch
ovirt-engine-config-3.1.0-2.fc17.noarch
ovirt-release-fedora-4-2.noarch
maven-surefire-provider-junit-2.10-5.fc17.noarch
ovirt-engine-restapi-3.1.0-2.fc17.noarch
ovirt-engine-3.1.0-2.fc17.noarch
apache-commons-discovery-0.5-3.fc17.noarch
ovirt-image-uploader-3.1.0-0.git9c42c8.fc17.noarch
ovirt-engine-genericapi-3.1.0-2.fc17.noarch
ovirt-engine-tools-common-3.1.0-2.fc17.noarch
ovirt-engine-backend-3.1.0-2.fc17.noarch
jetty-overlay-deployer-8.1.2-12.fc17.noarch
ovirt-log-collector-3.1.0-0.git10d719.fc17.noarch
ovirt-engine-webadmin-portal-3.1.0-2.fc17.noarch
ovirt-engine-dbscripts-3.1.0-2.fc17.noarch
ovirt-engine-setup-plugin-allinone-3.1.0-2.fc17.noarch
ovirt-engine-userportal-3.1.0-2.fc17.noarch
ovirt-engine-setup-3.1.0-2.fc17.noarch
ovirt-engine-sdk-3.1.0.4-1.fc17.noarch
groovy-1.8.7-1.fc17.noarch
ovirt-engine-notification-service-3.1.0-2.fc17.noarch
ovirt-iso-uploader-3.1.0-0.git1841d9.fc17.noarch
Comment 3 Itamar Heim 2012-11-09 10:06:15 EST
michael, in general, i think if sdk broke older clients, maybe the rpm should have conflicted with known bad rpms.
for now, let's just fix the problematic utility i guess.
Comment 4 Michael Pasternak 2012-11-11 02:57:09 EST
(In reply to comment #3)
> michael, in general, i think if sdk broke older clients, maybe the rpm
> should have conflicted with known bad rpms.
> for now, let's just fix the problematic utility i guess.

if you would attach trace or log i could help with analysing the cause,
but since none of these is provided, i can only assume that old tools using newer
sdk that requires certificate for ssl sites ...,

juan, can you please make sure new versions of tools also get 
uploaded to the f17.

thanks.
Comment 5 Juan Hernández 2012-11-12 09:00:59 EST
This has already been fixed in the master branch with the following commit:

http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=c833bba55a19b2e2383d532b87c363a7895a8927

I am proposing to make a new minor release of ovirt-engine including that fix:

http://gerrit.ovirt.org/9146
Comment 6 Juan Hernández 2012-11-27 04:11:59 EST
The change has been merged:

http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=e59e821190aa4c6b3df13ae40214316d03359aa9

And a new version containing it has been released:

http://lists.ovirt.org/pipermail/users/2012-November/005116.html
Comment 7 Adrian Gibanel Btactic 2012-12-06 13:23:17 EST
I confirm that:

1) I didn't come accross the:
  could not create ovirtsdk API object
message.

2) The iso uploader problem described here: http://lists.ovirt.org/pipermail/users/2012-October/004610.html still persists.

rpm -qa | grep ovirt
ovirt-engine-config-3.1.0-4.fc17.noarch
ovirt-image-uploader-3.1.0-0.git9c42c8.fc17.noarch
ovirt-engine-genericapi-3.1.0-4.fc17.noarch
ovirt-engine-setup-plugin-allinone-3.1.0-4.fc17.noarch
ovirt-engine-dbscripts-3.1.0-4.fc17.noarch
ovirt-engine-backend-3.1.0-4.fc17.noarch
ovirt-log-collector-3.1.0-0.git10d719.fc17.noarch
ovirt-engine-setup-3.1.0-4.fc17.noarch
ovirt-engine-tools-common-3.1.0-4.fc17.noarch
ovirt-engine-3.1.0-4.fc17.noarch
ovirt-engine-userportal-3.1.0-4.fc17.noarch
ovirt-engine-webadmin-portal-3.1.0-4.fc17.noarch
ovirt-engine-notification-service-3.1.0-4.fc17.noarch
ovirt-iso-uploader-3.1.0-0.git1841d9.fc17.noarch
ovirt-engine-sdk-3.2.0.2-1.fc17.noarch
ovirt-engine-restapi-3.1.0-4.fc17.noarch
ovirt-release-fedora-4-2.noarch
Comment 8 Itamar Heim 2013-01-24 22:23:56 EST
(In reply to comment #7)
> I confirm that:
> 
> 1) I didn't come accross the:
>   could not create ovirtsdk API object
> message.
> 
> 2) The iso uploader problem described here:
> http://lists.ovirt.org/pipermail/users/2012-October/004610.html still
> persists.

michael --^ ?
Comment 9 Michael Pasternak 2013-01-27 01:53:27 EST
(In reply to comment #8)
> (In reply to comment #7)
> > I confirm that:
> > 
> > 1) I didn't come accross the:
> >   could not create ovirtsdk API object
> > message.
> > 
> > 2) The iso uploader problem described here:
> > http://lists.ovirt.org/pipermail/users/2012-October/004610.html still
> > persists.
> 
> michael --^ ?

we have dedicate Bug 886525 on this.

Note You need to log in before you can comment on or make changes to this bug.