Bug 869465 - trouble booting /dev/root does not exist
trouble booting /dev/root does not exist
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut (Show other bugs)
7.0
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: dracut-maint
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 22:04 EDT by Ben Woodard
Modified: 2012-10-25 15:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-25 15:24:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vmm created virt image (2.69 KB, text/xml)
2012-10-23 22:04 EDT, Ben Woodard
no flags Details

  None (edit)
Description Ben Woodard 2012-10-23 22:04:36 EDT
Created attachment 632498 [details]
vmm created virt image

Description of problem:

Virtual image won't boot on F17
Warning: /dev/root does not exist 

looking in the dracut logs it doesn't appear to be finding a disk

There is no /dev/disk or /dev/sdX or any of the other likely candidates.

cdrom being found as sr1 seems to be the last thing in dmesg as if it can't find the qemu provided disk. Other virtual images seem to have no problem finding their disk.

The journalctl logs are practically unreadable. Most of the info is truncated toward the right side of the screen. 

Version-Release number of selected component (if applicable):
Fedora 17 host: 
  qemu-kvm-1.0.1-2.fc17.x86_64
  kernel-devel-3.6.1-1.fc17.x86_64
  libvirt-0.9.11.6-1.fc17.x86_64
RHEL7 image: 
  RHEL-7.0-20121012.1-Server-x86_64-dvd1.iso
  [root@snog images]# sha256sum RHEL-7.0-20121012.1-Server-x86_64-dvd1.iso 
  fd5fffb92df274b77d33c3244570d65ac0104da1766ed6b6d105c1a9b50144fc 
      RHEL-7.0-20121012.1-Server-x86_64-dvd1.iso

How reproducible:
Always

Steps to Reproduce:
1. basically take defaults creating a new virt image using Virtual Machine Manager
 using a local iso image.
 only change was to not pre-allocate image 
<see attached xml file>
  
Actual results:
doesn't boot falls to rdshell

Expected results:
boots

Additional info:
  RHEL-7.0-20120711.2-Server-x86_64-dvd1.iso has no problem booting properly on this machine.
I did not try any further bisecting as the other images are not readily available.

This doesn't seem to be the same as bz#829682 but that is the closest match that I was able to find in bz.
Comment 2 Ben Woodard 2012-10-24 17:04:14 EDT
summary of the above:
1) the problem is confirmed to be reproducible on F15
2) it appears that the problem is somewhere between the 7-11 compose and the 10-12 compose something changed that makes it so that rhel7's can't find the initramfs on the CD image.
Comment 4 Ben Woodard 2012-10-24 18:09:14 EDT
Since many if not all of the RHEL7 images between A2 and the 10-12 compose have been deleted, notting suggested that I try F18's alpha.

This worked as expected and so the problem appears to be with the recent RHEL7 compose and how it interacts with F15-17's sr driver.
Comment 5 Ben Woodard 2012-10-25 12:31:42 EDT
Travis Gummels tested the rhel7 installer on rhel6 and it appears to work.

I think that he used:
  libvirt-0.9.10-21.el6_3.5
  kernel-2.6.32-279.11.1
  qemu-kvm-2:0.12.1.2-2.295.el6_3.2
Comment 6 Ben Woodard 2012-10-25 12:53:42 EDT
actually gummels says that he's using:

<gummels> $ rpm -q qemu-img kernel libvirt
<gummels> qemu-img-0.12.1.2-2.295.el6_3.1.x86_64
<gummels> kernel-2.6.32-279.el6.x86_64
<gummels> kernel-2.6.32-279.2.1.el6.x86_64
<gummels> kernel-2.6.32-279.5.2.el6.x86_64
<gummels> libvirt-0.9.10-21.el6_3.4.x86_64
<gummels> I'm back  afew from that on the kernel
Comment 7 Ben Woodard 2012-10-25 15:24:58 EDT
OK this works in the 10/22 compose of RHEL7 this problem apparently solved.

Note You need to log in before you can comment on or make changes to this bug.