Bug 869476 - [virtio-win][block]Resume from S3 status guest quits automatically
[virtio-win][block]Resume from S3 status guest quits automatically
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 23:13 EDT by Min Deng
Modified: 2013-11-21 19:00 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Falling a system into Sleep (S3) with subsequent resume. Consequence: System cannot be resumed after S3 without BSOB Fix: in Seabios code Result: after updating seabios system can be resumed from S3.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 19:00:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Min Deng 2012-10-23 23:13:07 EDT
Description of problem:
The guest will quit while waking up from guest's S3 status
Version-Release number of selected component (if applicable):
virtio-win-prewhql-01-41
qemu-kvm-rhev-debuginfo-0.12.1.2-2.327.el6.x86_64
qemu-kvm-rhev-tools-0.12.1.2-2.327.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.327.el6.x86_64

How reproducible:
5 times / 3 reproduced

Steps to Reproduce:
1.boot up guest with the following CLI and install virtio block driver.
  /usr/libexec/qemu-kvm -m 2G -smp 2 -cpu host,+x2apic -usb -device usb-tablet -drive file=win2k8-R2.qcow2,format=qcow2,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=writethrough -device virtio-blk-pci,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device e1000,netdev=hostnet0,mac=10:10:1a:75:59:03,bus=pci.0,addr=0x4 -uuid `uuidgen` -rtc base=localtime -no-kvm-pit-reinjection -monitor stdio -name win2k8-64-fun -device virtio-balloon-pci,addr=0x6,bus=pci.0,id=balloon1 -chardev socket,id=111a,path=/tmp/monitor-win2k8-64-balloon-30,server,nowait -mon chardev=111a,mode=readline -cdrom /home/en_windows_server_2008_r2_standard_enterprise_datacenter_and_web_with_sp1_x64_dvd_617601.iso -drive file=disk1.qcow2,format=qcow2,if=none,id=drive-virtio1,cache=writethrough,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio1,id=virtio-blk-pci1 -drive file=disk2.qcow2,format=qcow2,if=none,id=drive-virtio2,cache=writethrough,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio2,id=virtio-blk-pci2 -drive file=disk3.qcow2,format=qcow2,if=none,id=drive-virtio3,cache=writethrough,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio3,id=virtio-blk-pci3 -drive file=disk4.qcow2,format=qcow2,if=none,id=drive-virtio4,cache=writethrough,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio4,id=virtio-blk-pci4 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -spice disable-ticketing,port=5931 -vga qxl
2.install crystal disk mark and run it on more than 3 disks
3.Do S3 and resume it back after a while 
  tips,let the Crystal Disk Mark running several minutes and then do S3/resume

Actual results:
The guest can not be resumed and quit automatically at last.

Expected results:
The guest is resumed by  keyboard or mouse.

Additional info:
Comment 1 Min Deng 2012-10-23 23:22:52 EDT
I cannot reproduce the issue if I did not use Crystal Disk Mark.
Comment 4 Ronen Hod 2012-10-29 09:09:14 EDT
This looks like an excellent test, but it is too late for RHEL6.4, and probably not a regression.
Postponed to RHEL6.5
Comment 7 Ronen Hod 2013-07-29 05:24:55 EDT
Please check with the 6.4 drivers. We think that it is solved.
The latest drivers have a regression.
Comment 8 Mike Cao 2013-07-31 02:47:41 EDT
dengmin

Pls retest it on virtio-win-prewhql-65 & virtio-win-1.6.5-5 w/ seabios-28
Comment 9 Min Deng 2013-08-01 04:13:44 EDT
Hi Mike,(In reply to Mike Cao from comment #8)
> dengmin
> 
> Pls retest it on virtio-win-prewhql-65 & virtio-win-1.6.5-5 w/ seabios-28

Hi Mike and Ronen,

   The issue was reproduced via build 41 
   Actual results:
   The guest can not be resumed and quit automatically at last.
   Expected results:
   The guest is resumed by keyboard or mouse.
   QE re-test the bug via build 66 & virti-win-1.6.5-6 with seabios 28.
Detail Steps,
1./usr/libexec/qemu-kvm -m 2G -smp 2 -cpu host,+x2apic -usb -device usb-tablet -drive file=win2k8-R2-0724.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=writethrough -device virtio-blk-pci,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device e1000,netdev=hostnet0,mac=10:10:1a:75:59:03,bus=pci.0,addr=0x4 -uuid `uuidgen` -rtc base=localtime -no-kvm-pit-reinjection -monitor stdio -name win2k8-64-fun -device virtio-balloon-pci,addr=0x6,bus=pci.0,id=balloon1 -chardev socket,id=111a,path=/tmp/monitor-win2k8-64-balloon-30,server,nowait -mon chardev=111a,mode=readline -drive file=disk1.qcow2,format=qcow2,if=none,id=drive-virtio1,cache=writethrough,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio1,id=virtio-blk-pci1 -drive file=disk2.qcow2,format=qcow2,if=none,id=drive-virtio2,cache=writethrough,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio2,id=virtio-blk-pci2 -drive file=disk3.qcow2,format=qcow2,if=none,id=drive-virtio3,cache=writethrough,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio3,id=virtio-blk-pci3 -drive file=disk4.qcow2,format=qcow2,if=none,id=drive-virtio4,cache=writethrough,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio4,id=virtio-blk-pci4 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -spice disable-ticketing,port=5931 -vga qxl

2.install crystal disk mark and run it on more than 3 disks

3.Sleep and resume it back after a while 
  Tips,let the Crystal Disk Mark running several minutes and then sleep&resume

Actual results,the guest can sleep&resume successfully.
Expected results,the guest can sleep&resume successfully.

  So the original issue has been fixed,thanks.

Best Regards,
Min
Comment 10 Mike Cao 2013-08-01 04:49:48 EDT
Move status to VERIFIED according to comment #9
Comment 12 errata-xmlrpc 2013-11-21 19:00:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1729.html

Note You need to log in before you can comment on or make changes to this bug.