Bug 869480 - errors with while configuring providers
errors with while configuring providers
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity high
: beta6
: ---
Assigned To: John Eckersberg
Dave Johnson
RHEL6.3
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 23:59 EDT by Dave Johnson
Modified: 2012-12-04 10:09 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
aeolus-configure sometimes ran into errors due to a change in status codes for API create actions (from 200 to 201). This fix updates the configuration to expect 201 instead of 200. No errors occur during "aeolus-configure".
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:09:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
aeolus-configure failure on qe-blade-02.idm.lab.bos.redhat.com (15.79 KB, text/plain)
2012-10-24 08:22 EDT, Gabriel Szasz
no flags Details
Logs from qe-blade-02.idm.lab.bos.redhat.com (84.45 KB, application/x-gzip)
2012-10-24 08:41 EDT, Gabriel Szasz
no flags Details

  None (edit)
Description Dave Johnson 2012-10-23 23:59:44 EDT
Description of problem:
=================================
Starting with puddle 6, aeolus-configure runs into errors and requires being run twice on 3 out of 4 installs.  Here are a few examples.  Running a second time seems to clear everything up.  Seems like we introduced a new race condition.

err: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Provider[ec2-us-west-1]/Web_request[provider-ec2-us-west-1]/post: change from  to https://localhost/conductor/providers.xml failed: An exception was raised when invoking web request: Invalid HTTP Return Code: 201,  was expecting one of 200

err: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Provider[ec2-ap-northeast-1]/Web_request[provider-ec2-ap-northeast-1]/post: change from  to https://localhost/conductor/providers.xml failed: An exception was raised when invoking web request: Invalid HTTP Return Code: 201, was expecting one of 200

err: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Provider[mock]/Web_request[provider-mock]/post: change from  to https://localhost/conductor/providers.xml failed: An exception was raised when invoking web request: Invalid HTTP Return Code: 201, was expecting one of 200


Version-Release number of selected component (if applicable):
====================================================================
[root@ibm-x3650-03 ~]# rpm -qa | grep aeolus | sort
aeolus-all-0.13.21-1.el6cf.noarch
aeolus-conductor-0.13.21-1.el6cf.noarch
aeolus-conductor-daemons-0.13.21-1.el6cf.noarch
aeolus-conductor-doc-0.13.21-1.el6cf.noarch
aeolus-configure-2.8.9-1.el6cf.noarch
rubygem-aeolus-cli-0.7.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch


How reproducible:  
=========================
75% - 3 out of 4 installs
Comment 1 Gabriel Szasz 2012-10-24 08:22:37 EDT
Created attachment 632736 [details]
aeolus-configure failure on qe-blade-02.idm.lab.bos.redhat.com

Terminal output of the "aeolus-configure -p mock,ec2" command executed on qe-blade-02.idm.lab.bos.redhat.com

Installed packages:
 * rubygem-aeolus-image-0.3.0-12.el6.noarch
 * aeolus-conductor-daemons-0.13.21-1.el6cf.noarch
 * aeolus-conductor-0.13.21-1.el6cf.noarch
 * rubygem-aeolus-cli-0.7.6-1.el6cf.noarch
 * aeolus-conductor-doc-0.13.21-1.el6cf.noarch
 * aeolus-all-0.13.21-1.el6cf.noarch
 * aeolus-configure-2.8.9-1.el6cf.noarch
 * deltacloud-core-vsphere-0.5.0-10.el6_2.noarch
 * deltacloud-core-rhevm-0.5.0-10.el6_2.noarch
 * deltacloud-core-ec2-0.5.0-10.el6_2.noarch
 * deltacloud-core-0.5.0-10.el6_2.noarch
 * rubygem-deltacloud-client-0.5.0-2.el6.noarch
Comment 2 Gabriel Szasz 2012-10-24 08:41:14 EDT
Created attachment 632758 [details]
Logs from qe-blade-02.idm.lab.bos.redhat.com

Attaching all aeaolus related logs from qe-blade-02.idm.lab.bos.redhat.com
Comment 4 John Eckersberg 2012-10-24 10:16:50 EDT
Looks like this is due to eec058d in conductor, which changes the status code for API create actions to 201 (from 200 previously).  I'll update configure to expect 201 instead of 200.
Comment 6 Steve Linabery 2012-10-24 15:12:21 EDT
f0dc5008a2617ed03b85dcd5b02e3e7562b3ce9b on master
a4075f6706365f9bd486ebaeb616690d17fee37f on 1.1
Comment 8 Rehana 2012-10-29 03:06:50 EDT
Retested, 

No errors during "aeolus-configure"

On

rpm -qa | grep aeolus
aeolus-configure-2.8.11-1.el6cf.noarch
aeolus-conductor-0.13.22-1.el6cf.noarch
rubygem-aeolus-cli-0.7.7-1.el6cf.noarch
aeolus-conductor-doc-0.13.22-1.el6cf.noarch
aeolus-all-0.13.22-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.22-1.el6cf.noarch

moving it to verified.
Comment 10 errata-xmlrpc 2012-12-04 10:09:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.