Bug 869481 - "Package $RPM is not signed" error only reports first package
"Package $RPM is not signed" error only reports first package
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 00:13 EDT by James Livingston
Modified: 2016-02-21 19:56 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-28 17:02:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Livingston 2012-10-24 00:13:03 EDT
If you attempt to perform a "yum update" and a package is not signed, it will fail with a "Package $RPM is not signed" error.

If more than one package is not signed, it will only report the first one it encounters. To find out all the packages that aren't signed, you need to then run "yum update -x $PACKAGE" and see if it fails again.

It would be nice if it reported all the unsigned packages when failing with that error, not just the first one.
Comment 1 James Antill 2013-05-28 17:02:28 EDT
 The problem is that the most common configuration is to have a single key for an entire repo. ... and so the entire repo. is either signed or not.
 Thus. it's often not desired to get the warning N times when you are updating N pkgs.

 If you need to do some rel-eng type checking, a tool using the yum API would be much better.

Note You need to log in before you can comment on or make changes to this bug.