Bug 869516 - Meaningless warning was given when set blank characters as ping test host
Meaningless warning was given when set blank characters as ping test host
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 03:12 EDT by Meng Liang
Modified: 2013-02-28 11:42 EST (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-8.el6
Doc Type: Bug Fix
Doc Text:
Attempts to ping a host when an invalid host name was provided yielded meaningless error messages. Now, pinging a host which cannot be reached returns the error message "ping unknown host", and pinging a host using unrecognised characters returns the error message "invalid hostname".
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:42:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen-shot of error message (17.19 KB, image/png)
2012-10-24 03:13 EDT, Meng Liang
no flags Details

  None (edit)
Description Meng Liang 2012-10-24 03:12:55 EDT
Description of problem:
Meaningless warning was given when set a blank character as the host name during ping test

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20121015.1.el6

How reproducible:
Always

Steps to Reproduce:
1.clean install rhev-hypervisor6-6.4-20121015.1.el6
2.Go to ping test in network page and enter a blank character:
  Enter Host to Ping
    Host:   __________

Actual results:
Meaningless warning was given, see the attached screenshot

Expected results:
if the host cannot be resolvable, it should return unknown host.
if the host can be resolvable, it should return ping test results.

# ping a
ping: unknown host a
# ping ""
ping: unknown host
# ping " "
ping: unknown host

Additional info:
Comment 1 Meng Liang 2012-10-24 03:13:57 EDT
Created attachment 632561 [details]
screen-shot of error message
Comment 8 errata-xmlrpc 2013-02-28 11:42:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.