This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 869517 - issues with JNI support on ARM
issues with JNI support on ARM
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: java-1.7.0-openjdk (Show other bugs)
18
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2012-10-24 03:14 EDT by Peter Robinson
Modified: 2012-10-30 11:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 11:52:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2012-10-24 03:14:58 EDT
I'm seeing issues with compilation of packages which require JNI support. 

One example is libgda:

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1217160

In configure we get the following error:
checking java compiler version... JAVA version used is Sun JRE 1.7 
checking for Java environment... in /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.9/jre
checking for /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.9/jre/include/jni.h... no
checking for /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.9/jre/jni.h... no
checking for /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.9/jre/../include/jni.h... yes
checking for /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.9/jre/../include/./jni_md.h... no
checking for /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.9/jre/../include/linux/jni_md.h... yes
checking whether JNI programs can be compiled... configure: error: Cannot compile a simple JNI program. See config.log for details.

We're not getting a different set of deps than x86 but it looks like the openjdk are slightly different from a basic grep:

$ rpm -qlp java-1.7.0-openjdk-devel-1.7.0.9-2.3.3.fc17.1.x86_64.rpm | grep jni
/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.9.x86_64/include/jni.h
/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.9.x86_64/include/linux/jni_md.h
/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.9.x86_64/tapset/hotspot_jni-1.7.0.stp
/usr/share/systemtap/tapset/x86_64/hotspot_jni-1.7.0.stp

$ rpm -qlp java-1.7.0-openjdk-devel-1.7.0.6-2.3.1.fc17.2.armv7hl.rpm | grep jni
/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.6/include/jni.h
/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.6/include/linux/jni_md.h
Comment 1 Andrew John Hughes 2012-10-30 09:16:57 EDT
These differences are benign; the ARM version uses an older version of IcedTea which supports the ARM port (hence the 6/9 difference) and doesn't yet have SystemTap support (so the .stp files are missing).

The issue here appears to lie in whatever JNI test is actually being run.  Attaching the config.log might be helpful.
Comment 2 Peter Robinson 2012-10-30 11:52:37 EDT
You are correct and it's now fixed. Thanks

Note You need to log in before you can comment on or make changes to this bug.