Bug 869614 - Update fontconfig's license field
Update fontconfig's license field
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 08:26 EDT by Marek Kašík
Modified: 2012-11-08 22:48 EST (History)
4 users (show)

See Also:
Fixed In Version: fontconfig-2.10.1-2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 22:48:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Kašík 2012-10-24 08:26:24 EDT
Description of problem:
License field of fontconfig should include also "Public Domain" and "UCD" identifiers.

Additional info:
See src/ftglue.{h,c} and src/fccache.c for Public Domain
and fc-case/CaseFolding.txt for Unicode Character Database.
Comment 1 Nicolas Mailhot 2012-10-24 10:31:09 EDT
Actually, the unicode consortium files should be split in their own package instead of being bundled in fonctonfig, perl, etc
Comment 2 Akira TAGOH 2012-10-24 21:32:25 EDT
(In reply to comment #1)
> Actually, the unicode consortium files should be split in their own package
> instead of being bundled in fonctonfig, perl, etc

Sure. fontconfig uses CaseFolding.txt to generate fccase.h and shipping it in the archive because that file is differently generated on the cross-compiling. so it isn't necessarily needed in the archive to build. but I guess the generated code is still Public Domain right? I tend to agree to have a separate package for Unicode Character Database though, it would be another issue at this point.
Comment 3 Akira TAGOH 2012-10-24 21:33:01 EDT
erm, I meant s/Public Domain/UCD/
Comment 4 Fedora Update System 2012-10-25 02:30:37 EDT
fontconfig-2.10.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fontconfig-2.10.1-2.fc18
Comment 5 Fedora Update System 2012-10-26 15:30:19 EDT
Package fontconfig-2.10.1-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fontconfig-2.10.1-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16864/fontconfig-2.10.1-2.fc18
then log in and leave karma (feedback).
Comment 6 Akira TAGOH 2012-11-08 22:48:38 EST
updates has been pushed to stable. closing.

Note You need to log in before you can comment on or make changes to this bug.