This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 869660 - After logging out, User <UNKNOWN> is shown in events for async tasks
After logging out, User <UNKNOWN> is shown in events for async tasks
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity low
: ---
: 3.2.0
Assigned To: Ravi Nori
Leonid Natapov
infra
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-10-24 09:53 EDT by Jakub Libosvar
Modified: 2016-02-10 14:43 EST (History)
12 users (show)

See Also:
Fixed In Version: sf7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log (11.60 KB, text/x-log)
2012-10-24 09:53 EDT, Jakub Libosvar
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10896 None None None Never

  None (edit)
Comment 1 Jakub Libosvar 2012-10-24 09:53:20 EDT
Created attachment 632810 [details]
engine log
Comment 2 Maor 2012-10-28 11:13:39 EDT
I think you forgot to mention that the user must be logged out from the web admin before the task was finished.
is that was the case?
Comment 3 Jakub Libosvar 2012-10-29 03:37:16 EDT
I didn't use webadmin at all, it was done via API. So basically yes, user wasn't logged in.
Comment 4 Asaf Shakarchi 2012-12-03 11:37:17 EST
This is a more general infra problem  rather than a specific issue, so this BZ is just an example of a more general problem,

This is a long invocation and involves creation of async tasks,
The problem is that async tasks 'loose' the context of the user,

In the infra level there should be a support for preserving user context.
Comment 6 Barak 2013-01-01 10:03:57 EST
It looks like the user in the event is taken at the end of the command execution, hence the session does not exist and user = UNKNOWN

Eli suggested to add the user to the command base.

In this case this should be an easy fix.
Comment 7 Ravi Nori 2013-01-10 16:15:03 EST
link : http://gerrit.ovirt.org/#/c/10896/

change id : Ic0904f9f6d9432ecac1cebee3790eae902a1329a
Comment 9 Leonid Natapov 2013-03-04 10:01:00 EST
sf9. fixed. shows the user instead of UNKNOWN.
Comment 10 Itamar Heim 2013-06-11 04:49:46 EDT
3.2 has been released
Comment 11 Itamar Heim 2013-06-11 04:49:58 EDT
3.2 has been released
Comment 12 Itamar Heim 2013-06-11 04:49:58 EDT
3.2 has been released
Comment 13 Itamar Heim 2013-06-11 04:54:18 EDT
3.2 has been released
Comment 14 Itamar Heim 2013-06-11 05:24:50 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.