Bug 869667 - when rpm --import fail rpm does not return error
when rpm --import fail rpm does not return error
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rpm (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Panu Matilainen
Patrik Kis
: Regression
Depends On:
Blocks: 871313
  Show dependency treegraph
 
Reported: 2012-10-24 10:10 EDT by Patrik Kis
Modified: 2013-02-21 05:51 EST (History)
1 user (show)

See Also:
Fixed In Version: rpm-4.8.0-31.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 871313 (view as bug list)
Environment:
Last Closed: 2013-02-21 05:51:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Patrik Kis 2012-10-24 10:10:24 EDT
Description of problem:
rpm exit with 0 even if key import fail

Version-Release number of selected component (if applicable):
rpm-4.8.0-30.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.
# gpg --gen-key
---%<----------
# gpg -k
/root/.gnupg/pubring.gpg
------------------------
pub   2048R/EF271BD7 2012-10-24
uid                  tester <test@test>
sub   2048R/EB178E96 2012-10-24

2.
# gpg --output key.exp --export 
# gpg -a --export > key.exp.txt
# touch key.0
# echo 'dwionfd39feuwqfie' > key.ascii

3.
# rpm --import key.exp ; echo $?
0
# rpm -qa gpg-pubkey*
# rpm --import key.0 ; echo $?
error: key.0: import read failed(0).
1
# rpm --import /bin/bash ; echo $?
0
# rpm --import key.ascii ; echo $?
error: key.ascii: import read failed(0).
1
# rpm --import key.exp.txt ; echo $?
0
# rpm -qa gpg-pubkey*
gpg-pubkey-ef271bd7-5087ef29

  
Actual results:
When the key cannot be exported from a file no error is returned.

Expected results:

On RHEL5 this works as expected; therefore this bug can be considered as regression.

rhel58# rpm --import key.exp ; echo $?
error: key.exp: import read failed(-1).
1
#

Additional info:
Comment 5 RHEL Product and Program Management 2012-10-30 04:41:30 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 11 errata-xmlrpc 2013-02-21 05:51:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0461.html

Note You need to log in before you can comment on or make changes to this bug.