This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 869668 - Seam2.3 jee6 example JBDS errors
Seam2.3 jee6 example JBDS errors
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Examples, Seam (Show other bugs)
2.1.0
Unspecified Unspecified
unspecified Severity medium
: CR1
: 2.1.0
Assigned To: Marek Novotny
Marek Schmidt
Seam2.3 seam-example
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 10:13 EDT by Marek Schmidt
Modified: 2012-11-30 10:34 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 869662
Environment:
Last Closed: 2012-11-30 10:34:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Schmidt 2012-10-24 10:13:52 EDT
+++ This bug was initially created as a clone of Bug #869662 +++

Description of problem:

1. The jee6 Seam2.3 example shows compile errors in the jee6-test module when imported into the JBDS. The problem is that the test module depends on the classes from the war and so uses the build-helper-maven-plugin to copy the classes (as a maven dependency on a .war artifact doesn't get its classes)

The workaround for this issue is to do a quickfix - fix project config - and do the Eclipse-suggested action "Add project 'jee6-web' to build path of 'jee6-tests'". This workaround should probably be added to the example readme file.

2. Running the app from JBDS deploys the example as "'jee6-web.war'", while 
opening a page "http://localhost:8080/jboss-seam-jee6/", which gets 404, as the context root is jee6-web. 

Also, the JNDI name is wrong in this case, so the EJBs don't work if the example is deployed from JBDS.

Workaround for this problem would be to change the artifactId to be the same as the finalName (btw. all the .war examples have this problem)

Version-Release number of selected component (if applicable):
jboss-seam-2.3.0.Final-redhat-1
JBDS 5.0.1 and JBDS 6.0.0.Beta1
Comment 1 Vaclav Dedik 2012-10-30 11:58:56 EDT
1. I replaced build-helper-maven plugin with this solution:
http://stackoverflow.com/questions/1769586/maven-war-dependency
Now it shouldn't show any compile error in any IDE.

2. I replaced finalName with the artifactId for all war examples.
Comment 3 Karel Piwko 2012-11-30 10:34:36 EST
Distributed as a part of WFK 2.1.0.GA release.

Note You need to log in before you can comment on or make changes to this bug.