Bug 869676 - Seam2.3 jpa example JBDS errors
Seam2.3 jpa example JBDS errors
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Examples, Seam (Show other bugs)
2.1.0
Unspecified Unspecified
unspecified Severity low
: CR1
: 2.1.0
Assigned To: Marek Novotny
Marek Schmidt
Seam2.3 seam-example
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 10:30 EDT by Marek Schmidt
Modified: 2013-03-22 09:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Cause: errors in JBDS due known JBIDE issue - JBIDE-12779 Consequence: Workaround (if any): None Result: the errors doesn't affect deployment of JPA example
Story Points: ---
Clone Of: 869662
Environment:
Last Closed: 2012-11-30 10:35:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Schmidt 2012-10-24 10:30:38 EDT
+++ This bug was initially created as a clone of Bug #869662 +++

Description of problem:

1. The jpa Seam2.3 example shows compile errors in the jpa-tests module when imported into the JBDS. The problem is that the test module depends on the classes from the war and so uses the build-helper-maven-plugin to copy the classes (as a maven dependency on a .war artifact doesn't get its classes)

The workaround for this issue is to do a quickfix - fix project config - and do the Eclipse-suggested action "Add project 'jpa-web' to build path of 'jpa-tests'". This workaround should probably be added to the example readme file.

2. Running the app from JBDS deploys the example as "'jpa-web.war'", while 
opening a page "http://localhost:8080/jboss-seam-jpa/", which gets 404, as the context root is jpa-web. 

Workaround for this problem would be to change the artifactId to be the same as the finalName (btw. all the .war examples have this problem)

3. a "cvc-attribute.3: The value '${loadPersistenceUnits}' of attribute 'installed' on element 'persistence:entity-manager-factory' is not valid with respect to its type, 'boolean'."  error in the components.xml due to a known JBIDE issue https://issues.jboss.org/browse/JBIDE-12779 . 

Workaround is to not use maven properties for components.xml boolean values.

Version-Release number of selected component (if applicable):
jboss-seam-2.3.0.Final-redhat-1
JBDS 5.0.1 and JBDS 6.0.0.Beta1
Comment 1 Marek Novotny 2012-11-01 09:19:01 EDT
Points 1. and 2. were fixed

Point 3. is food for Release Notes

The following JBDS Error messages are shown:

cvc-datatype-valid.1.2.3: '${loadPersistenceUnits}' is not a valid value of union type 'boolean'.

cvc-attribute.3: The value '${loadPersistenceUnits}' of attribute 'installed' on element 'persistence:entity-manager-factory' is not valid with respect to its type, 'boolean'.
Comment 3 Karel Piwko 2012-11-30 10:35:24 EST
Distributed as a part of WFK 2.1.0.GA release.

Note You need to log in before you can comment on or make changes to this bug.