Bug 869689 - Email notifications include incorrect changelog
Email notifications include incorrect changelog
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Email Notifications (Show other bugs)
4.2
Unspecified Unspecified
low Severity low (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 11:04 EDT by Mikolaj Izdebski
Modified: 2014-10-12 18:49 EDT (History)
5 users (show)

See Also:
Fixed In Version: 4.4.1012
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-05 23:40:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Simon Green 2012-11-08 23:02:39 EST
This usually happens when Bugzilla is unable to send an e-mail for the first change. If you can reproduce this error, then we can fix it (i.e. find out why the e-mail is not being sent the first time). If you cannot reproduce, there is nothing we can do to fix this issue.
Comment 2 Miroslav Franc 2013-03-19 09:58:57 EDT
(In reply to comment #1)
> This usually happens when Bugzilla is unable to send an e-mail for the first
> change. If you can reproduce this error, then we can fix it (i.e. find out
> why the e-mail is not being sent the first time). If you cannot reproduce,
> there is nothing we can do to fix this issue.

In that case I believe the old change should be simply discarded instead of sending bogus information.  The fact that bugzilla is blaming me for things I never did makes me slightly uneasy.

This is another example:

https://bugzilla.redhat.com/show_activity.cgi?id=921000


    Miroslav Franc <mfranc@redhat.com> changed:

               What    |Removed                     |Added
    ----------------------------------------------------------------------------
                     CC|ykaul@redhat.com            |
                     CC|                            |mfranc@redhat.com

I only added myself to CC.
Comment 7 Simon Green 2013-12-03 01:00:41 EST
In the see also bug, we will fix the e-mails so that even when we send multiple e-mails, they will have separate headers for each person making the change. The e-mail headers will still only refer to the person making the last change.
Comment 8 Simon Green 2013-12-05 23:40:13 EST
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.