Bug 869716 - Availability check change is not automatically picked up
Availability check change is not automatically picked up
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Agent (Show other bugs)
JON 3.1.0
All All
high Severity high
: ---
: JON 3.1.2
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On: 871873
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 11:39 EDT by bkramer
Modified: 2013-09-11 07:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 869719
: 869719 871873 (view as bug list)
Environment:
Last Closed: 2013-09-11 07:00:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 278983 None None None Never

  None (edit)
Description bkramer 2012-10-24 11:39:23 EDT
Description of problem:
When Availability check is changed, for instance from enabled to disabled, this change is not picked up by the agent and availability is still checked and server status changed depending on it's real state. 


Version-Release number of selected component (if applicable):
JON 3.1.0

How reproducible:
Every time.

Steps to Reproduce:
1. Import JBoss instance;
2. Navigate to Monitor -> Schedule (for that server instance) and disable Availability check;
3. After some time (at least 2 minutes if Availability check was initially set to 1 minute), stop the JBoss instance;
4. Execute "avail --force" on the JON Agent command line;
5. Check the status of the JBoss server;
  
Actual results:
The status of the JBoss instance changes to DOWN in JON UI. 

Expected results:
JBoss stays UP because it picks up the status of its parent resource (platform) as explained in [1]. 

Additional info:
The change in Availability check will be propagated after the agent is restarted with "--purgedata" option.

[1] https://access.redhat.com/knowledge/docs/en-US/JBoss_Operations_Network/3.1/html-single/Admin_Setting_up_Monitoring_Alerts_and_Operations/index.html#avail-backfill
Comment 1 Larry O'Leary 2012-12-12 13:50:00 EST
The impact of this issue can be pretty bad. It prevents the update of a resource's availability check interval from being modified, enabled, or disabled. The workaround is to force an inventory sync but this is a manual process. One can either execute agent command:

    inventory --sync

Or restart the agent with the --purgedata command-line argument or delete the agent's inventory.dat file. 

All workarounds are not really ideal considering they all require knowledge of this bug before updating availability metric collection schedules for inventoried resources.
Comment 3 Jay Shaughnessy 2012-12-12 15:29:46 EST
I see no reason not to CP this to 3.1.2:

commit cf8b29cf05e6fc4fea5e175431bcee99c91e376a
Author: Jay Shaughnessy <jshaughn@jshaughn.csb>
Date:   Wed Dec 12 15:26:58 2012 -0500

Set availability schedule data if present in ResourceMeasurementScheduleRequest
    
Cherry pick of master commit: 257e056801c29bc241b7c292008326be14faffb9
Comment 4 Simeon Pinder 2012-12-13 14:18:38 EST
Moving to ON_QA as new build available to test with:
https://brewweb.devel.redhat.com/buildinfo?buildID=247371
Comment 5 Sunil Kondkar 2012-12-14 08:34:14 EST
Verified on JON 3.1.2 ER5.

Followed the steps and verified that after avail --force at agent command line, the JBoss instance remains UP in JON UI.

Note You need to log in before you can comment on or make changes to this bug.