Bug 869717 - RFE: systemd should use yum protected packages configuration, as removing it would be "a bad idea"
RFE: systemd should use yum protected packages configuration, as removing it ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Schmidt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 11:40 EDT by James Antill
Modified: 2012-12-20 11:05 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:05:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2012-10-24 11:40:30 EDT
Description of problem:
 systemd should ship a file /etc/yum/protected.d/systemd with "systemd" in it (and/or any other package names which really shouldn't be removed). See "man yum.conf" etc.

 This is somewhat more important/useful/needed now because systemd has a much bigger set of requires than sysvinit ever did (and it's growing). So it's much more likely that someone could do "yum remove -r libmicrohttpd" or whatever.
Comment 1 Michal Schmidt 2012-10-24 12:47:07 EDT
Added into 195-4.
Comment 2 Fedora Update System 2012-11-09 11:45:53 EST
systemd-195-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/systemd-195-6.fc18
Comment 3 Fedora Update System 2012-11-09 16:09:44 EST
Package systemd-195-6.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-195-6.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17924/systemd-195-6.fc18
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-12-20 11:05:44 EST
systemd-195-6.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.