Bug 869729 - --autosubscribe and --activationkey should be mutually exclusive
--autosubscribe and --activationkey should be mutually exclusive
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: William Poteat
IDM QE LIST
:
Depends On:
Blocks: 771481
  Show dependency treegraph
 
Reported: 2012-10-24 12:04 EDT by Alex Wood
Modified: 2013-02-21 03:59 EST (History)
4 users (show)

See Also:
Fixed In Version: subscription-manager-1.1.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:59:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Wood 2012-10-24 12:04:26 EDT
Description of problem:
In the subscription-manager register sub-command, the --autosubscribe and --activationkey options should be mutually exclusive.

Steps to Reproduce:
1. Run subscription-manager register --autosubscribe --activationkey=YOURKEYHERE
  
Actual results:
subscription-manager attempts to auto-subscribe.

Expected results:
Error: Activation keys can not be used with --autosubscribe.
Comment 2 William Poteat 2012-10-26 08:06:43 EDT
master commit d992b09431328b4236ce95666e7598871c250afb
Comment 5 Shwetha Kallesh 2012-11-06 01:27:38 EST
[root@rhel-64-server ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.7.17-1
subscription-manager: 1.1.5-1.el6
python-rhsm: 1.1.4-1.el6


[root@rhel-64-server ~]# subscription-manager register --autosubscribe --activationkey=Shwetha
Error: Activation keys cannot be used with --autosubscribe.
Comment 7 errata-xmlrpc 2013-02-21 03:59:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.