Bug 869748 - /dns_resolvable not working on STG
/dns_resolvable not working on STG
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Master (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Ravi Sankar
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 14:04 EDT by Fotios Lindiakos
Modified: 2015-05-14 20:52 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:48:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
devenvstg.log (83.39 KB, text/x-log)
2012-11-02 04:35 EDT, Wei Sun
no flags Details

  None (edit)
Description Fotios Lindiakos 2012-10-24 14:04:31 EDT
Description of problem:
On a newly launched devenv, the /dnv_resolvable call returns an 500 error

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create application
2. Attempt to use /dns_resolvable
3.
  
Actual results:
500 error. The relevant information is:
"dnsruby can't connect to 172.16.0.23:53 from 0.0.0.0:52686, use_tcp=false, exception = Errno::EACCES, Permission denied - bind(2)"

Expected results:
Should work


Additional info:
Comment 1 Ravi Sankar 2012-10-30 12:33:23 EDT
selinux is blocking broker process to connect to ephemeral udp port. Dan Walsh is working on the fix.
Comment 2 Ravi Sankar 2012-10-31 15:55:23 EDT
https://github.com/openshift/li/pull/555
Comment 3 Xiaoli Tian 2012-10-31 22:01:36 EDT
(In reply to comment #2)
> https://github.com/openshift/li/pull/555

Move it to ON_QA since it's merged in devenv_2417.
Comment 4 Rony Gong 2012-11-01 04:36:01 EDT
Verified on devenv_2418
[qgong@localhost dev]$ curl -k -H "Accept: application/xml" --user "qgong+1@redhat.com:123456"  https://ec2-50-16-130-119.compute-1.amazonaws.com/broker/rest/domains/qgong15/applications/qjbosseap/dns_resolvable -X GET
<?xml version="1.0" encoding="UTF-8"?>
<response>
  <version>1.2</version>
  <status>ok</status>
  <messages/>
  <type>boolean</type>
  <supported-api-versions>
    <supported-api-version>1.0</supported-api-version>
    <supported-api-version>1.1</supported-api-version>
    <supported-api-version>1.2</supported-api-version>
  </supported-api-versions>
  <data>
    <datum>true</datum>
  </data>
</response>
Comment 5 Wei Sun 2012-11-02 04:34:06 EDT
This bug is reproduced on stage(devenv-stage_242),so assign back.

1.on stage
[sunwei@dhcp-8-229 dev]$ curl -k -H "Accept: application/xml" --user "wsun+1@redhat.com:redhat"  https://stg.openshift.redhat.com/broker/rest/domains/wsunstg02/applications/ewstest/dns_resolvable -X GET 
<!DOCTYPE html>
<html>
<head>
  <title>We're sorry, but something went wrong (500)</title>
  <style type="text/css">
    body { background-color: #fff; color: #666; text-align: center; font-family: arial, sans-serif; }
    div.dialog {
      width: 25em;
      padding: 0 4em;
      margin: 4em auto 0 auto;
      border: 1px solid #ccc;
      border-right-color: #999;
      border-bottom-color: #999;
    }
    h1 { font-size: 100%; color: #f00; line-height: 1.5em; }
  </style>
</head>

<body>
  <!-- This file lives in public/500.html -->
  <div class="dialog">
    <h1>We're sorry, but something went wrong.</h1>
    <p>We've been notified about this issue and we'll take a look at it shortly.</p>
  </div>
</body>
</html>

2.test on devenv-stage_242,will get error ,please refer to attachment
Comment 6 Wei Sun 2012-11-02 04:35:58 EDT
Created attachment 636970 [details]
devenvstg.log
Comment 7 Xiaoli Tian 2012-11-02 07:23:04 EDT
The following change in this pull request may be not in stage:
https://github.com/openshift/li/pull/555 

in misc/devenv/devenv.spec
+# Allow httpd to verify dns records
+getsebool httpd_verify_dns | grep -q -e 'on$' || /usr/sbin/setsebool -P httpd_verify_dns=on ||
Comment 9 Rony Gong 2012-11-05 00:26:41 EST
verified on Stage server(243)
[qgong@localhost myrawapp]$ curl -k -H "Accept: application/xml" --user "qgong@redhat.com:111111"  https://stg.openshift.redhat.com/broker/rest/domains/qgong/applications/q2sphp/dns_resolvable -X GET
<?xml version="1.0" encoding="UTF-8"?>
<response>
  <messages/>
  <status>ok</status>
  <type>boolean</type>
  <supported-api-versions>
    <supported-api-version>1.0</supported-api-version>
    <supported-api-version>1.1</supported-api-version>
    <supported-api-version>1.2</supported-api-version>
  </supported-api-versions>
  <version>1.2</version>
  <data>
    <datum>true</datum>
  </data>
</response>

Note You need to log in before you can comment on or make changes to this bug.