Bug 869810 - SELinux is preventing /usr/sbin/rngd from 'getattr' accesses on the file /proc/sys/kernel/random/poolsize.
SELinux is preventing /usr/sbin/rngd from 'getattr' accesses on the file /pro...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c48a0e9c3125cbbe3e0dcb9e17f...
:
: 869813 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 16:46 EDT by Michael Scherer
Modified: 2014-11-05 08:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:08:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-24 16:46 EDT, Michael Scherer
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-24 16:46 EDT, Michael Scherer
no flags Details

  None (edit)
Description Michael Scherer 2012-10-24 16:46:07 EDT
Description of problem:
start rngd with systemd ( systemctl start rngd )

Additional info:
libreport version: 2.0.16
kernel:         3.6.3-3.fc18.x86_64

description:
:SELinux is preventing /usr/sbin/rngd from 'getattr' accesses on the file /proc/sys/kernel/random/poolsize.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If vous pensez que rngd devrait être autorisé à accéder getattr sur poolsize file par défaut.
:Then vous devriez rapporter ceci en tant qu'anomalie.
:Vous pouvez générer un module de stratégie local pour autoriser cet accès.
:Do
:autoriser cet accès pour le moment en exécutant :
:# grep rngd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:rngd_t:s0
:Target Context                system_u:object_r:sysctl_kernel_t:s0
:Target Objects                /proc/sys/kernel/random/poolsize [ file ]
:Source                        rngd
:Source Path                   /usr/sbin/rngd
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           rng-tools-4-2.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-43.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.3-3.fc18.x86_64 #1 SMP Tue Oct
:                              23 14:55:06 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-24 22:42:30 CEST
:Last Seen                     2012-10-24 22:42:30 CEST
:Local ID                      1ea80b82-4609-4aa9-99a7-f589e0b61970
:
:Raw Audit Messages
:type=AVC msg=audit(1351111350.73:505): avc:  denied  { getattr } for  pid=2986 comm="rngd" path="/proc/sys/kernel/random/poolsize" dev="proc" ino=13453 scontext=system_u:system_r:rngd_t:s0 tcontext=system_u:object_r:sysctl_kernel_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1351111350.73:505): arch=x86_64 syscall=fstat success=yes exit=0 a0=3 a1=7fff53eaee80 a2=7fff53eaee80 a3=238 items=0 ppid=1 pid=2986 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=rngd exe=/usr/sbin/rngd subj=system_u:system_r:rngd_t:s0 key=(null)
:
:Hash: rngd,rngd_t,sysctl_kernel_t,file,getattr
:
:audit2allow
:
:#============= rngd_t ==============
:allow rngd_t sysctl_kernel_t:file getattr;
:
:audit2allow -R
:
:#============= rngd_t ==============
:allow rngd_t sysctl_kernel_t:file getattr;
:
Comment 1 Michael Scherer 2012-10-24 16:46:11 EDT
Created attachment 633023 [details]
File: type
Comment 2 Michael Scherer 2012-10-24 16:46:13 EDT
Created attachment 633024 [details]
File: hashmarkername
Comment 3 Daniel Walsh 2012-10-24 16:49:06 EDT
Fixed in selinux-policy-3.11.1-44.fc18.noarch
Comment 4 Daniel Walsh 2012-10-24 16:51:52 EDT
*** Bug 869813 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2012-10-26 11:39:58 EDT
selinux-policy-3.11.1-46.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-46.fc18
Comment 6 Fedora Update System 2012-10-26 15:29:34 EDT
Package selinux-policy-3.11.1-46.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-46.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16862/selinux-policy-3.11.1-46.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-12-20 11:08:56 EST
selinux-policy-3.11.1-46.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.