Bug 869834 - ResponseTime metrics are not collected for Apache when SNMP is not being used
ResponseTime metrics are not collected for Apache when SNMP is not being used
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- Apache (Show other bugs)
JON 3.1.0
All All
unspecified Severity high
: ER01
: JON 3.2.0
Assigned To: Thomas Segismont
Mike Foley
:
: 872275 (view as bug list)
Depends On: 869843
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 18:51 EDT by Larry O'Leary
Modified: 2014-01-02 15:33 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 869843 (view as bug list)
Environment:
Last Closed: 2014-01-02 15:33:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 20329 None None None 2012-10-24 19:30:49 EDT

  None (edit)
Description Larry O'Leary 2012-10-24 18:51:48 EDT
Description of problem:
After enabling Apache ResponseTime metrics by installing the Apache response time module (mod_rt.so) call time data is not collected and therefore, not displayed in the ON UI.

Version-Release number of selected component (if applicable):
4.4.0.JON310GA

How reproducible:
Always

Steps to Reproduce:
1. Install ON system
2. Install Apache ResponeTime module into Apache httpd[1]
3. Start Apache httpd server
4. Start ON system
5. Import httpd server into inventory
6. Enabled calltime metrics on the virtual host's monitoring > schedules page
7. Set the response time log file path and name under the virtual host's inventory > connection page
8. Generate some activity to the httpd server (http://localhost/)
9. Wait for the metric collection schedule interval to pass

[1]: https://access.redhat.com/knowledge/docs/en-US/JBoss_Operations_Network/3.1/html/Admin_Setting_up_Monitoring_Alerts_and_Operations/rt-configuration.html#Apache_Configuration

Actual results:
No calltime data is displayed on the Calltime page and the agent logs the following message when DEBUG is enabled:
    DEBUG [ResourceContainer.invoker.daemon-11] (org.rhq.plugins.apache.ApacheVirtualHostServiceComponent)- Failed to connect to SNMP agent at 127.0.0.1/1610/public - aborting metric collection...

Expected results:
Calltime data should be collected.
SNMP is not needed.

Additional info:
This is occurring because ApacheVirtualHostServiceComponent.getValues(MeasurementReport report, Set<MeasurementScheduleRequest> schedules) assumes that it is only collecting metrics from SNMP. The following lines of code break calltime metrics for Apache:

        //bail out quickly if there's no SNMP support
        if (primaryIndex < 0)
            return;
...
        if (!snmpSession.ping()) {
            log.debug("Failed to connect to SNMP agent at " + snmpSession + " - aborting metric collection...");
            return;
        }
Comment 1 Thomas Segismont 2013-06-24 12:01:16 EDT
*** Bug 872275 has been marked as a duplicate of this bug. ***
Comment 2 Thomas Segismont 2013-06-25 10:01:26 EDT
Fixed in master

commit 622b5b19cb8a784a063d61f035d72aefca807695
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Tue Jun 25 10:36:19 2013 +0200
Comment 3 Larry O'Leary 2013-09-06 10:30:08 EDT
As this is MODIFIED or ON_QA, setting milestone to ER1.
Comment 4 Filip Brychta 2013-11-18 11:07:11 EST
Verified on
Version :	
3.2.0.ER5
Build Number :	
2cb2bc9:225c796

Note You need to log in before you can comment on or make changes to this bug.