Bug 869840 - gnuradio-companion fails to start properly due to missing configs
gnuradio-companion fails to start properly due to missing configs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnuradio (Show other bugs)
18
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 19:15 EDT by Brian Harrington
Modified: 2014-03-03 19:33 EST (History)
4 users (show)

See Also:
Fixed In Version: 3.6.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:51:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace log of gnuradio-companion (1.15 MB, text/x-log)
2012-10-24 19:15 EDT, Brian Harrington
no flags Details

  None (edit)
Description Brian Harrington 2012-10-24 19:15:19 EDT
Created attachment 633104 [details]
strace log of gnuradio-companion

Description of problem:

Due to the fact that gnuradio version less than 3.6.2 do not support the -DSYSCONFDIR cmake flag, gnuradio expects configs to be in /usr/etc/ rather than /etc.  This causes programs like gnuradio-companion to fail on start.

This is exacerbated by the fact that gnuradio fails back to a config file in the path ~/.gnuradio/config.conf.  As this is not created by default (which it shouldn't be) this causes gnuradio-companion to choke.

Version-Release number of selected component (if applicable):
< 3.6.2

How reproducible:
100%

Steps to Reproduce:
1. Install gnuradio
2. Run gnuradio-companion (strace -f -o /tmp/grc.log gnuradio-companion)
3. Analyze output of /tmp/grc.log
  
Actual results:
Line #:
   5340 32283 close(7)                          = 0
   5341 32283 openat(AT_FDCWD, "/usr/etc/gnuradio/conf.d", O_RDONLY|O_NONBLOCK|O_DIRECTORY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
   5342 32283 open("/home/bharrington/.gnuradio/config.conf", O_RDONLY) = -1 ENOENT (No such file or directory)
   5343 32283 close(6)   

Expected results:


Additional info:

This can be fixed by either including the patches located here:

http://gnuradio.org/cgit/gnuradio.git/commit/?id=9b2855a4d868731a2d4a1eb03b12d5c930c5c6d0

or by updating to gnuradio 3.6.2
Comment 1 Brian Harrington 2012-10-24 19:16:42 EDT
This is tracked through gnuradio bug 492:

http://gnuradio.org/redmine/issues/492
Comment 2 Jaroslav Škarvada 2012-10-25 04:58:52 EDT
Thanks for info. The 3.6.2 update was delayed in Fedora because the upstream is using several release URLs and I didn't follow them all :)
Comment 3 Fedora Update System 2012-10-25 11:08:36 EDT
gnuradio-3.6.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnuradio-3.6.2-1.fc18
Comment 4 Fedora Update System 2012-10-26 15:40:44 EDT
Package gnuradio-3.6.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnuradio-3.6.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16947/gnuradio-3.6.2-1.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-10-28 12:33:01 EDT
Package gnuradio-3.6.2-1.fc18, gr-air-modes-0-0.5.20120905git6c7a7370.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnuradio-3.6.2-1.fc18 gr-air-modes-0-0.5.20120905git6c7a7370.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16947/gr-air-modes-0-0.5.20120905git6c7a7370.fc18,gnuradio-3.6.2-1.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-12-20 10:51:08 EST
gnuradio-3.6.2-1.fc18, gr-air-modes-0-0.5.20120905git6c7a7370.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.