Bug 869859 - virt-host-validate: Output machine readable data
virt-host-validate: Output machine readable data
Status: CLOSED DEFERRED
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All All
unspecified Severity low
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 21:18 EDT by felicitus
Modified: 2016-04-26 17:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-23 19:04:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description felicitus 2012-10-24 21:18:57 EDT
Description of problem:

Right now, virt-host-validate outputs a machine-unfriendly format for each check. If somebody writes a script which would test for certain problems in a bunch of servers, the script would need to parse the strings given back by virt-host-validate.

If strings would differ between versions, results could be false.

It has been suggested that JSON or XML output would be an option. It would also be sufficient if somebody could invoke virt-host-validate, passing a parameter to specify which test should be run, and checking return codes afterwards.
Comment 1 Dave Allan 2012-10-24 22:19:30 EDT
You should float this idea on libvir-list to see if other people are receptive to it; I saw your conversation with eblake on irc, and I also think it's a reasonable RFE, but the list is where you get everybody's attention.  You'll get the best response if you propose specifics, for example, what you think the output should look like.  XML seems like a good choice since libvirt uses it so much already.  If you get consensus on a design on the list, then you can also get advice on how to structure the code to get the patches accepted before you go to the trouble of writing anything.  That's all Dan Berrange's code, so he'll undoubtedly have some good ideas on how to do what you want, and maybe some ideas on how to use the existing code.
Comment 2 Cole Robinson 2016-03-23 19:04:42 EDT
closing per comment #1 since it doesn't seem like anything came of this

Note You need to log in before you can comment on or make changes to this bug.