This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 869909 - CVE-2012-4508 kernel: ext4: AIO vs fallocate stale data exposure [fedora-all]
CVE-2012-4508 kernel: ext4: AIO vs fallocate stale data exposure [fedora-all]
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
All Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
AcceptedNTH
: Security, SecurityTracking
Depends On:
Blocks: F18Beta-accepted/F18BetaFreezeExcept CVE-2012-4508
  Show dependency treegraph
 
Reported: 2012-10-25 02:29 EDT by Petr Matousek
Modified: 2012-11-08 04:43 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 04:43:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Matousek 2012-10-25 02:29:12 EDT
This is an automatically created tracking bug!  It was created to ensure
that one or more security vulnerabilities are fixed in affected versions
of Fedora.

For comments that are specific to the vulnerability please use bugs filed
against the "Security Response" product referenced in the "Blocks" field.

For more information see:
http://fedoraproject.org/wiki/Security/TrackingBugs

When creating a Bodhi update request, please use the bodhi submission link
noted in the next comment(s).  This will include the bug IDs of this
tracking bug as well as the relevant top-level CVE bugs.

Please also mention the CVE IDs being fixed in the RPM changelog and the
Bodhi notes field when available.

Please note: this issue affects multiple supported versions of Fedora.
Only one tracking bug has been filed; please ensure that it is only closed
when all affected versions are fixed.

Reproducers, if any, will remain confidential and never be made public, unless done so by the security team.

[bug automatically created by: add-tracking-bugs]
Comment 1 Petr Matousek 2012-10-25 02:29:21 EDT
Please use the following update submission link to create the Bodhi
request for this issue as it contains the top-level parent bug(s) as well
as this tracking bug.  This will ensure that all associated bugs get
updated when new packages are pushed to stable.

Please also ensure that the "Close bugs when update is stable" option
remains checked.

Bodhi update submission link:
https://admin.fedoraproject.org/updates/new/?type_=security&bugs=869904,869909
Comment 2 Josh Boyer 2012-10-30 13:30:57 EDT
The patch set for this has been committed to F16-F18.

Updates will come soon.
Comment 3 Fedora Update System 2012-10-31 22:12:15 EDT
kernel-3.6.5-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.6.5-2.fc18
Comment 4 Fedora Update System 2012-11-01 01:53:24 EDT
Package kernel-3.6.5-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.6.5-2.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17413/kernel-3.6.5-2.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-11-01 09:24:30 EDT
kernel-3.6.5-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.6.5-2.fc16
Comment 6 Adam Williamson 2012-11-01 16:41:56 EDT
Nominating as NTH for F18 Beta; it's a security bug in kernel, that's on the path that can't be fixed entirely by an update (vuln will still be in installer and live images).
Comment 7 Jaroslav Reznik 2012-11-01 16:48:26 EDT
+1 to NTH as it's security issue and can't be fixed by update.
Comment 8 Jóhann B. Guðmundsson 2012-11-01 17:23:58 EDT
+1 to NTH as it's security issue and can't be fixed in the installer without updating the kernel there.
Comment 9 Tim Flink 2012-11-01 17:29:58 EDT
+1 F18 beta NTH as it's a security issue that can't be fixed in the installer or livecds with an update

That makes +4 (assuming +1 from Adam), moving to AcceptedNTH
Comment 10 Adam Williamson 2012-11-08 04:43:23 EST
We have a much newer kernel stable now, for 17 and 18 at least. Closing. (Bodhi closing of bugs when updates go stable is currently broken).

Note You need to log in before you can comment on or make changes to this bug.