Bug 869934 - "subscription-manager release --list" report "Network error" against SAM 1.2.
"subscription-manager release --list" report "Network error" against SAM 1.2.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity high
: rc
: 6.4
Assigned To: candlepin-bugs
Entitlement Bugs
:
Depends On:
Blocks: 771481 sam12-tracker
  Show dependency treegraph
 
Reported: 2012-10-25 03:36 EDT by Hui Wang
Modified: 2013-02-21 03:59 EST (History)
6 users (show)

See Also:
Fixed In Version: subscription-manager-1.1.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:59:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hui Wang 2012-10-25 03:36:30 EDT
Description of problem:
OS (installed RHEL5.9-snapshot4, subscription-manager-1.0.23-1.el5) registered to SAM 1.2, "subscription-manager release --list" will report "Network error". But OS (installed RHEL6.3GA, subscription-manager-0.99.19-1.el6.x86_64) register to the same SAM 1.2, subscription-manager release --list works well.

Version-Release number of selected component (if applicable):
subscription-manager-1.0.23-1.el5
python-rhsm-1.0.10-1.el5
katello-headpin-1.1.15-2h.el6_3.noarch
candlepin-0.7.13-1.el6_3.noarch
candlepin-tomcat6-0.7.13-1.el6_3.noarch
thumbslug-0.0.24-1.el6_2.noarch

How reproducible:
100%

Steps to Reproduce:
1. Register the OS to SAM
# subscription-manager register
Username: admin
Password: 
The system has been registered with id: fae80883-c8b9-4df3-9c63-41260f2cd903 

2. Subscribe one subscription 
# subscription-manager list --available
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+
Subscription Name:    	Resilient Storage (8 sockets)
SKU:                  	RH1316844
Pool Id:              	8ac28d403a72c03e013a72c4822c0092
Quantity:             	18
Service Level:        	Layered
Service Type:         	L1-L3
Multi-Entitlement:    	No
Ends:                 	02/24/2013
Machine Type:         	physical

Subscription Name:    	60 Day Supported CloudForms Evaluation
SKU:                  	SER0408
Pool Id:              	8ac28d403a72c03e013a72c481340083
Quantity:             	22
Service Level:        	Premium
Service Type:         	L1-L3
Multi-Entitlement:    	No
Ends:                 	01/01/2013
Machine Type:         	physical

Subscription Name:    	Red Hat Employee Subscription
SKU:                  	SYS0395
Pool Id:              	8ac28d403a72c03e013a72c4826b00a1
Quantity:             	29
Service Level:        	None
Service Type:         	None
Multi-Entitlement:    	No
Ends:                 	01/01/2022
Machine Type:         	physical

Subscription Name:    	Scalable File System (8 sockets)
SKU:                  	RH1416373
Pool Id:              	8ac28d403a72c03e013a72c482ba00b5
Quantity:             	10
Service Level:        	Layered
Service Type:         	L1-L3
Multi-Entitlement:    	No
Ends:                 	02/24/2013
Machine Type:         	physical

[root@localhost ~]# subscription-manager subscribe --pool=8ac28d403a72c03e013a72c4826b00a1
Successfully consumed a subscription for: Red Hat Employee Subscription

3. List the available release
# subscription-manager release --list
Network error, unable to connect to server.
Please see /var/log/rhsm/rhsm.log for more information.
  
Actual results:
# subscription-manager release --list
Network error, unable to connect to server.
Please see /var/log/rhsm/rhsm.log for more information.

Expected results:
# subscription-manager release --list
5.6
5.7
5.8
5.9
5Server





Additional info:

1.[root@virtlab-66-84-18 rhsm]# subscription-manager release --list
Network error, unable to connect to server.
Please see /var/log/rhsm/rhsm.log for more information.
[root@virtlab-66-84-18 rhsm]# tail -f /var/log/rhsm/rhsm.log
    self.endheaders()
  File "/usr/lib64/python2.4/httplib.py", line 804, in endheaders
    self._send_output()
  File "/usr/lib64/python2.4/httplib.py", line 685, in _send_output
    self.send(msg)
  File "/usr/lib64/python2.4/httplib.py", line 652, in send
    self.connect()
  File "/usr/lib64/python2.4/site-packages/M2Crypto/httpslib.py", line 49, in connect
    for (family, _, _, _, _) in \
gaierror: (-2, 'Name or service not known')

2. cat /etc/rhsm/rhsm.conf
[server]
# Server hostname:
hostname = samserv.redhat.com

# Server prefix:
prefix = /subscription

# Server port:
port = 443

# Set to 1 to disable certificate validation:
insecure = 0

# Set the depth of certs which should be checked
# when validating a certificate
ssl_verify_depth = 3

# Server CA certificate location:
ca_cert_dir = /etc/rhsm/ca/

# an http proxy server to use
proxy_hostname =

# port for http proxy server
proxy_port =

# user name for authenticating to an http proxy, if needed
proxy_user =

# password for basic http proxy auth, if needed
proxy_password =

[rhsm]
# Content base URL:
baseurl=https://samserv.redhat.com:8088

# Default CA cert to use when generating yum repo configs:
repo_ca_cert = %(ca_cert_dir)scandlepin-local.pem
...

3. If register the OS (installed RHEL5.9-snapshot4, subscription-manager-1.0.23-1.el5) registered to SAM 1.1 (katello-headpin-0.2.13-1.el6_2.noarch, katello-headpin-0.2.13-1.el6_2.noarch), 
#subscription-manager release --list 
Error: The 'release' command is not supported by the server.
Comment 1 Tom McKay 2012-10-31 13:12:55 EDT
subscription-manager does not get its list of available releases from SAM, but instead goes directly to the CDN. Can you confirm that the manifest used was not revoked and that the system was subscribed successfully and consuming subscriptions?
Comment 2 Og Maciel 2012-10-31 14:55:03 EDT
[root@qeclient11 ~]# subscription-manager list --available
No available subscription pools to list
[root@qeclient11 ~]# subscription-manager release --list
Network error, unable to connect to server.
Please see /var/log/rhsm/rhsm.log for more information.
Comment 3 Tom McKay 2012-11-05 08:02:04 EST
Assigning to James so he can give feedback.
Comment 4 Tom McKay 2012-11-05 10:30:21 EST
rhsm.log

> 2012-11-05 10:28:29,401 [INFO]  @connection.py:484 - Using certificate authentication: key = /etc/pki/consumer/key.pem, cert = /etc/pki/consumer/cert.pem, ca = /etc/rhsm/ca/, insecure = False
> 2012-11-05 10:28:29,401 [INFO]  @connection.py:495 - Connection Built: host: rhel62-sam12, port: 443, handler: /sam/api
> 2012-11-05 10:28:29,401 [DEBUG]  @connection.py:147 - ContectConnection
> 2012-11-05 10:28:29,532 [DEBUG]  @cert_sorter.py:107 - Sorting product and entitlement cert status for: 2012-11-05 15:28:29.532503+00:00
> 2012-11-05 10:28:29,536 [DEBUG]  @cert_sorter.py:160 - Installed product IDs: ['69', '83']
> 2012-11-05 10:28:29,604 [DEBUG]  @cert_sorter.py:176 - Checking certificate: 5235744500234977804
> 2012-11-05 10:28:29,611 [DEBUG]  @cert_sorter.py:287 -   system has 1 sockets, 8 covered by entitlement
> 2012-11-05 10:28:29,616 [DEBUG]  @cert_sorter.py:176 - Checking certificate: 4321842981385582122
> 2012-11-05 10:28:29,618 [DEBUG]  @cert_sorter.py:287 -   system has 1 sockets, 8 covered by entitlement
> 2012-11-05 10:28:29,663 [DEBUG]  @cert_sorter.py:113 - valid entitled products: ['83', '69']
> 2012-11-05 10:28:29,664 [DEBUG]  @cert_sorter.py:114 - expired entitled products: []
> 2012-11-05 10:28:29,664 [DEBUG]  @cert_sorter.py:115 - partially entitled products: []
> 2012-11-05 10:28:29,664 [DEBUG]  @cert_sorter.py:116 - unentitled products: []
> 2012-11-05 10:28:29,664 [DEBUG]  @cert_sorter.py:117 - future products: []
> 2012-11-05 10:28:29,664 [DEBUG]  @cert_sorter.py:118 - partial stacks: []
> 2012-11-05 10:28:29,665 [DEBUG]  @cert_sorter.py:119 - valid stacks: []
> 2012-11-05 10:28:29,666 [DEBUG]  @cert_sorter.py:107 - Sorting product and entitlement cert status for: 2012-11-05 15:28:29.666439+00:00
> 2012-11-05 10:28:29,669 [DEBUG]  @cert_sorter.py:160 - Installed product IDs: ['69', '83']
> 2012-11-05 10:28:29,734 [DEBUG]  @cert_sorter.py:176 - Checking certificate: 5235744500234977804
> 2012-11-05 10:28:29,736 [DEBUG]  @cert_sorter.py:287 -   system has 1 sockets, 8 covered by entitlement
> 2012-11-05 10:28:29,741 [DEBUG]  @cert_sorter.py:176 - Checking certificate: 4321842981385582122
> 2012-11-05 10:28:29,743 [DEBUG]  @cert_sorter.py:287 -   system has 1 sockets, 8 covered by entitlement
> 2012-11-05 10:28:29,788 [DEBUG]  @cert_sorter.py:113 - valid entitled products: ['83', '69']
> 2012-11-05 10:28:29,788 [DEBUG]  @cert_sorter.py:114 - expired entitled products: []
> 2012-11-05 10:28:29,788 [DEBUG]  @cert_sorter.py:115 - partially entitled products: []
> 2012-11-05 10:28:29,789 [DEBUG]  @cert_sorter.py:116 - unentitled products: []
> 2012-11-05 10:28:29,789 [DEBUG]  @cert_sorter.py:117 - future products: []
> 2012-11-05 10:28:29,789 [DEBUG]  @cert_sorter.py:118 - partial stacks: []
> 2012-11-05 10:28:29,789 [DEBUG]  @cert_sorter.py:119 - valid stacks: []
> 2012-11-05 10:28:29,984 [INFO]  @release.py:138 - No matching products with RHEL product tags found
> 2012-11-05 10:28:29,985 [INFO]  @release.py:138 - No matching products with RHEL product tags found
> 2012-11-05 10:28:29,985 [DEBUG]  @connection.py:195 - Loading CA certificate: '/etc/pki/entitlement/5235744500234977804.pem'
> 2012-11-05 10:28:29,986 [DEBUG]  @connection.py:195 - Loading CA certificate: '/etc/pki/entitlement/4321842981385582122.pem'
> 2012-11-05 10:28:29,990 [ERROR]  @managercli.py:101 - exception caught in subscription-manager
> 2012-11-05 10:28:29,991 [ERROR]  @managercli.py:102 - [Errno -2] Name or service not known
> Traceback (most recent call last):
>   File "/usr/sbin/subscription-manager", line 79, in <module>
>     sys.exit(abs(main() or 0))
>   File "/usr/sbin/subscription-manager", line 70, in main
>     return managercli.CLI().main()
>   File "/usr/share/rhsm/subscription_manager/managercli.py", line 1771, in main
>     return cmd.main()
>   File "/usr/share/rhsm/subscription_manager/managercli.py", line 280, in main
>     return_code = self._do_command()
>   File "/usr/share/rhsm/subscription_manager/managercli.py", line 1045, in _do_command
>     releases = self.release_backend.get_releases()
>   File "/usr/share/rhsm/subscription_manager/release.py", line 98, in get_releases
>     data = self.content_connection.get_versions(listing_path)
>   File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 213, in get_versions
>     results = self._request("GET", handler, body="")
>   File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 181, in _request
>     conn.request("GET", handler, body="", headers={"Host": "%s:%s" % (self.host, self.ssl_port), "Content-Length": "0"} )
>   File "/usr/lib64/python2.6/httplib.py", line 914, in request
>     self._send_request(method, url, body, headers)
>   File "/usr/lib64/python2.6/httplib.py", line 951, in _send_request
>     self.endheaders()
>   File "/usr/lib64/python2.6/httplib.py", line 908, in endheaders
>     self._send_output()
>   File "/usr/lib64/python2.6/httplib.py", line 780, in _send_output
>     self.send(msg)
>   File "/usr/lib64/python2.6/httplib.py", line 739, in send
>     self.connect()
>   File "/usr/lib64/python2.6/site-packages/M2Crypto/httpslib.py", line 50, in connect
>     self.sock.connect((self.host, self.port))
>   File "/usr/lib64/python2.6/site-packages/M2Crypto/SSL/Connection.py", line 181, in connect
>     self.socket.connect(addr)
>   File "<string>", line 1, in connect
> gaierror: [Errno -2] Name or service not known
Comment 5 Adrian Likins 2012-11-05 12:11:52 EST
Looks like subscription-manager 1.0.x get's this wrong since 1.0.4 or so.

If baseurl has a port number on it, it is currently ignore with rhel59 versions
of subscription-mananger, so connections to foo:243 are attempted as
a connect to hostname "foo:243" instead of a hostname of "foo" and port of "243".

When it get's the rhsm.baseurl from /etc/rhsm/rhsm.conf, it uses
urlparse.urlparse to parse that into hostname, port, etc. 


Looks like as of 4f0d60d138422939cf5ebd2be5a04f6d201d08d4, we switch
from using:

   parsed_url = urlparse.urlparse(cdn_url)
   port = parsed_url.port

to:
   parsed_url = urlparse.urlparse(cdn_url)
   port = parsed_url[2]

Change was because parsed_url.port isn't supported on python2.4. However,
parsed_url[2] is not the same as parsed_url.port. 

On python2.4 (aka, rhel5) urlparse doesn't support pulling out the port info
directly. It retures "netloc" which is "hostname:port". 



The two places we use this is where we create the connection info for gathering the "release" info, in both managercli, and managergui.py. managergui.py has an additional bug in that it ignore the port altogether and always uses the default.

So, if cdn (or a thumbslug proxy to a cdn) needs to specify a port (not the
default 443), "subscription-manager release --list" will fail with a name resolution error. The gui equilivent (the preferences dialog) will do the same. 

We already have a utils.parse_baseurl_info that should handle this correctly, so fix is to just use that.
Comment 8 Adrian Likins 2012-11-08 16:28:28 EST
commit 39e8dfdf120bd1e4b5152c0e2abcdd294cb4fd39
Author: Adrian Likins <alikins@redhat.com>
Date:   Mon Nov 5 13:22:38 2012 -0500

    869934: make "release" related cdn usage use proper urlparse
    
    We were incorrectly parsing rhsm.baseurl when we were
    creating connection objects for use with release related
    commands. Update them to use parse_baseurl_info.
    
    This fixes issues using "subscription-manager release --list"
    with cdns that used a non default port (for example, a
    system pointing at a thumbslug proxy).

will land in 1.1.6-1

This is in the tree already, can I get a pm_ack+ and devel_ack+?
Comment 11 Hui Wang 2012-11-22 02:15:07 EST
[root@dhcp-66-82-166 ~]# subscription-manager release --list
No release versions available, please check subscriptions.
^^^^^^^^^^^^^^^Still can't list the release version

[root@dhcp-66-82-166 ~]# cat /var/log/rhsm/rhsm.log 
2012-11-22 15:13:43,243 [DEBUG]  @profile.py:95 - Loading current RPM profile.
2012-11-22 15:13:43,491 [INFO]  @managercli.py:252 - Client Versions: {'python-rhsm': '1.1.6-1.el6', 'subscription-manager': '1.1.10-1.el6'} 
2012-11-22 15:13:43,492 [INFO]  @connection.py:512 - Using certificate authentication: key = /etc/pki/consumer/key.pem, cert = /etc/pki/consumer/cert.pem, ca = /etc/rhsm/ca/, insecure = False
2012-11-22 15:13:43,492 [INFO]  @connection.py:523 - Connection Built: host: samserv.redhat.com, port: 443, handler: /subscription
2012-11-22 15:13:43,493 [INFO]  @connection.py:519 - Using no auth
2012-11-22 15:13:43,493 [INFO]  @connection.py:523 - Connection Built: host: samserv.redhat.com, port: 443, handler: /subscription
2012-11-22 15:13:43,582 [DEBUG]  @connection.py:334 - Loading CA PEM certificates from: /etc/rhsm/ca/
2012-11-22 15:13:43,582 [DEBUG]  @connection.py:316 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2012-11-22 15:13:43,583 [DEBUG]  @connection.py:316 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2012-11-22 15:13:43,584 [DEBUG]  @connection.py:316 - Loading CA certificate: '/etc/rhsm/ca/candlepin-local.pem'
2012-11-22 15:13:43,585 [DEBUG]  @connection.py:355 - Making request: GET /subscription/
2012-11-22 15:13:43,627 [DEBUG]  @connection.py:368 - Response status: 200
2012-11-22 15:13:43,628 [DEBUG]  @connection.py:539 - Server supports the following resources:
2012-11-22 15:13:43,628 [DEBUG]  @connection.py:540 - {'status': '/api/status/', 'organizations': '/api/organizations/', 'users': '/api/users/', 'roles': '/api/roles/', 'providers': '/api/providers/', 'environments': '/api/environments/', 'entitlements': '/api/entitlements/', 'systems': '/api/systems/', 'activation_keys': '/api/activation_keys/', 'consumers': '/api/consumers/'}
2012-11-22 15:13:43,629 [DEBUG]  @connection.py:334 - Loading CA PEM certificates from: /etc/rhsm/ca/
2012-11-22 15:13:43,629 [DEBUG]  @connection.py:316 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2012-11-22 15:13:43,630 [DEBUG]  @connection.py:316 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2012-11-22 15:13:43,630 [DEBUG]  @connection.py:316 - Loading CA certificate: '/etc/rhsm/ca/candlepin-local.pem'
2012-11-22 15:13:43,631 [DEBUG]  @connection.py:355 - Making request: GET /subscription/status
2012-11-22 15:13:43,668 [DEBUG]  @connection.py:368 - Response status: 200
2012-11-22 15:13:43,671 [DEBUG]  @connection.py:334 - Loading CA PEM certificates from: /etc/rhsm/ca/
2012-11-22 15:13:43,672 [DEBUG]  @connection.py:316 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2012-11-22 15:13:43,672 [DEBUG]  @connection.py:316 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2012-11-22 15:13:43,673 [DEBUG]  @connection.py:316 - Loading CA certificate: '/etc/rhsm/ca/candlepin-local.pem'
2012-11-22 15:13:43,674 [DEBUG]  @connection.py:355 - Making request: GET /subscription/status
2012-11-22 15:13:43,707 [DEBUG]  @connection.py:368 - Response status: 200
2012-11-22 15:13:43,708 [INFO]  @managercli.py:263 - Server Versions: {'candlepin': '1.2.6-2h.el6_3-Headpin', 'server-type': 'Red Hat Subscription Management'} 
2012-11-22 15:13:43,709 [DEBUG]  @connection.py:165 - ContectConnection
2012-11-22 15:13:43,712 [DEBUG]  @connection.py:334 - Loading CA PEM certificates from: /etc/rhsm/ca/
2012-11-22 15:13:43,713 [DEBUG]  @connection.py:316 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2012-11-22 15:13:43,714 [DEBUG]  @connection.py:316 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2012-11-22 15:13:43,715 [DEBUG]  @connection.py:316 - Loading CA certificate: '/etc/rhsm/ca/candlepin-local.pem'
2012-11-22 15:13:43,716 [DEBUG]  @connection.py:355 - Making request: GET /subscription/consumers/d43413e5-200d-4eb0-bba0-212ebb40b1dc
2012-11-22 15:13:44,031 [DEBUG]  @connection.py:368 - Response status: 200
2012-11-22 15:13:44,294 [DEBUG]  @cert_sorter.py:116 - Sorting product and entitlement cert status for: 2012-11-22 07:13:44.293607+00:00
2012-11-22 15:13:44,299 [DEBUG]  @cert_sorter.py:169 - Installed product IDs: ['69']
2012-11-22 15:13:52,687 [DEBUG]  @cert_sorter.py:185 - Checking certificate: 6015201578430053133
2012-11-22 15:13:52,687 [DEBUG]  @cert_sorter.py:298 -   system has 1 sockets, 128 covered by entitlement
2012-11-22 15:13:52,687 [DEBUG]  @cert_sorter.py:122 - valid entitled products: ['69']
2012-11-22 15:13:52,688 [DEBUG]  @cert_sorter.py:123 - expired entitled products: []
2012-11-22 15:13:52,688 [DEBUG]  @cert_sorter.py:124 - partially entitled products: []
2012-11-22 15:13:52,688 [DEBUG]  @cert_sorter.py:125 - unentitled products: []
2012-11-22 15:13:52,688 [DEBUG]  @cert_sorter.py:126 - future products: []
2012-11-22 15:13:52,688 [DEBUG]  @cert_sorter.py:127 - partial stacks: []
2012-11-22 15:13:52,688 [DEBUG]  @cert_sorter.py:128 - valid stacks: []
2012-11-22 15:13:52,689 [INFO]  @certlib.py:130 - Entitlements are valid for today: 2012-11-22 07:13:40.068243+00:00
2012-11-22 15:13:52,689 [DEBUG]  @cert_sorter.py:116 - Sorting product and entitlement cert status for: 2012-11-23 07:13:40.068243+00:00
2012-11-22 15:13:52,689 [DEBUG]  @cert_sorter.py:169 - Installed product IDs: ['69']
2012-11-22 15:13:52,689 [DEBUG]  @cert_sorter.py:185 - Checking certificate: 6015201578430053133
2012-11-22 15:13:52,689 [DEBUG]  @cert_sorter.py:298 -   system has 1 sockets, 128 covered by entitlement
2012-11-22 15:13:52,690 [DEBUG]  @cert_sorter.py:122 - valid entitled products: ['69']
2012-11-22 15:13:52,690 [DEBUG]  @cert_sorter.py:123 - expired entitled products: []
2012-11-22 15:13:52,690 [DEBUG]  @cert_sorter.py:124 - partially entitled products: []
2012-11-22 15:13:52,690 [DEBUG]  @cert_sorter.py:125 - unentitled products: []
2012-11-22 15:13:52,690 [DEBUG]  @cert_sorter.py:126 - future products: []
2012-11-22 15:13:52,691 [DEBUG]  @cert_sorter.py:127 - partial stacks: []
2012-11-22 15:13:52,691 [DEBUG]  @cert_sorter.py:128 - valid stacks: []
2012-11-22 15:13:52,691 [INFO]  @certlib.py:141 - Entitlements are valid for tomorrow: 2012-11-23 07:13:40.068243+00:00
2012-11-22 15:13:52,691 [INFO]  @certlib.py:148 - Auto-heal check complete.
2012-11-22 15:13:52,996 [DEBUG]  @profile.py:95 - Loading current RPM profile.
2012-11-22 15:13:53,241 [INFO]  @connection.py:512 - Using certificate authentication: key = /etc/pki/consumer/key.pem, cert = /etc/pki/consumer/cert.pem, ca = /etc/rhsm/ca/, insecure = False
2012-11-22 15:13:53,241 [INFO]  @connection.py:523 - Connection Built: host: samserv.redhat.com, port: 443, handler: /subscription
2012-11-22 15:13:53,601 [DEBUG]  @cert_sorter.py:116 - Sorting product and entitlement cert status for: 2012-11-22 07:13:53.600976+00:00
2012-11-22 15:13:53,604 [DEBUG]  @cert_sorter.py:169 - Installed product IDs: ['69']
2012-11-22 15:13:57,177 [DEBUG]  @cert_sorter.py:185 - Checking certificate: 6015201578430053133
2012-11-22 15:13:57,178 [DEBUG]  @cert_sorter.py:298 -   system has 1 sockets, 128 covered by entitlement
2012-11-22 15:13:57,178 [DEBUG]  @cert_sorter.py:122 - valid entitled products: ['69']
2012-11-22 15:13:57,178 [DEBUG]  @cert_sorter.py:123 - expired entitled products: []
2012-11-22 15:13:57,178 [DEBUG]  @cert_sorter.py:124 - partially entitled products: []
2012-11-22 15:13:57,178 [DEBUG]  @cert_sorter.py:125 - unentitled products: []
2012-11-22 15:13:57,179 [DEBUG]  @cert_sorter.py:126 - future products: []
2012-11-22 15:13:57,179 [DEBUG]  @cert_sorter.py:127 - partial stacks: []
2012-11-22 15:13:57,179 [DEBUG]  @cert_sorter.py:128 - valid stacks: []
2012-11-22 15:13:57,179 [DEBUG]  @cert_sorter.py:116 - Sorting product and entitlement cert status for: 2012-11-22 07:13:57.179655+00:00
2012-11-22 15:13:57,179 [DEBUG]  @cert_sorter.py:169 - Installed product IDs: ['69']
2012-11-22 15:13:57,180 [DEBUG]  @cert_sorter.py:185 - Checking certificate: 6015201578430053133
2012-11-22 15:13:57,180 [DEBUG]  @cert_sorter.py:298 -   system has 1 sockets, 128 covered by entitlement
2012-11-22 15:13:57,180 [DEBUG]  @cert_sorter.py:122 - valid entitled products: ['69']
2012-11-22 15:13:57,180 [DEBUG]  @cert_sorter.py:123 - expired entitled products: []
2012-11-22 15:13:57,180 [DEBUG]  @cert_sorter.py:124 - partially entitled products: []
2012-11-22 15:13:57,181 [DEBUG]  @cert_sorter.py:125 - unentitled products: []
2012-11-22 15:13:57,181 [DEBUG]  @cert_sorter.py:126 - future products: []
2012-11-22 15:13:57,181 [DEBUG]  @cert_sorter.py:127 - partial stacks: []
2012-11-22 15:13:57,181 [DEBUG]  @cert_sorter.py:128 - valid stacks: []
2012-11-22 15:13:57,182 [INFO]  @release.py:148 - No matching products with RHEL product tags found
2012-11-22 15:13:57,182 [INFO]  @release.py:148 - No matching products with RHEL product tags found
2012-11-22 15:13:57,182 [INFO]  @release.py:148 - No matching products with RHEL product tags found
2012-11-22 15:13:57,182 [INFO]  @release.py:148 - No matching products with RHEL product tags found
2012-11-22 15:13:57,182 [INFO]  @release.py:148 - No matching products with RHEL product tags found
2012-11-22 15:13:57,183 [INFO]  @release.py:148 - No matching products with RHEL product tags found
2012-11-22 15:13:57,183 [INFO]  @release.py:148 - No matching products with RHEL product tags found
2012-11-22 15:13:57,183 [INFO]  @release.py:148 - No matching products with RHEL product tags found
2012-11-22 15:13:57,183 [INFO]  @release.py:148 - No matching products with RHEL product tags found
2012-11-22 15:13:57,183 [INFO]  @release.py:148 - No matching products with RHEL product tags found
2012-11-22 15:13:57,184 [INFO]  @release.py:148 - No matching products with RHEL product tags found
2012-11-22 15:13:57,184 [INFO]  @release.py:148 - No matching products with RHEL product tags found
2012-11-22 15:13:57,185 [DEBUG]  @connection.py:213 - Loading CA certificate: '/etc/pki/entitlement/6015201578430053133.pem'
Comment 12 Hui Wang 2012-11-22 02:22:26 EST
[root@dhcp-66-82-166 ~]# subscription-manager register
Username: admin
Password: 
The system has been registered with id: 42879261-c509-47aa-a704-460e38c17f74 
[root@dhcp-66-82-166 ~]# subscription-manager subscribe --auto
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed

[root@dhcp-66-82-166 ~]# subscription-manager release --list
No release versions available, please check subscriptions.

Test version:
subscription-manager-gui-1.1.10-1.el6.x86_64
subscription-manager-1.1.10-1.el6.x86_64
subscription-manager-firstboot-1.1.10-1.el6.x86_64
candlepin-0.7.19-1.el6_3.noarch
katello-headpin-1.2.6-2h.el6_3.noarch
thumbslug-0.0.27-1.el6_3.noarch
Comment 13 Hui Wang 2012-11-22 04:21:35 EST
Verified the bug, the result is PASS.

steps: 
[root@localhost pki]# subscription-manager register 
Username: admin
Password: 
The system has been registered with id: 398aa703-9f54-4723-92dd-8040e595cb2d 
[root@localhost pki]# subscription-manager list --available
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+
Subscription Name:    	Resilient Storage (8 sockets)
SKU:                  	RH1316844
Pool Id:              	8ac28dd53b2762a1013b276c059900d1
Quantity:             	18
Service Level:        	Layered
Service Type:         	L1-L3
Multi-Entitlement:    	No
Ends:                 	02/23/2013
System Type:          	Physical

Subscription Name:    	Scalable File System (8 sockets)
SKU:                  	RH1416373
Pool Id:              	8ac28dd53b2762a1013b276c056d00c1
Quantity:             	10
Service Level:        	Layered
Service Type:         	L1-L3
Multi-Entitlement:    	No
Ends:                 	02/23/2013
System Type:          	Physical

Subscription Name:    	Red Hat Employee Subscription
SKU:                  	SYS0395
Pool Id:              	8ac28dd53b2762a1013b276c052400ac
Quantity:             	50
Service Level:        	None
Service Type:         	None
Multi-Entitlement:    	No
Ends:                 	09/26/2013
System Type:          	Physical

Subscription Name:    	60 Day Supported CloudForms Evaluation
SKU:                  	SER0408
Pool Id:              	8ac28dd53b2762a1013b276c04ac009f
Quantity:             	30
Service Level:        	Premium
Service Type:         	L1-L3
Multi-Entitlement:    	No
Ends:                 	12/31/2012
System Type:          	Physical

Subscription Name:    	Red Hat Enterprise Linux Server for HPC Compute Node, Self-support (8 sockets) (Up to 1 guest)
SKU:                  	RH0604852
Pool Id:              	8ac28dd53b2762a1013b276c04200091
Quantity:             	25
Service Level:        	Self-support
Service Type:         	L1-L3
Multi-Entitlement:    	No
Ends:                 	12/20/2012
System Type:          	Physical

[root@localhost pki]# subscription-manager subscribe --pool=8ac28dd53b2762a1013b276c052400ac
Successfully attached a subscription for: Red Hat Employee Subscription
[root@localhost pki]# subscription-manager release --list
+-------------------------------------------+
          Available Releases
+-------------------------------------------+
6.1
6.2
6.3
6Server


Test version:
subscription-manager-gui-1.1.10-1.el6.x86_64
subscription-manager-1.1.10-1.el6.x86_64
subscription-manager-firstboot-1.1.10-1.el6.x86_64
candlepin-0.7.19-1.el6_3.noarch
katello-headpin-1.2.6-2h.el6_3.noarch
thumbslug-0.0.27-1.el6_3.noarch
Comment 15 errata-xmlrpc 2013-02-21 03:59:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.