This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 869945 - connect to a stopped spice would lead qemu core dump
connect to a stopped spice would lead qemu core dump
Status: CLOSED DUPLICATE of bug 867405
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-server (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Uri Lublin
Desktop QE
: Regression
Depends On:
Blocks: 869958
  Show dependency treegraph
 
Reported: 2012-10-25 04:02 EDT by Xiaoqing Wei
Modified: 2012-11-15 12:46 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 869958 (view as bug list)
Environment:
Last Closed: 2012-11-15 12:46:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
core file: bunzip to decompress (2.19 MB, application/octet-stream)
2012-10-25 04:10 EDT, Xiaoqing Wei
no flags Details

  None (edit)
Description Xiaoqing Wei 2012-10-25 04:02:42 EDT
Description of problem:

connect to a stopped spice would lead qemu core dump

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.331.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.331.el6.x86_64
How reproducible:

100%

Steps to Reproduce:
1. boot a vm, w/ spice , w/ -S
eg: qemu-kvm -vga qxl -spice port=8000,disable-ticketing -S
2. connect to that qemu w/ spice-client:
spicec -h $host_ip -p 8000
3.
  
Actual results:
qemu core dump

Expected results:
qemu work well

Additional info:

Tried same steps on qemu-kvm-0.12.1.2-2.295.el6.x86_64, works *WELL*, so it's a Regression
Comment 1 Xiaoqing Wei 2012-10-25 04:10:04 EDT
Created attachment 633220 [details]
core file: bunzip to decompress

Original core has been uploaded.

(gdb) bt
#0  0x00007fa103b648a5 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x00007fa103b66085 in abort () at abort.c:92
#2  0x00007fa103b5da1e in __assert_fail_base (fmt=<value optimized out>, assertion=
    0x7fa1063d0c38 "qemu_spice_display_is_running(&d->ssd)", file=0x7fa1063d0b28 "/builddir/build/BUILD/qemu-kvm-0.12.1.2/hw/qxl.c", 
    line=<value optimized out>, function=<value optimized out>) at assert.c:96
#3  0x00007fa103b5dae0 in __assert_fail (assertion=0x7fa1063d0c38 "qemu_spice_display_is_running(&d->ssd)", file=
    0x7fa1063d0b28 "/builddir/build/BUILD/qemu-kvm-0.12.1.2/hw/qxl.c", line=1658, function=0x7fa1063d1820 "qxl_send_events")
    at assert.c:105
#4  0x00007fa106390c5d in qxl_send_events (d=0x7fa1086bc840, events=16) at /usr/src/debug/qemu-kvm-0.12.1.2/hw/qxl.c:1658
#5  0x00007fa10439c7a2 in handle_new_display_channel (opaque=0x7f9fdc0008c0, payload=0x7f9fdc1d80a0) at red_worker.c:10370
#6  handle_dev_display_connect (opaque=0x7f9fdc0008c0, payload=0x7f9fdc1d80a0) at red_worker.c:11216
#7  0x00007fa10437ccc7 in dispatcher_handle_single_read (dispatcher=0x7fa1072ca1d8) at dispatcher.c:139
#8  dispatcher_handle_recv_read (dispatcher=0x7fa1072ca1d8) at dispatcher.c:162
#9  0x00007fa10439d88e in red_worker_main (arg=<value optimized out>) at red_worker.c:11782
#10 0x00007fa105b5b851 in start_thread (arg=0x7fa0f5bfc700) at pthread_create.c:301
#11 0x00007fa103c1a90d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115
(gdb)
Comment 3 Xiaoqing Wei 2012-10-25 04:24:18 EDT
after bisect testing, this is a Regression since
qemu-kvm-0.12.1.2-2.324.el6.x86_64

should be introduced by:
Bug 860017 - [RFE] -spice- Add rendering support in order to improve spice performance
Comment 4 Xiaoqing Wei 2012-10-25 04:30:51 EDT
updating relavent packages here:
spice-server-0.12.0-1.el6.x86_64
vgabios-0.6b-3.6.el6.noarch
Comment 6 Xiaoqing Wei 2012-10-25 05:19:19 EDT
Found that this exists on Fedora rawhide too, cloned a Bug 869958 .
Comment 7 Xiaoqing Wei 2012-10-25 05:21:32 EDT
Hi,

I Found a similar one, Bug 867405 - core dump when starting qemu with spice and -S

If they are same, pls feel free to dup to that bug.

Thanks,
Xiaoqing.
Comment 8 Gerd Hoffmann 2012-10-29 03:56:27 EDT
Looks like a dup of bug 867405 indeed, but I leave that to the spice team to investigate in detail.
Comment 10 Marc-Andre Lureau 2012-11-15 12:46:03 EST

*** This bug has been marked as a duplicate of bug 867405 ***

Note You need to log in before you can comment on or make changes to this bug.