Bug 87 - aic7xxx driver V5.1 is buggy: scsi timeouts
Summary: aic7xxx driver V5.1 is buggy: scsi timeouts
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 5.2
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
: 386 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-16 12:51 UTC by bs
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-01-12 03:43:16 UTC


Attachments (Terms of Use)

Description bs 1998-11-16 12:51:39 UTC
Henry Stiles Email: henrys@meerkat.dimensional.com
in comp.os.linux.hardware says:

I am trying to install "stock" Redhat 5.2 on a Gateway 2000
Pentium II.  It has an Adaptec 294x ultra scsi host adapter
and some sort of IBM SCSI disk.  The disk drive and adapter
seem to be properly detected and I can get through almost
1/2 of the installation but then I get intermittant failures
with scsi error messages like:
"aborting command due to timeout:"
"scsi host 0 abort timed out resetting"
finally, the machine locks up.
The same machine ran Redhat 4.1 without any problems.

Me too, a Pentium II 300 with Adaptec 2940UW.

I tried to search in DejaNews, and I found some german
newsgroups with the same problem. They all say that the new
driver is buggy.

It would be nice to have a new boot image soon.

Regards,

Sandor Barany

Comment 1 Matt Wilson 1998-11-16 18:36:59 UTC
Problem is known, errata disks should be ready soon - msw

Comment 2 motyl 1998-11-22 18:18:59 UTC
I would like to add a comment about new Adaptec driver 5.1.3
introduced in 2.0.36pre14. It does not read SCSI EEPROM and
defaults to extended translation: ENABLED, what breaks lilo
and fdisk if disk was formatted with disabled extended translation
see
http://www.linuxhq.com/lnxlists/linux-scsi/ls_9811_03/msg00051.html

I have also noticed that the kernel-2.0.36-1.src.rpm should be
affected by this bug.

Comment 3 David Lawrence 1998-12-14 19:43:59 UTC
*** Bug 87 has been marked as a duplicate of this bug. ***
It is impossible to boot the 2.0.36 kernel from an Adaptec
AIC 7880 on-board UW SCSI chip.
This has prevented the installation of RH 5.2 on what was to
be my company's first official Linux server.
The bug is clearly in aicxxxx.o.

I have installed RH 5.0 with all errata including kernel
2.0.35 without any problem on this machine.
I installed the 2.0.36 kernel source and built a new kernel:
it won't boot. Same problem as when installing RH 5.2 :
command aborted due to time-out, SCSI bus resets, etc...

The newsgroups are overflowing with complaints about this,
but I have not seen an official RH response.

Can I make a boot diskette with a 2.0.35 kernel to
install/upgrade RH 5.2 ?

I have now manually installed/upgraded all RH 5.2 RPMS on
top of RH 5.0 and now the machine runs RH 5.2 with a 2.0.35
kernel, but it was rather tedious.

Danny Heijl.

Danny.Heijl@cevi.be
---

------- Additional Comments From Danny.Heijl@cevi.be  12/14/98 12:20 -------
I can make the 2.0.36 kernel boot by applying the aicxxx 5.1.2 to
5.1.3 and 5.1.3 to 5.1.4 patches (from your pub/aic directory) and
building and installing a new kernel.

The RH 5.2 CD/boot floppy install problem remains of course.

Comment 4 Matt Wilson 1998-12-14 20:29:59 UTC
Just to let everyone know - we're working to make new boot images and
install instructions to fix a variety of problems.  The images will be
ready as soon as possible.

Comment 5 Matt Wilson 1999-01-12 03:43:59 UTC
This was fixed in the errata bootdisk release earlier this month.


Note You need to log in before you can comment on or make changes to this bug.