Bug 870007 - lightdm-gtk-greeter crashes
lightdm-gtk-greeter crashes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lightdm-gtk (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-25 06:56 EDT by Matthias Runge
Modified: 2012-11-23 03:49 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 03:49:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Runge 2012-10-25 06:56:59 EDT
Description of problem:
/var/log/messages quickly fills with the following messages:
Oct 25 12:31:21 localhost kernel: [   50.164175] lightdm-gtk-gre[1912]: segfault at 3 ip 0000003ce2c1bde0 s
p 00007fff341ea660 error 4 in libgdk-3.so.0.600.1[3ce2c00000+7b000]
Oct 25 12:31:21 localhost abrt[1928]: Not saving repeating crash in '/usr/sbin/lightdm-gtk-greeter'
Oct 25 12:31:22 localhost kernel: [   51.680945] lightdm-gtk-gre[1946]: segfault at 3 ip 0000003ce2c1bde0 s
p 00007fff5b916430 error 4 in libgdk-3.so.0.600.1[3ce2c00000+7b000]
Oct 25 12:31:22 localhost abrt[1962]: Not saving repeating crash in '/usr/sbin/lightdm-gtk-greeter'
Oct 25 12:31:24 localhost kernel: [   53.163472] lightdm-gtk-gre[1971]: segfault at 3 ip 0000003ce2c1bde0 s
p 00007fff3528f4e0 error 4 in libgdk-3.so.0.600.1[3ce2c00000+7b000]
Oct 25 12:31:24 localhost abrt[1987]: Not saving repeating crash in '/usr/sbin/lightdm-gtk-greeter'
Oct 25 12:31:25 localhost kernel: [   54.662614] lightdm-gtk-gre[1996]: segfault at 3 ip 0000003ce2c1bde0 s
p 00007fff50720da0 error 4 in libgdk-3.so.0.600.1[3ce2c00000+7b000]
Oct 25 12:31:25 localhost abrt[2012]: Not saving repeating crash in '/usr/sbin/lightdm-gtk-greeter'
Oct 25 12:31:26 localhost dbus-daemon[425]: ** Message: No devices in use, exit
Oct 25 12:31:27 localhost kernel: [   56.178304] lightdm-gtk-gre[2021]: segfault at 3 ip 0000003ce2c1bde0 s
p 00007fffb6020ee0 error 4 in libgdk-3.so.0.600.1[3ce2c00000+7b000]
Oct 25 12:31:27 localhost abrt[2037]: Not saving repeating crash in '/usr/sbin/lightdm-gtk-greeter'
Oct 25 12:31:28 localhost kernel: [   57.649197] lightdm-gtk-gre[2046]: segfault at 3 ip 0000003ce2c1bde0 s
p 00007ffff2d1b1b0 error 4 in libgdk-3.so.0.600.1[3ce2c00000+7b000]
Oct 25 12:31:28 localhost abrt[2062]: Not saving repeating crash in '/usr/sbin/lightdm-gtk-greeter'
Oct 25 12:31:30 localhost kernel: [   59.189546] lightdm-gtk-gre[2071]: segfault at 3 ip 0000003ce2c1bde0 s
p 00007ffff478fdc0 error 4 in libgdk-3.so.0.600.1[3ce2c00000+7b000]
Oct 25 12:31:30 localhost abrt[2087]: Not saving repeating crash in '/usr/sbin/lightdm-gtk-greeter'
Oct 25 12:31:31 localhost kernel: [   60.673164] lightdm-gtk-gre[2096]: segfault at 3 ip 0000003ce2c1bde0 s
p 00007fff076de060 error 4 in libgdk-3.so.0.600.1[3ce2c00000+7b000]
Oct 25 12:31:31 localhost abrt[2112]: Not saving repeating crash in '/usr/sbin/lightdm-gtk-greeter'
Oct 25 12:31:33 localhost kernel: [   62.140345] lightdm-gtk-gre[2121]: segfault at 3 ip 0000003ce2c1bde0 s
p 00007fff54a9ad80 error 4 in libgdk-3.so.0.600.1[3ce2c00000+7b000]


Version-Release number of selected component (if applicable):
lightdm-1.4.0-1.fc18.x86_64
lightdm-gobject-1.4.0-1.fc18.x86_64
lightdm-gtk-1.3.1-1.fc18.x86_64


How reproducible:
100%

Steps to Reproduce:
1. start machine
2.
3.


I'd had a coredump there, if that helps.
Comment 1 Matthias Runge 2012-11-05 07:48:32 EST
Great, that is seems to be just me.

I've found some backtrace:
Gtk.py:1624:<module>:RuntimeError: Gtk couldn't be initialized

Traceback (most recent call last):
  File "/bin/firewall-config", line 22, in <module>
    from gi.repository import Gtk, GObject
  File "/usr/lib64/python2.7/site-packages/gi/importer.py", line 76, in load_mod
ule
    dynamic_module._load()
  File "/usr/lib64/python2.7/site-packages/gi/module.py", line 244, in _load
    overrides_modules = __import__('gi.overrides', fromlist=[self._namespace])
  File "/usr/lib64/python2.7/site-packages/gi/overrides/Gtk.py", line 1624, in <
module>
    raise RuntimeError("Gtk couldn't be initialized")
RuntimeError: Gtk couldn't be initialized

Local variables in innermost frame:
Box: None
_callable: None
Container: None
LinkButton: None
SizeGroup: None
HScrollbar: None


When using gdm as login manager, the system works as expected.
Comment 2 Rex Dieter 2012-11-05 07:55:44 EST
any abrt report and/or backtrace could help...
Comment 3 Matthias Runge 2012-11-05 08:03:12 EST
core dump:
http://www.matthias-runge.de/fedora/coredump
pyhook dir from abrt:
http://www.matthias-runge.de/fedora/pyhook.tar.gz
Comment 4 Rex Dieter 2012-11-05 08:16:01 EST
That looks more like a crash report for firewall-config, not lightdm.  ??
Comment 5 Matthias Runge 2012-11-06 02:35:40 EST
I'm very sorry, I must have mixed that up.

That dir containing the coredump etc. is here:
http://www.matthias-runge.de/fedora/ccpp.tar.gz

cat cmdline 
/usr/sbin/lightdm-gtk-greeter

cat package 
lightdm-gtk-1.3.1-1.fc18
Comment 6 Matthias Runge 2012-11-21 06:21:45 EST
I could this error reproduce in a kvm virtual machine, but not on real hardware.
Comment 7 Matthias Runge 2012-11-22 03:49:26 EST
Since I even can not reproduce this error in a freshly created vm, I'm closing this bug as notabug. Thanks
Comment 8 Matthias Runge 2012-11-23 03:49:53 EST
I could narrow this crash to this update.

https://admin.fedoraproject.org/updates/FEDORA-2012-16107/xorg-x11-drv-qxl-0.1.0-1.fc18

Downgrading to an earlier version fixed the issue.

Note You need to log in before you can comment on or make changes to this bug.