Bug 870026 - sometimes gdm does not start on boot
sometimes gdm does not start on boot
Status: CLOSED DUPLICATE of bug 870057
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
18
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-25 08:23 EDT by Jeff Bastian
Modified: 2012-10-25 10:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-25 10:32:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdm logs from /var/log/messages (10.34 KB, text/plain)
2012-10-25 08:24 EDT, Jeff Bastian
no flags Details
tar of Xorg logs (12.32 KB, application/octet-stream)
2012-10-25 08:34 EDT, Jeff Bastian
no flags Details

  None (edit)
Description Jeff Bastian 2012-10-25 08:23:48 EDT
Description of problem:
Sometimes gdm fails to start on boot and I'm left with a plain text screen showing the boot messages from the various services starting.

It's easily fixed by hitting CTRL-ALT-F2 and logging in as root and running
  systemctl restart gdm.service

It might be a timing issue with starting the X server.

[root@firefly ~]# systemctl status gdm.service
gdm.service - GNOME Display Manager
	  Loaded: loaded (/usr/lib/systemd/system/gdm.service; enabled)
	  Active: active (running) since Thu, 25 Oct 2012 07:05:12 -0500; 2min 36s ago
	Main PID: 754 (gdm-binary)
	  CGroup: name=systemd:/system/gdm.service
		  ├ 754 /usr/sbin/gdm-binary
		  └ 810 /usr/bin/Xorg :0 -background none -verbose -auth /...

Oct 25 07:05:21 firefly.localdomain gdm-binary[754]: WARNING: GdmDisplay: display lasted 0.174408 seconds
Oct 25 07:05:21 firefly.localdomain gdm[754]: gdm-binary[754]: WARNING: Unable to kill slave process
Oct 25 07:05:21 firefly.localdomain gdm[754]: gdm-binary[754]: WARNING: Child process 875 was already dead.
Oct 25 07:05:21 firefly.localdomain gdm[754]: gdm-binary[754]: WARNING: Unable to kill slave process
Oct 25 07:05:21 firefly.localdomain gdm[754]: gdm-binary[754]: WARNING: GdmDisplay: display lasted 0.174408 seconds
Oct 25 07:05:21 firefly.localdomain gdm-simple-slave[881]: WARNING: Child process 884 was already dead.
Oct 25 07:05:21 firefly.localdomain gdm[754]: gdm-binary[754]: WARNING: GdmDisplay: display lasted 0.056684 seconds
Oct 25 07:05:21 firefly.localdomain gdm-binary[754]: WARNING: GdmDisplay: display lasted 0.056684 seconds
Oct 25 07:05:21 firefly.localdomain gdm-binary[754]: WARNING: GdmLocalDisplayFactory: maximum number of X display failures reached: check X server log for errors
Oct 25 07:05:21 firefly.localdomain gdm[754]: gdm-binary[754]: WARNING: GdmLocalDisplayFactory: maximum number of X display failures reached: check X server log for errors


Version-Release number of selected component (if applicable):
gdm-3.6.1-1.fc18.x86_64
systemd-194-1.fc18.x86_64
xorg-x11-server-Xorg-1.13.0-5.fc18.x86_64

How reproducible:
rarely, maybe 1 time in 10?

Steps to Reproduce:
1. boot the computer
  
Actual results:
gdm fails to start

Expected results:
presented with graphical login screen when boot finishes

Additional info:
I'm using a Lenovo T60 laptop with Intel graphics:
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
Comment 1 Jeff Bastian 2012-10-25 08:24:56 EDT
Created attachment 633293 [details]
gdm logs from /var/log/messages
Comment 2 Jeff Bastian 2012-10-25 08:31:33 EDT
I have a number of log files from Xorg from this morning's boot (Oct 25 07:05):

[root@firefly ~]# ls -latr /var/log/Xorg* | grep Oct.25
-rw-r--r--. 1 root root  9852 Oct 25 07:05 /var/log/Xorg.1.log
-rw-r--r--. 1 root root  9852 Oct 25 07:05 /var/log/Xorg.2.log
-rw-r--r--. 1 root root  9852 Oct 25 07:05 /var/log/Xorg.3.log
-rw-r--r--. 1 root root  9852 Oct 25 07:05 /var/log/Xorg.4.log
-rw-r--r--. 1 root root  9852 Oct 25 07:05 /var/log/Xorg.5.log
-rw-r--r--. 1 root root 27859 Oct 25 07:08 /var/log/Xorg.0.log.old
-rw-r--r--. 1 root root 30287 Oct 25 07:22 /var/log/Xorg.0.log


Servers 1 though 5 all ended with a seg fault:

[    42.860] (EE) Backtrace:
[    42.975] (EE) 0: /usr/bin/Xorg (xorg_backtrace+0x36) [0x46c326]
[    42.975] (EE) 1: /usr/bin/Xorg (0x400000+0x71c59) [0x471c59]
[    42.975] (EE) 2: /lib64/libpthread.so.0 (0x7f23c7785000+0xf000) [0x7f23c7794000]
[    42.975] (EE) 3: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f23c6949000+0x1335b) [0x7f23c695c35b]
[    42.975] (EE) 4: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f23c6949000+0x143d5) [0x7f23c695d3d5]
[    42.975] (EE) 5: /usr/bin/Xorg (xf86DeleteScreen+0x84) [0x4946a4]
[    42.976] (EE) 6: /usr/bin/Xorg (InitOutput+0xc37) [0x48daf7]
[    42.976] (EE) 7: /usr/bin/Xorg (0x400000+0x27e76) [0x427e76]
[    42.976] (EE) 8: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x7f23c6ee5a05]
[    42.976] (EE) 9: /usr/bin/Xorg (0x400000+0x2839d) [0x42839d]
[    42.976] (EE) 
[    42.976] (EE) Segmentation fault at address 0x60
[    42.976] 
Fatal server error:
[    42.976] Caught signal 11 (Segmentation fault). Server aborting
Comment 3 Jeff Bastian 2012-10-25 08:34:47 EDT
Created attachment 633295 [details]
tar of Xorg logs
Comment 4 Jeff Bastian 2012-10-25 09:36:37 EDT
I created a /etc/X11/xorg.conf.d/serverflags.conf with contents below so that abrt could capture a core dump from the X server:

Section "ServerFlags"
    Option "NoTrapSignals"
EndSection


I then restarted gdm repeatedly until the problem happened again
  systemctl restart gdm.service


After about 20 restarts, the X server crashed on gdm start.  With debuginfo installed, the backtrace looks like:

[root@firefly ~]# gdb /usr/bin/Xorg /var/spool/abrt/ccpp-2012-10-25-08\:20\:44-7444/coredump 
...
(gdb) bt full
#0  list_is_empty (head=<optimized out>) at intel_list.h:269
No locals.
#1  intel_mode_fini (intel=intel@entry=0x26b1c10) at intel_display.c:1774
        mode = 0x0
#2  0x00007f2bc31de3d5 in I830FreeScreen (arg=0x26b0e80) at intel_driver.c:1077
        scrn = 0x26b0e80
        intel = 0x26b1c10
#3  0x00000000004946a4 in xf86DeleteScreen (pScrn=0x26b0e80)
    at xf86Helper.c:237
        i = <optimized out>
        scrnIndex = 0
        is_gpu = 0
#4  0x000000000048daf7 in InitOutput (
    pScreenInfo=pScreenInfo@entry=0x81a780 <screenInfo>, argc=argc@entry=12, 
    argv=argv@entry=0x7fff61c3d588) at xf86Init.c:606
        i = -1
        j = <optimized out>
        k = <optimized out>
        scr_index = <optimized out>
        modulelist = <optimized out>
        optionlist = 0x26a1fa0
        screenpix24 = <optimized out>
        pix24 = <optimized out>
        pix24From = X_DEFAULT
        pix24Fail = 0
        autoconfig = <optimized out>
        sigio_blocked = 0
        configured_device = <optimized out>
#5  0x0000000000427e76 in main (argc=12, argv=0x7fff61c3d588, 
    envp=<optimized out>) at main.c:204
        i = <optimized out>
        alwaysCheckForInput = {0, 1}
Comment 5 Jeff Bastian 2012-10-25 09:43:52 EDT
I reported the X crash using abrt-gui and it opened
  https://bugzilla.redhat.com/show_bug.cgi?id=870057
Comment 6 Ray Strode [halfline] 2012-10-25 10:32:28 EDT
okay let's dupe this. Thanks for the investigative work.

*** This bug has been marked as a duplicate of bug 870057 ***

Note You need to log in before you can comment on or make changes to this bug.