Bug 870042 - (i686) Rawhide kernel fails to boot on Rawhide qemu: hangs at: ..TIMER:/smpboot:...
(i686) Rawhide kernel fails to boot on Rawhide qemu: hangs at: ..TIMER:/smpbo...
Status: CLOSED DUPLICATE of bug 744426
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-25 09:18 EDT by Richard W.M. Jones
Modified: 2013-01-09 07:10 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-01 21:51:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2012-10-25 09:18:07 EDT
Description of problem:

libguestfs: libvirt XML:\n<?xml version="1.0"?>\n<domain type="qemu" xmlns:qemu="http://libvirt.org/schemas/domain/qemu/1.0">\n  <name>guestfs-h082cpd6wbbgkm0x</name>\n  <memory unit="MiB">500</memory>\n  <currentMemory unit="MiB">500</currentMemory>\n  <cpu mode="host-model">\n    <model fallback="allow"/>\n  </cpu>\n  <vcpu>1</vcpu>\n  <clock offset="utc"/>\n  <os>\n    <type>hvm</type>\n    <kernel>/home/rjones/d/libguestfs/tmp/.guestfs-1000/kernel.9831</kernel>\n    <initrd>/home/rjones/d/libguestfs/tmp/.guestfs-1000/initrd.9831</initrd>\n    <cmdline>panic=1 console=ttyS0 udevtimeout=600 no_timer_check acpi=off printk.time=1 cgroup_disable=memory root=/dev/sdb selinux=0 guestfs_verbose=1 TERM=xterm </cmdline>\n  </os>\n  <on_reboot>destroy</on_reboot>\n  <devices>\n    <controller type="scsi" index="0" model="virtio-scsi"/>\n    <disk device="disk" type="file">\n      <source file="/tmp/libguestfs-test-tool-sda-24R00N"/>\n      <target dev="sda" bus="scsi"/>\n      <driver name="qemu" type="raw"/>\n      <address type="drive" controller="0" bus="0" target="0" unit="0"/>\n    </disk>\n    <disk type="file" device="disk">\n      <source file="/home/rjones/d/libguestfs/tmp/libguestfshKqZAD/snapshot1"/>\n      <target dev="sdb" bus="scsi"/>\n      <driver name="qemu" type="qcow2" cache="unsafe"/>\n      <address type="drive" controller="0" bus="0" target="1" unit="0"/>\n      <shareable/>\n    </disk>\n    <serial type="unix">\n      <source mode="connect" path="/home/rjones/d/libguestfs/tmp/libguestfshKqZAD/console.sock"/>\n      <target port="0"/>\n    </serial>\n    <channel type="unix">\n      <source mode="connect" path="/home/rjones/d/libguestfs/tmp/libguestfshKqZAD/guestfsd.sock"/>\n      <target type="virtio" name="org.libguestfs.channel.0"/>\n    </channel>\n  </devices>\n  <qemu:commandline>\n    <qemu:env name="TMPDIR" value="/home/rjones/d/libguestfs/tmp"/>\n  </qemu:commandline>\n</domain>\n
libguestfs: [01584ms] launch libvirt guest
libguestfs: accept_from_daemon: 0x8167b00 g->state = 1
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Linux version 3.7.0-0.rc2.git1.2.fc19.i686.PAE (mockbuild@) (gcc version 4.7.2 20121015 (Red Hat 4.7.2-6) (GCC) ) #1 SMP Tue Oct 23 20:11:04 UTC 2012
[    0.000000] e820: BIOS-provided physical RAM map:
[    0.000000] BIOS-e820: [mem 0x0000000000000000-0x000000000009fbff] usable
[    0.000000] BIOS-e820: [mem 0x000000000009fc00-0x000000000009ffff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000000f0000-0x00000000000fffff] reserved
[    0.000000] BIOS-e820: [mem 0x0000000000100000-0x000000001f3fffff] usable
[    0.000000] BIOS-e820: [mem 0x00000000fffc0000-0x00000000ffffffff] reserved
[    0.000000] NX (Execute Disable) protection: active
[    0.000000] DMI 2.4 present.
[    0.000000] e820: last_pfn = 0x1f400 max_arch_pfn = 0x1000000
[    0.000000] x86 PAT enabled: cpu 0, old 0x7040600070406, new 0x7010600070106
[    0.000000] found SMP MP-table at [mem 0x000fdaf0-0x000fdaff] mapped at [c00fdaf0]
[    0.000000] init_memory_mapping: [mem 0x00000000-0x1f3fffff]
[    0.000000] RAMDISK: [mem 0x1f2e5000-0x1f3effff]
[    0.000000] 0MB HIGHMEM available.
[    0.000000] 500MB LOWMEM available.
[    0.000000]   mapped low ram: 0 - 1f400000
[    0.000000]   low ram: 0 - 1f400000
[    0.000000] Zone ranges:
[    0.000000]   DMA      [mem 0x00010000-0x00ffffff]
[    0.000000]   Normal   [mem 0x01000000-0x1f3fffff]
[    0.000000]   HighMem  empty
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00010000-0x0009efff]
[    0.000000]   node   0: [mem 0x00100000-0x1f3fffff]
[    0.000000] Using APIC driver default
[    0.000000] SFI: Simple Firmware Interface v0.81 http://simplefirmware.org
[    0.000000] Intel MultiProcessor Specification v1.4
[    0.000000]     Virtual Wire compatibility mode.
[    0.000000] MPTABLE: OEM ID: BOCHSCPU
[    0.000000] MPTABLE: Product ID: 0.1         
[    0.000000] MPTABLE: APIC at: 0xFEE00000
[    0.000000] Processor #0 (Bootup-CPU)
[    0.000000] IOAPIC[0]: apic_id 0 already used, trying 1
[    0.000000] IOAPIC[0]: apic_id 1, version 17, address 0xfec00000, GSI 0-23
[    0.000000] Processors: 1
[    0.000000] smpboot: Allowing 1 CPUs, 0 hotplug CPUs
[    0.000000] PM: Registered nosave memory: 000000000009f000 - 00000000000a0000
[    0.000000] PM: Registered nosave memory: 00000000000a0000 - 00000000000f0000
[    0.000000] PM: Registered nosave memory: 00000000000f0000 - 0000000000100000
[    0.000000] e820: [mem 0x1f400000-0xfffbffff] available for PCI devices
[    0.000000] Booting paravirtualized kernel on bare hardware
[    0.000000] setup_percpu: NR_CPUS:32 nr_cpumask_bits:32 nr_cpu_ids:1 nr_node_ids:1
[    0.000000] PERCPU: Embedded 335 pages/cpu @dedae000 s1347968 r0 d24192 u1372160
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 126887
[    0.000000] Kernel command line: panic=1 console=ttyS0 udevtimeout=600 no_timer_check acpi=off printk.time=1 cgroup_disable=memory root=/dev/sdb selinux=0 guestfs_verbose=1 TERM=xterm 
[    0.000000] Disabling memory control group subsystem
[    0.000000] PID hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
[    0.000000] Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.000000] __ex_table already sorted, skipping sort
[    0.000000] Initializing CPU#0
[    0.000000] Initializing HighMem for node 0 (00000000:00000000)
[    0.000000] Memory: 486200k/512000k available (6369k kernel code, 25348k reserved, 2990k data, 2064k init, 0k highmem)
[    0.000000] virtual kernel memory layout:
[    0.000000]     fixmap  : 0xffa96000 - 0xfffff000   (5540 kB)
[    0.000000]     pkmap   : 0xff600000 - 0xff800000   (2048 kB)
[    0.000000]     vmalloc : 0xdfc00000 - 0xff5fe000   ( 505 MB)
[    0.000000]     lowmem  : 0xc0000000 - 0xdf400000   ( 500 MB)
[    0.000000]       .init : 0xc0d24000 - 0xc0f28000   (2064 kB)
[    0.000000]       .data : 0xc0a38603 - 0xc0d23e40   (2990 kB)
[    0.000000]       .text : 0xc0400000 - 0xc0a38603   (6369 kB)
[    0.000000] Checking if this processor honours the WP bit even in supervisor mode...Ok.
[    0.000000] SLUB: Genslabs=15, HWalign=128, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] Hierarchical RCU implementation.
[    0.000000] \tRCU lockdep checking is enabled.
[    0.000000] \tRCU restricting CPUs from NR_CPUS=32 to nr_cpu_ids=1.
[    0.000000] NR_IRQS:2304 nr_irqs:256 16
[    0.000000] Console: colour *CGA 80x25
[    0.000000] console [ttyS0] enabled
[    0.000000] Lock dependency validator: Copyright (c) 2006 Red Hat, Inc., Ingo Molnar
[    0.000000] ... MAX_LOCKDEP_SUBCLASSES:  8
[    0.000000] ... MAX_LOCK_DEPTH:          48
[    0.000000] ... MAX_LOCKDEP_KEYS:        8191
[    0.000000] ... CLASSHASH_SIZE:          4096
[    0.000000] ... MAX_LOCKDEP_ENTRIES:     16384
[    0.000000] ... MAX_LOCKDEP_CHAINS:      32768
[    0.000000] ... CHAINHASH_SIZE:          16384
[    0.000000]  memory used by lock dependency info: 3823 kB
[    0.000000]  per task-struct memory footprint: 1920 bytes
[    0.000000] kmemleak: Kernel memory leak detector disabled
[    0.000000] tsc: Fast TSC calibration failed
[    0.000000] tsc: Unable to calibrate against PIT
[    0.000000] tsc: No reference (HPET/PMTIMER) available
[    0.000000] tsc: Marking TSC unstable due to could not calculate TSC khz
[    0.019000] Calibrating delay loop... 62.08 BogoMIPS (lpj=31040)
[    0.049000] pid_max: default: 32768 minimum: 301
[    0.085000] Security Framework initialized
[    0.087000] SELinux:  Disabled at boot.
[    0.132000] Mount-cache hash table entries: 512
[    0.347000] Initializing cgroup subsys cpuacct
[    0.349000] Initializing cgroup subsys memory
[    0.368000] Initializing cgroup subsys devices
[    0.371000] Initializing cgroup subsys freezer
[    0.374000] Initializing cgroup subsys net_cls
[    0.378000] Initializing cgroup subsys blkio
[    0.381000] Initializing cgroup subsys perf_event
[    0.412000] mce: CPU supports 10 MCE banks
[    0.422000] Last level iTLB entries: 4KB 0, 2MB 0, 4MB 0
[    0.422000] Last level dTLB entries: 4KB 0, 2MB 0, 4MB 0
[    0.422000] tlb_flushall_shift: 6
[    0.919000] Freeing SMP alternatives: 20k freed
[    0.980000] ftrace: allocating 23453 entries in 46 pages
[    1.597000] Enabling APIC mode:  Flat.  Using 1 I/O APICs
[    1.601000] ------------[ cut here ]------------
[    1.603000] WARNING: at arch/x86/kernel/apic/apic.c:1337 setup_local_APIC+0x2c3/0x3d6()
[    1.604000] Hardware name: Bochs
[    1.606000] Modules linked in:
[    1.609000] Pid: 1, comm: swapper/0 Not tainted 3.7.0-0.rc2.git1.2.fc19.i686.PAE #1
[    1.612000] Call Trace:
[    1.615000]  [<c0456082>] warn_slowpath_common+0x72/0xa0
[    1.618000]  [<c0a1e1aa>] ? setup_local_APIC+0x2c3/0x3d6
[    1.619000]  [<c0a1e1aa>] ? setup_local_APIC+0x2c3/0x3d6
[    1.621000]  [<c04560d2>] warn_slowpath_null+0x22/0x30
[    1.622000]  [<c0a1e1aa>] setup_local_APIC+0x2c3/0x3d6
[    1.623000]  [<c0a2f920>] ? restore_all+0xf/0xf
[    1.623000]  [<c0d32fd3>] native_smp_prepare_cpus+0x244/0x30d
[    1.624000]  [<c0a0a1e9>] kernel_init+0x79/0x2b0
[    1.625000]  [<c048eeb0>] ? schedule_tail+0x20/0xa0
[    1.626000]  [<c0a371b7>] ret_from_kernel_thread+0x1b/0x28
[    1.627000]  [<c0a0a170>] ? rest_init+0x130/0x130
[    1.631000] ---[ end trace 4f1f864c83491174 ]---
[    1.635000] ..TIMER: vector=0x41 apic1=-1 pin1=2 apic2=-1 pin2=-1
[    1.635000] smpboot: CPU0: Intel Common KVM processor (fam: 0f, model: 06, stepping: 01)

(and then hangs forever)

Version-Release number of selected component (if applicable):

qemu-1.2.0-16.fc19.i686
kernel-3.7.0-0.rc2.git1.2.fc19.i686

How reproducible:

100%

Steps to Reproduce:
1. Run 'make quickcheck' in libguestfs.

Additional info:

Likely to be a kernel bug actually.

However it does yet again show how much we need the qemu and
kernel packages to include a %check that one boots on the other,
and which gates everything that goes into Fedora.
Comment 1 Marcelo Tosatti 2012-11-01 21:51:03 EDT

*** This bug has been marked as a duplicate of bug 744426 ***

Note You need to log in before you can comment on or make changes to this bug.