Bug 870066 - [rhevm] Logging Error “Try to add duplicate values with same name” during import VM from Export Domain
[rhevm] Logging Error “Try to add duplicate values with same name” during imp...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity medium
: ---
: 3.2.0
Assigned To: Tal Nisan
vvyazmin@redhat.com
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-25 10:05 EDT by vvyazmin@redhat.com
Modified: 2016-02-10 14:32 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
## Logs rhevm (1.03 MB, application/octet-stream)
2012-10-25 10:05 EDT, vvyazmin@redhat.com
no flags Details

  None (edit)
Description vvyazmin@redhat.com 2012-10-25 10:05:22 EDT
Created attachment 633339 [details]
## Logs rhevm

Description of problem:
Get an error “Try to add duplicate values with same name” during import VM from Export Domain. 

Version-Release number of selected component (if applicable):
RHEVM 3.1 - SI22

RHEVM: rhevm-3.1.0-22.el6ev.noarch
VDSM: vdsm-4.9.6-39.0.el6_3.x86_64
LIBVIRT: libvirt-0.9.10-21.el6_3.5.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.295.el6_3.2.x86_64
SANLOCK: sanlock-2.3-4.el6_3.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create a new DC
2. Import Export Domain
3. Import VM from Export Domain
  
Actual results:
Action succeed import VM but in engine.log get en error “Try to add duplicate values with same name. Ty
pe: UNASSIGNED. Value: vmname”

Expected results:
No Error in RHEVM logs

Additional info:

2012-10-25 14:25:04,917 INFO  [org.ovirt.engine.core.bll.ImportVmCommand] (pool-4-thread-48) [3436a463] Running command: ImportVmCommand internal: false. Entities affected :  ID
: 8f81428c-612d-4f01-a834-aa7fff4e9485 Type: Storage
2012-10-25 14:25:04,933 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (pool-4-thread-48) [3436a463] Try to add duplicate values with same name. Ty
pe: UNASSIGNED. Value: vmname
2012-10-25 14:25:04,976 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.GetVmsInfoVDSCommand] (ajp-/127.0.0.1:8702-2) START, GetVmsInfoVDSCommand( storagePoolId = 7455040b-1fe6
-4434-95a4-57cab522d76e, ignoreFailoverLimit = false, compatabilityVersion = null, storageDomainId = 27fedd2e-d04e-4a16-a9f7-714f2931e6d3, vmIdList = null), log id: 6c34d764
2012-10-25 14:25:05,041 INFO  [org.ovirt.engine.core.bll.MoveOrCopyImageGroupCommand] (pool-4-thread-48) [4236c2cc] Running command: MoveOrCopyImageGroupCommand internal: true. 
Entities affected :  ID: 8f81428c-612d-4f01-a834-aa7fff4e9485 Type: Storage
2012-10-25 14:25:05,052 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.GetVmsInfoVDSCommand] (ajp-/127.0.0.1:8702-2) FINISH, GetVmsInfoVDSCommand, log id: 6c34d764
2012-10-25 14:25:05,057 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.CopyImageVDSCommand] (pool-4-thread-48) [4236c2cc] START, CopyImageVDSCommand( storagePoolId = 7455040b-1fe6-4434-95a4-57cab522d76e, ignoreFailoverLimit = false, compatabilityVersion = 3.1, storageDomainId = 27fedd2e-d04e-4a16-a9f7-714f2931e6d3, imageGroupId = 853af9ba-490c-42c5-a829-9f680de65cef, imageId = 37f44a08-3890-4d36-8db0-1d2c409ca1b5, dstImageGroupId = 853af9ba-490c-42c5-a829-9f680de65cef, vmId = 4cbe0842-3e91-4195-8b23-a20e1e2d811c, dstImageId = 37f44a08-3890-4d36-8db0-1d2c409ca1b5, imageDescription = , dstStorageDomainId = 8f81428c-612d-4f01-a834-aa7fff4e9485, copyVolumeType = LeafVol, volumeFormat = COW, preallocate = Sparse, postZero = false, force = true), log id: 6e28da43
2012-10-25 14:25:05,057 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.CopyImageVDSCommand] (pool-4-thread-48) [4236c2cc] -- CopyImageVDSCommand::ExecuteIrsBrokerCommand: calling 'copyImage' with two new parameters: description and UUID
2012-10-25 14:25:05,057 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.CopyImageVDSCommand] (pool-4-thread-48) [4236c2cc] -- copyImage parameters:
                sdUUID=27fedd2e-d04e-4a16-a9f7-714f2931e6d3
                spUUID=7455040b-1fe6-4434-95a4-57cab522d76e
                vmGUID=4cbe0842-3e91-4195-8b23-a20e1e2d811c
                srcImageGUID=853af9ba-490c-42c5-a829-9f680de65cef
                srcVolUUID=37f44a08-3890-4d36-8db0-1d2c409ca1b5
                dstImageGUID=853af9ba-490c-42c5-a829-9f680de65cef
                dstVolUUID=37f44a08-3890-4d36-8db0-1d2c409ca1b5
                descr=
                
2012-10-25 14:25:05,760 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.CopyImageVDSCommand] (pool-4-thread-48) [4236c2cc] FINISH, CopyImageVDSCommand, return: 00000000-0000-0000-0000-000000000000, log id: 6e28da43
2012-10-25 14:25:05,857 INFO  [org.ovirt.engine.core.bll.EntityAsyncTask] (pool-4-thread-48) [4236c2cc] EntityAsyncTask::Adding EntityMultiAsyncTasks object for entity 37f44a08-3890-4d36-8db0-1d2c409ca1b5
2012-10-25 14:25:05,857 INFO  [org.ovirt.engine.core.bll.EntityMultiAsyncTasks] (pool-4-thread-48) [4236c2cc] EntityMultiAsyncTasks::AttachTask: Attaching task 84f30941-31f3-4752-800a-f68547125b16 to entity 37f44a08-3890-4d36-8db0-1d2c409ca1b5.
Comment 1 vvyazmin@redhat.com 2012-10-25 10:55:47 EDT
Please add a line number in code, where this function is failed.
Comment 3 vvyazmin@redhat.com 2012-11-11 03:44:03 EST
IMHO, look like same scenario.
Comment 4 Tal Nisan 2012-12-30 16:02:50 EST
Couldn't reproduced what so ever, the ImportVmCommand went through massive cleanups a few weeks ago so it probably fixed the redundant log
The cleanup patches for reference:
http://gerrit.ovirt.org/#/c/9614/
http://gerrit.ovirt.org/#/c/9613
http://gerrit.ovirt.org/#/c/9615
http://gerrit.ovirt.org/#/c/9616
http://gerrit.ovirt.org/#/c/9620
http://gerrit.ovirt.org/#/c/9621
http://gerrit.ovirt.org/#/c/9622
http://gerrit.ovirt.org/#/c/9623
http://gerrit.ovirt.org/#/c/9611
Comment 5 vvyazmin@redhat.com 2013-01-09 07:48:15 EST
No issues are found

Verified on RHEVM 3.2 - SF03 environment 

RHEVM: rhevm-3.2.0-4.el6ev.noarch
VDSM: vdsm-4.10.2-3.0.el6ev.x86_64
LIBVIRT: libvirt-0.10.2-13.el6.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.348.el6.x86_64
SANLOCK: sanlock-2.6-2.el6.x86_64
Comment 6 Itamar Heim 2013-06-11 05:22:01 EDT
3.2 has been released
Comment 7 Itamar Heim 2013-06-11 05:44:17 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.